Επιλογή Σελίδας

Θέμα A, Ερώτημα 1, 2001, Ημερήσια, Μαΐου-Ιουνίου

Να μεταφέρετε στο τετράδιό σας και να συμπληρώσετε τον παρακάτω πίνακα αλήθειας Δύο προτάσεων Α, Β και των τριών λογικών πράξεων.

Πρόταση Α Πρόταση Β Α ή Β

(Διάζευξη)

Α και Β

(Σύζευξη)

όχι Α

(Άρνηση)

Ψευδής Ψευδής
Ψευδής Αληθής
Αληθής Ψευδής
Αληθής Αληθής

Μονάδες 6
ΛΥΣΗ: (περισσότερα…)

Θέμα A, Ερώτημα 2, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνεται η δομή επανάληψης.

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

Να μετατρέψετε την παραπάνω δομή σε ισοδύναμη δομή επανάληψης Όσο … επανάλαβε.

Σημείωση: Αντί του Όσο … επανάλαβε μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε. Επίσης αντί του:

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

μπορεί ισοδύναμα να χρησιμοποιηθεί το:

για i:= τιμή1 μέχρι τιμή2 μεταβολή β κάνε

Εντολές

τέλοςγια

Μονάδες 9

ΛΥΣΗ:  (περισσότερα…)

Θέμα A, Ερώτημα 3, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνονται οι παρακάτω έννοιες:

  1. Λογικός τύπος δεδομένων
  2. Επιλύσιμο
  3. Ακέραιος τύπος δεδομένων
  4. Περατότητα
  5. Μεταβλητή
  6. Ημιδομημένο
  7. Πραγματικός τύπος δεδομένων
  8. Σταθερά
  9. Αδόμητο
  10. Καθοριστικότητα
  11. Άλυτο
  12. Ανοικτό

Να γράψετε στο τετράδιό σας ποιες από τις παραπάνω έννοιες:

α.   είναι στοιχεία μιας γλώσσας προγραμματισμού;  Μονάδες 5

β.   ανήκουν σε κατηγορίες προβλημάτων;  Μονάδες 5

ΛΥΣΗ: (περισσότερα…)

Θέμα A, Ερώτημα 4, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνεται μονοδιάστατος πίνακας Π, Ν στοιχείων, που είναι ακέραιοι αριθμοί. Να αναπτύξετε αλγόριθμο, ο οποίος να ταξινομεί με τη μέθοδο της φυσαλίδας τα στοιχεία του πίνακα Π.

Μονάδες 15

ΛΥΣΗ:  (περισσότερα…)

Θέμα Β, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνεται το παρακάτω τμήμα αλγορίθμου.
 
 Χ <-- 1
 Όσο Χ<5 επανάλαβε
 Α <-- Χ+2
 Β <-- 3*Α-4
 C <-- Β-Α+4
 Αν Α > Β τότε
    Αν Α > C τότε 
       MAX <-- A
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 αλλιώς
    Αν Β > C τότε 
       MAX <-- Β
    αλλιώς
       MAX <-- C
    Τέλος_αν 
 Τέλος_αν
 Εμφάνισε Χ, Α, Β, C, MAX
 Χ <-- Χ+2
 Τέλος_επανάληψης

 Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου;

Μονάδες 20

Σημείωση: Αντί του συμβόλου (<-) μπορεί ισοδύναμα να χρησιμοποιηθεί το σύμβολο (: =) ή το (=). Επίσης αντί του Όσο … επανάλαβε … Τέλος επανάληψης μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε … τέλοςόσο και αντί του Τέλος_αν μπορεί ισοδύναμα να χρησιμοποιηθεί το τέλοςαν.

ΛΥΣΗ: (περισσότερα…)

Θέμα Γ, 2001, Ημερήσια, Μαΐου-Ιουνίου

Δίνεται πίνακας Π δύο διαστάσεων, που τα στοιχεία του είναι ακέραιοι αριθμοί µε Ν γραμμές και Μ στήλες. Να αναπτύξετε αλγόριθμο που να υπολογίζει το ελάχιστο στοιχείο του πίνακα.

Μονάδες 20

ΛΥΣΗ:  (περισσότερα…)

Θέμα Δ, 2001, Ημερήσια, Μαΐου-Ιουνίου

Σε ένα πρόγραμμα περιβαλλοντικής εκπαίδευσης συμμετέχουν 20 σχολεία. Στα πλαίσια αυτού του προγράμματος, εθελοντές μαθητές των σχολείων, που συμμετέχουν στο πρόγραμμα, μαζεύουν ποσότητες τριών υλικών (γυαλί, χαρτί και αλουμίνιο).

Να αναπτύξετε έναν αλγόριθμο, ο οποίος:
α.   να διαβάζει τις ποσότητες σε κιλά των παραπάνω υλικών που μάζεψαν οι μαθητές σε κάθε σχολείο
Μονάδες 4

β.    να υπολογίζει τη συνολική ποσότητα σε κιλά του κάθε υλικού που μάζεψαν οι μαθητές σε όλα τα σχολεία
Μονάδες 8

γ. αν η συνολική ποσότητα του χαρτιού που μαζεύτηκε από όλα τα σχολεία είναι λιγότερη των 1000 κιλών, να εμφανίζεται το μήνυμα «Συγχαρητήρια». Αν η ποσότητα είναι από 1000 κιλά και πάνω, αλλά λιγότερο από 2000, να εμφανίζεται το μήνυμα «Δίνεται έπαινος» και τέλος αν η ποσότητα είναι από 2000 κιλά και πάνω να εμφανίζεται το μήνυμα «Δίνεται βραβείο».
Μονάδες 8

Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες είναι θετικοί αριθμοί.

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2001, Ημερήσια, Επαναληπτικές

Να γράψετε στο τετράδιο σας, ποιες από τις παρακάτω εντολές εκχώρησης είναι συντακτικά σωστές και ποιες λάθος.
α. 2* Α  <- Α
β. Α <- 3*Α + 5
γ. Β + 5 <- «Α»

Μονάδες 3

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 2, 2001, Ημερήσια, Επαναληπτικές

Για τις απλές αριθμητικές πράξεις:

α. να αναφερθούν οι αντίστοιχοι τελεστές

Μονάδες 2

β. να δοθεί η σειρά προτεραιότητας (ιεραρχία) των τελεστών αυτών στις αριθμητικές εκφράσεις.

Μονάδες 2

ΛΥΣΗ:  (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2001, Ημερήσια, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Χ <- Α
Αρχήεπανάληψης
Χ<-Χ+2
τύπωσε το Χ
μέχριςότου Χ >= Μ
α. Να δώσετε τη δομή επανάληψης «Για … από … μέχρι … βήμα» η οποία τυπώνει ακριβώς τις ίδιες τιμές με το πιο πάνω τμήμα αλγορίθμου.
Μονάδες 7
β. Τι θα τυπωθεί, αν Α = 4 και Μ = 9;
Μονάδες 3
γ. Τι θα τυπωθεί, αν Α = -5 και Μ = 0 ;
Μονάδες 3

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2001, Ημερήσια, Επαναληπτικές

Αντιστοιχίστε σωστά τις εκφράσεις της Στήλης Α με τις αλγοριθμικές έννοιες της Στήλης Β, γράφοντας στο τετράδιο σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β.

Στήλη Α Στήλη Β
Εκφράσεις Αλγοριθμικές έννοιες
1. Χ<-Χ*2 α. αριθμητική έκφραση (παράσταση)
2. 3 + Α>Β β. μεταβλητή
3. τύπωσε Β γ. λογική έκφραση (παράσταση)
4. όσο Κ < 3 επανάλαβε δ. δομή ακολουθίας
εντολές ε. δομή επανάληψης
τέλος _ επανάληψης στ. εντολή εκχώρησης
Χ – (Χ/2) * 2 ζ. εντολή εξόδου

Μονάδες 10

ΛΥΣΗ:  (περισσότερα…)