Επιλογή Σελίδας

ΔΤ2, Κεφάλαιο 8, Κωδικοποίηση εντολών σε φυσική γλώσσα

Να γράψεις τις εντολές για τα παρακάτω:
Α) Αν η Βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από το Μέσο όρο (ΜΟ), τότε να τυπώνει “Πολύ καλά”, αν είναι ίση ή μικρότερη του Μέσου όρου μέχρι και 2 μονάδες, να τυπώνει “Καλά”, και, όταν είναι μικρότερη του Μέσου όρου περισσότερο από 2 μονάδες, να τυπώνει “Μέτρια”.
Β) Αν το τμήμα (ΤΜΗΜΑ) είναι Γ1 και η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από 15, τότε να τυπώνει το επώνυμο (ΕΠΩΝΥΜΟ).
Γ) Αν η απάντηση (ΑΠΑΝΤΗΣΗ) δεν είναι Ν ή ν ή Ο ή ο, τότε να τυπώνει το μήνυμα “Λάθος απάντηση… ” .
Δ) Αν ο αριθμός Χ είναι αρνητικός ή το ΗΜ(Χ)=0, τότε να τυπώνεται το μήνυμα “Λάθος δεδομένα… ” , αλλιώς να υπολογίζεται η παράσταση (Χ^2+5Χ)/(Τ_Ρ(Χ)ΗΜ(Χ)).

ΛΥΣΗ (περισσότερα…)

ΔΤ4, Κεφάλαιο 8, Τμήμα προγράμματος, βρες τη λειτουργία, τον αριθμό επαναλήψεων, κάνε μετατροπή σε άλλες δομές

Έστω το παρακάτω τμήμα προγράμματος:

Κ <- 0 
ΓΙΑ Ι ΑΠΟ 0 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 5 
    Α <- Ι^3 
    Κ <- Κ+Α 
    ΓΡΑΨΕ Ι, Α 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Κ

Πόσες φορές θα εκτελεστεί ο βρόχος; Ποια η λειτουργία των εντολών; Γράψτε τις παραπάνω εντολές χρησιμοποιώντας την εντολή επανάληψης ΟΣΟ και την εντολή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. Ποιον από τους τρεις τρόπους προτιμάς και γιατί;

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Eρώτημα 5, 2015, Ημερήσια

α. Δίνονται οι παρακάτω προτάσεις σε φυσική γλώσσα:

  1. Αύξησε το Χ κατά 2.
  2. Εκχώρησε στο Υ τον μέσο όρο των Κ, Λ, Μ.
  3. Το τελευταίο ψηφίο του Α είναι
  4. Ο Β είναι διψήφιος.

Να θεωρήσετε ότι οι Α και Β είναι θετικοί ακέραιοι. Να γράψετε στο τετράδιό σας τον αριθμό της κάθε πρότασης και δίπλα την κωδικοποίησή της σε ΓΛΩΣΣΑ. (μονάδες 4)
β. Δίνεται το παρακάτω τμήμα αλγορίθμου:

 Διάβασε Χ 
 Αν Χ > 15 τότε
     Γράψε 1 
 αλλιώς_αν Χ > 23 τότε
     Γράψε 2 
 αλλιώς
     Γράψε 3 
 Τέλος_αν

Μια εντολή εξόδου στο παραπάνω τμήμα δεν πρόκειται να εκτελεστεί, όποια και αν είναι η τιμή του Χ.

  1. Ποια είναι η εντολή αυτή; (μονάδες 2)
  2. Να γράψετε τις εντολές εξόδου που είναι δυνατόν να εκτελεστούν και, δίπλα σε καθεμία από αυτές, το διάστημα τιμών του Χ για το οποίο θα εκτελεστεί η εντολή. (μονάδες 4)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.5.α.

  1. Χ ← Χ + 2

  2. Υ ← ( Κ + Λ + Μ ) /3

  3. Α mod 10 = 5

  4. B >= 10 KAI B < 100

A.5.β

  1. Η εντολή Γράψε 2

  2. Γράψε 1 για x > 15

Γράψε 3 για x <= 15

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα Α, Ερώτημα 5, 2015, Επαναληπτικές, Ημερήσια

Δίνονται οι παρακάτω αριθμητικές εκφράσεις σε ΓΛΩΣΣΑ:

  1. ((Α_Τ(x) – HM(θ))/(Τ_Ρ((x^2)+5)))
  2. (2*x+((3*(x + 1))/(y^2 + 1)) – Ε(x))

Λαμβάνοντας υπόψη την ιεραρχία των αριθμητικών πράξεων, να ξαναγράψετε τις εκφράσεις αυτές, παραλείποντας όλες τις παρενθέσεις που δεν είναι απαραίτητες.

Μονάδες 6

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα Β, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα Α, Ερώτημα 2, 2014, Επαναληπτικές, Ημερήσια

α.    Να δώσετε τον ορισμό της δομής ενός προβλήματος. (μονάδες 4)

β.   Να κάνετε τη διαγραμματική αναπαράσταση του προβλήματος «Αντιμετώπιση ναρκωτικών», που περιγράφεται παρακάτω:

Για την αντιμετώπιση του προβλήματος των ναρκωτικών, απαιτείται τόσο η πρόληψη όσο και η θεραπεία των εξαρτημένων ατόμων, ενώ σημαντικό ρόλο έχει και η διαδικασία επανένταξης των απεξαρτημένων ατόμων στην κοινωνία. Η πρόληψη περιλαμβάνει την ενημέρωση των πολιτών. Εξίσου σημαντική για την πρόληψη κρίνεται η ανάπτυξη ενδιαφερόντων για άτομα «αυξημένης προδιάθεσης». Στον τομέα της θεραπείας, εκτός από την ενίσχυση των υπαρχουσών θεραπευτικών κοινοτήτων, σκόπιμη είναι και η δημιουργία κατάλληλων τμημάτων στα δημόσια νοσοκομεία. Σημαντικοί παράγοντες για αποτελεσματική επανένταξη είναι τόσο η καταπολέμηση της κοινωνικής προκατάληψης, όσο και η επιδότηση θέσεων εργασίας για τους απεξαρτημένους πρώην χρήστες. (μονάδες 6)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2013, Επαναληπτικές, Ημερήσια

Να μετατραπεί το παρακάτω διάγραμμα ροής σε ισοδύναμο αλγόριθμο με ψευδογλώσσα.

themav2013epanhmer

Μονάδες 11

Β2. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παραπάνω αλγορίθμου.

Μονάδες 9

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Β, Ερώτημα 2,2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

er2th2-aepp_2012_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 4, 2013, Μαΐου-Ιουνίου, Ημερήσια

α. Δίνεται τετραγωνικός πίνακας Π[100,100] και το παρακάτω τμήμα αλγορίθμου σε ψευδογλώσσα:
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i<j τότε
Διάβασε Π[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου χωρίς τη χρήση της δομής επιλογής, έτσι ώστε να επιτελεί την ίδια λειτουργία (μονάδες 4).
β. Να μεταφέρετε στο τετράδιό σας το παρακάτω τμήμα αλγορίθμου, έχοντας συμπληρώσει τις γραμμές εντολών 2, και 3 ώστε να εμφανίζει πάντα το μεγαλύτερο από τους δυο αριθμούς που διαβάστηκαν:
1. Διάβασε Α, Β
2. Αν Α … Β τότε
3. ……………..
4. Τέλος_αν
5. Εμφάνισε Α (μονάδες 4)

Μονάδες 8

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10