Επιλογή Σελίδας

Παράδειγμα 1, Κεφάλαιο 8, Βιβλίο, Κλίμακα υπολογισμού τιμής Υπολογιστών

Στο πρόγραμμα του προηγούμενου κεφαλαίου (πωλήσεις υπολογιστών) υποθέτουμε ότι η τιμή των υπολογιστών εξαρτάται από την ποσότητα παραγγελίας. Συγκεκριμένα ισχύουν οι παρακάτω τιμές αγοράς υπολογιστών.

Ο υπολογισμός με χρήση εμφωλευμένων εντολών ΑΝ είναι:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ
  ΑΝ Ποσότητα<=100 ΤΟΤΕ 
     Κόστος <-- Ποσότητα*520 
  ΑΛΛΙΩΣ
     ΑΝ Ποσότητα<=200 ΤΟΤΕ 
        Κόστος <-- Ποσότητα*470 
     ΑΛΛΙΩΣ 
        Κόστος <-- Ποσότητα*440 
     ΤΕΛΟΣ_ΑΝ 
  ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΑΝ

Το ίδιο πρόγραμμα με τη χρήση της εντολής ΑΝ…ΤΟΤΕ…ΑΛΛΙΩΣ_ΑΝ έχει ως εξής:

ΑΝ Ποσότητα <= 50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=200 ΤΟΤΕ 
Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ 

Ένα συχνό λάθος που παρατηρείται στα προγράμματα είναι ο έλεγχος περιττών συνθηκών. Οι επιπλέον έλεγχοι αυξάνουν την πολυπλοκότητα του προγράμματος. Στο προηγούμενο παράδειγμα για το οποίο θεωρούμε ότι η ποσότητα είναι θετικός αριθμός, ένα παράδειγμα περιττών ελέγχων είναι το ακόλουθο:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 50 ΚΑΙ Ποσότητα <=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα>100 ΚΑΙ Ποσότητα <=200 ΤΟΤΕ
      Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
      Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ

Βλέπε επίσης: ΔΕ1, Κεφαλαίου 8

Παράδειγμα 2, Κεφάλαιο 8, Βιβλίο, Άθροισμα και Πλήθος αριθμών

Να γραφεί πρόγραμμα το οποίο διαβάζει από το πληκτρολόγιο μία σειρά μετρήσεων, ακεραίων μη μηδενικών αριθμών, υπολογίζει και τυπώνει το άθροισμά τους καθώς και το μέσο τους όρο. Ως τέλος της διαδικασίας εισαγωγής στοιχείων χρησιμοποιείται η τιμή 0.

ΠΡΟΓΡΑΜΜΑ Άθροισμα1  !Παρόραμα - ίδιο όνομα μεταβλητής
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ 
ΑΡΧΗ 
Πλήθος <--0 
Άθροισμα <-- 0 
ΓΡΑΨΕ 'Δώσε Αριθμό' 
ΔΙΑΒΑΣΕ Χ 
ΟΣΟ Χ<>0 ΕΠΑΝΑΛΑΒΕ 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Δώσε Αριθμό' 
    ΔΙΑΒΑΣΕ Χ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Πλήθος >0 ΤΟΤΕ  
   ΜΟ <-- Άθροισμα/Πλήθος 
   ΓΡΑΨΕ 'Το Άθροισμα είναι : ', Άθροισμα 
   ΓΡΑΨΕ 'Ο Μέσος όρος είναι : ', ΜΟ
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Δεν δόθηκαν στοιχεία' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παρατηρήσεις:

Η χρήση τιμών για τον τερματισμό μίας επαναληπτικής διαδικασίας, όπως στο παράδειγμα η αυθαίρετη επιλογή του 0, είναι συνήθης στον προγραμματισμό. Η τιμή αυτή ορίζεται από τον προγραμματιστή και αποτελεί μια σύμβαση για το τέλος του προγράμματος. Η τιμή αυτή είναι τέτοια, ώστε να μην είναι λογικά σωστή για το πρόβλημα, για παράδειγμα η τιμή 0 αποκλείεται από τις μετρήσεις σύμφωνα με την εκφώνηση του παραδείγματος. Η τιμή αυτή συχνά αποκαλείται «τιμή φρουρός«.

*Το όνομα του προγράμματος Άθροισμα (όπως υπάρχει στο βιβλίο) έχει το ίδιο όνομα με μεταβλητή που χρησιμοποιείται μέσα στο πρόγραμμα. (παρόραμα). Έγινε Άθροισμα1.

 

Παράδειγμα 3, Κεφάλαιο 8, Βιβλίο, Άθροισμα και Πλήθος αριθμών

Στο προηγούμενο παράδειγμα ας υποθέσουμε ότι οι μετρήσεις είναι υποχρεωτικά θετικοί αριθμοί και ότι μετά την εισαγωγή κάθε αριθμού υπάρχει η ερώτηση αν θα εισαγάγουμε άλλο. Η διαδικασία θα τελειώσει, όταν η απάντηση θα είναι Όχι (ο ή Ο).

ΠΡΟΓΡΑΜΜΑ Άθροισμα2 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ:Επιλογή 
ΑΡΧΗ 
Πλήθος <-- 0 
Άθροισμα <-- 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
       ! Έλεγχος δεδομένων 
       ΓΡΑΨΕ 'Δώσε Αριθμό' 
       ΔΙΑΒΑΣΕ Χ 
       ΑΝ Χ <= 0 ΤΟΤΕ 
          ΓΡΑΨΕ 'Λάθος Αριθμός, Παρακαλώ δώστε ξανά...' 
       ΤΕΛΟΣ_ΑΝ 
       ! Αν το X δεν είναι θετικό εισάγουμε νέο αριθμό 
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Νέα μέτρηση ;' 
    ΔΙΑΒΑΣΕ Επιλογή ! Αν η επιλογή είναι Ο ή ο τότε σταματάει η επανάληψη
ΜΕΧΡΙΣ_ΟΤΟΥ Επιλογή='Ο' Ή Επιλογή='ο' 
ΜΟ <-- Άθροισμα/Πλήθος 
ΓΡΑΨΕ 'Άθροισμα =' , Άθροισμα 
ΓΡΑΨΕ 'Μέσος όρος =', ΜΟ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Παράδειγμα 4, Κεφάλαιο 8, Βιβλίο, Άθροισμα Περιττών μέχρι το 100

Το παρακάτω πρόγραμμα υπολογίζει το άθροισμα των περιττών αριθμών που είναι μικρότεροι από το 100.

ΠΡΟΓΡΑΜΜΑ Περιττοί 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Άθροισμα, Αριθμός 
ΑΡΧΗ  
Άθροισμα <-- 0 
ΓΙΑ Αριθμός ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2   
    Άθροισμα <-- Άθροισμα + Αριθμός 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Άθροισμα περιττών αριθμών είναι: ', Άθροισμα 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 5, Κεφάλαιο 8, Βιβλίο, Προπαίδεια

Να γραφεί πρόγραμμα το οποίο να εκτυπώνει την προπαίδεια του πολλαπλασιασμού.

ΠΡΟΓΡΑΜΜΑ Προπαίδεια 
!Πρόγραμμα εκτύπωσης της προπαίδειας των αριθμών 1 έως 10 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Α, Β, Γ 
!A:Πολλαπλασιαστέος
!Β:Πολαπλασιαστής
!Γ:Γινόμενο
ΑΡΧΗ
ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10   
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
        Γ <- Α*Β
        ΓΡΑΨΕ A,'X',Β,'=',Γ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ  !Εισαγωγή κενής γραμμής στην εκτύπωση 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ