Επιλογή Σελίδας

Θέμα Α, Ερώτημα 3, 2016, Επαναληπτικές, Νέο

Δίνεται ο παρακάτω πίνακας                                                         

Εντολή Επανάληψης Καταλληλότητα Χρήσης
1.    Όσο … επανάλαβε

Τέλος_επανάληψης

α.   Γνωστός αριθμός επαναλήψεων
2.     Για … από … μέχρι … με βήμα …

Τέλος_επανάληψης

β.   Άγνωστος   αριθμός επαναλήψεων
3. Αρχή   επανάληψης …

μέχρις ότου …

γ. Άγνωστος   αριθμός επαναλήψεων, αλλά τουλάχιστον μία επανάληψη

Να   γράψετε στο τετράδιό σας τους αριθμούς της πρώτης στήλη και, δίπλα, το γράμμα της δεύτερης στήλης που αντιστοιχεί σωστά.

Μονάδες 6

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Δίνεται ο πίνακας αριθμών Χ[50], ταξινομημένος κατά φθίνουσα σειρά, και ο πίνακας Υ[100], ταξινομημένος κατά αύξουσα σειρά. Να θεωρήσετε ότι οι τιμές κάθε πίνακα είναι διαφορετικές μεταξύ τους και ότι οι δύο πίνακες δεν έχουν κοινές τιμές.

Το παρακάτω ημιτελές τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Ζ[10], ταξινομημένο σε φθίνουσα σειρά, με τις δέκα μεγαλύτερες τιμές από τις εκατόν πενήντα (150) τιμές των δύο πινάκων.

i <--(1)
j <-- (2)
Για k από 1 μέχρι 10
      Αν Χ[ i ] (3) Υ[ j ] τότε 
            Ζ[ k ] <-- Χ[ i ] 
            i <-- i (4) 1 
     Αλλιώς
            Ζ[ k ] <-- Υ[ j ] 
             j <-- j (5) 1 
    Τέλος_αν
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Για K από A μέχρι B μεβήμα Γ
       Εμφάνισε K
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας για καθεμία από τις παρακάτω περιπτώσεις τις τιμές των Α, Β, Γ, έτσι ώστε το αντίστοιχο τμήμα αλγορίθμου να εμφανίζει:

  1. όλους τους περιττούς ακεραίους από το 100 μέχρι το
  2. όλους τους ακεραίους από το -20 μέχρι και το 10 σε φθίνουσα σειρά.
  3. όλα τα πολλαπλάσια του 3 από το 1 μέχρι το 80.

Μονάδες 9

Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

  1. Α = 101, Β = 999, Γ = 2
  2. Α = 10, Β = -20, Γ = -1
  3. Α = 3, Β = 80, Γ = 3

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Παράδειγμα 6, Κεφάλαιο 2, Τετράδιο Εργασιών, Διοφαντική Ανάλυση

Να εκπονηθεί ένας αλγόριθμος για την εύρεση όλων των ακεραίων λύσεων της εξίσωσης:
3x + 2y – 7z = 5
για τιμές των x, y, z μεταξύ των 0 και 100. Η επίλυση τέτοιων εξισώσεων με πολλές μεταβλητές που επιδέχονται πολλές λύσεις ονομάζεται διοφαντική ανάλυση.

Λύση:  (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

aepp_2011_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 1, Θέμα Α, 2005, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Μια συνάρτηση υπολογίζει και επιστρέφει παραπάνω από μία τιμές με το όνομά της.
  2. Πολλαπλές επιλογές μπορούν να γίνουν και με μία εμφωλευμένη δομή.
  3. Στην επαναληπτική δομή Για … από … μέχρι … με_βήμα οι τιμές από, μέχρι και με_βήμα δεν είναι απαραίτητο να είναι ακέραιες.
  4. Ο πίνακας που χρησιμοποιεί ένα μόνο δείκτη για την αναφορά των στοιχείων του ονομάζεται μονοδιάστατoς.
  5. Η ΓΛΩΣΣΑ υποστηρίζει τρεις εντολές επανάληψης, την εντολή ΟΣΟ, την εντολή ΜΕΧΡΙΣ_ΟΤΟΥ και την εντολή ΓΙΑ.

Μονάδες 10

Τα θέματα σε pdf, 2005, Επαναληπτικές, Ημερήσια

Ερώτημα 4, Θέμα Α, 2004, Επαναληπτικές, Ημερήσια

Δίνεται η παρακάτω αλληλουχία εντολών:

Α <-x

Όσο A < = y επανάλαβε

A<- Α + z

Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας πόσες φορές εκτελείται η εντολή A <- Α + z για κάθε έναν από τους παρακάτω συνδυασμούς των τιμών των μεταβλητών x, y και z:

1.   x = 0 y = 8 z = 3
2.   x = 7 y = 10 z = 5
3.   x = -10 y = -5 z = -1
4.   x = 10 y = 5 z = 2

Μονάδες 8

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια

Θέμα B, 2004, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Αριθμοί_ΜΕΡΣΕΝ

Διάβασε Α

B<-4

C<-2

Αρχή_επανάληψης

Β<-(Β^2) – 2

      Εμφάνισε Β

C<- C + 1

Μέχρις_ότου C > (Α – 1)

D <- (2^Α) – 1

Ε<-Β ΜΟD D

Εμφάνισε D

Αν Ε = 0 τότε

F <- (2^(C – 1)) * D

      Εμφάνισε «Τέλειος αριθμός:», F

G<- 0

      Όσο F > 0 επανάλαβε

              Ρ <- Ρ DIV 10

      Τέλος_επανάληψης

       Εμφάνισε G

Τέλος_αν

Τέλος Αριθμοί_ΜΕΡΣΕΝ

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α.   3

Μονάδες 12

β.   4

Μονάδες 8

Θέματα σε pdf, 2004,Επαναληπτικές, Ημερήσια