Επιλογή Σελίδας

Θέμα Γ, 2008, Επαναληπτικές, Ημερήσια

Μία εταιρεία αποφάσισε να δώσει βοηθητικό επίδομα στους υπαλλήλους της για τον μήνα Ιούλιο. Το επίδομα διαφοροποιείται, ανάλογα με το φύλο του/της υπαλλήλου και τον αριθμό των παιδιών του/της, με βάση τους παρακάτω πίνακες:

ΑΝΔΡΕΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ ΕΠΙΔΟΜΑ ΣΕ €
1 20
2 50
>=3 120

 

ΓΥΝΑΙΚΕΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ ΕΠΙΔΟΜΑ ΣΕ €
1 30
2 80
>=3 160

Να γράψετε αλγόριθμο ο οποίος

α. διαβάζει το φύλο («Α» ή «Γ») το οποίο ελέγχεται ως προς την ορθότητα της εισαγωγής του. Επίσης διαβάζει τον μισθό και τον αριθμό των παιδιών του υπαλλήλου.

Μονάδες 3

β. υπολογίζει και εμφανίζει το επίδομα και το συνολικό ποσό που θα εισπράξει ο υπάλληλος τον μήνα Ιούλιο.

Μονάδες 7

γ. δέχεται απάντηση «ΝΑΙ» ή «ΟΧΙ» για τη συνέχεια ή τον τερματισμό της επανάληψης μετά την εμφάνιση σχετικού μηνύματος.

Μονάδες 4

δ. υπολογίζει και εμφανίζει το συνολικό ποσό επιδόματος που πρέπει να καταβάλει η Εταιρεία στους υπαλλήλους της.

Μονάδες 6

ΛΥΣΗ

(περισσότερα…)

Θέμα Δ, 2008, Επαναληπτικές, Ημερήσια

Στο άθλημα των 110 μέτρων μετ’ εμποδίων, στους δύο ημιτελικούς αγώνες συμμετέχουν δέκα έξι (16) αθλητές (8 σε κάθε ημιτελικό). Σύμφωνα με τον κανονισμό στον τελικό προκρίνεται ο πρώτος αθλητής κάθε ημιτελικού. Η οκτάδα του τελικού συμπληρώνεται με τους αθλητές που έχουν τους έξι (6) καλύτερους χρόνους απ’ όλους τους υπόλοιπους συμμετέχοντες. Να θεωρήσετε ότι δεν υπάρχουν αθλητές με ίδιους χρόνους. Να γράψετε πρόγραμμα στη «ΓΛΩΣΣΑ» το οποίο:
α. περιλαμβάνει το τμήμα δηλώσεων. Μονάδες 2
β. καλεί τη διαδικασία ΕΙΣΟ∆ΟΣ για κάθε ημιτελικό ξεχωριστά. Η διαδικασία διαβάζει το όνομα του αθλητή και τoν χρόνο του (με ακρίβεια δεκάτου του δευτερολέπτου). Μονάδες 2
γ. καλεί τη διαδικασία ΤΑΞΙΝΟΜΗΣΗ για κάθε ημιτελικό ξεχωριστά. Η διαδικασία ταξινομεί τους αθλητές ως προς τον χρόνο τους με αύξουσα σειρά. Μονάδες 2
δ. δημιουργεί τον πίνακα ΟΝ με τα ονόματα και τον πίνακα ΧΡ με τους αντίστοιχους χρόνους των αθλητών που προκρίθηκαν στον τελικό Μονάδες 6
ε. εμφανίζει τα ονόματα και τους χρόνους των αθλητών που θα λάβουν μέρος στον τελικό. Μονάδες 2
Να γράψετε
α. τη διαδικασία ΕΙΣΟ∆ΟΣ. Μονάδες 2
β. τη διαδικασία ΤΑΞΙΝΟΜΗΣΗ. Μονάδες 4

ΛΥΣΗ

(περισσότερα…)

Θέμα Α, Ερώτημα 1, 2016, Επαναληπτικές, Νέο

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η λογική έκφραση (Α > Β) Ή   ΟΧΙ(Α > Β) είναι πάντα αληθής για οποιεσδήποτε τιμές των αριθμητικών μεταβλητών Α και Β.
  2. Στη ΓΛΩΣΣΑ ο χαρακτήρας είναι ένας τύπος δεδομένων.
  3. Το κύριο χαρακτηριστικό των δένδρων   είναι ότι από έναν κόμβο υπάρχει μόνο ένας επόμενος κόμβος.
  4. Έστω ο πίνακας ακεραίων Α[10]. Η εντολή Σ <- Α[10] εκχωρεί στη μεταβλητή Σ το άθροισμα όλων των στοιχείων του πίνακα Α.
  5. Στη στοίβα, ο ίδιος δείκτης μάς δίνει, τόσο τη θέση του στοιχείου που μπορεί να εξαχθεί, όσο και τη θέση εκείνου που εισήλθε τελευταίο.

Μονάδες 10

ΛΥΣΗ

  1. Σωστό         2. Σωστό         3. Λάθος          4. Λάθος          5. Σωστό

Θέμα Α, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Σε ποιες περιπτώσεις ένας αλγόριθμος Α χαρακτηρίζεται αποδοτικότερος από ένα αλγόριθμο Β; Να θεωρήσετε ότι η σύγκριση γίνεται κάτω από τις ίδιες ακριβώς συνθήκες (ίδια δεδομένα, ίδιος υπολογιστής, ίδια γλώσσα προγραμματισμού).

Μονάδες 6

Απάντηση

από την παράγραφο 5.1.4 Αποδοτικότητα αλγορίθμων  (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2016, Επαναληπτικές, Νέο

Δίνεται ο παρακάτω πίνακας                                                         

Εντολή Επανάληψης Καταλληλότητα Χρήσης
1.    Όσο … επανάλαβε

Τέλος_επανάληψης

α.   Γνωστός αριθμός επαναλήψεων
2.     Για … από … μέχρι … με βήμα …

Τέλος_επανάληψης

β.   Άγνωστος   αριθμός επαναλήψεων
3. Αρχή   επανάληψης …

μέχρις ότου …

γ. Άγνωστος   αριθμός επαναλήψεων, αλλά τουλάχιστον μία επανάληψη

Να   γράψετε στο τετράδιό σας τους αριθμούς της πρώτης στήλη και, δίπλα, το γράμμα της δεύτερης στήλης που αντιστοιχεί σωστά.

Μονάδες 6

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2016, Επαναληπτικές, Νέο

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές

Θέμα Α, Ερώτημα 5, 2016, Επαναληπτικές, Νέο

Σε μια κενή στοίβα πρόκειται να εισαχθούν τα στοιχεία Μ, Δ, Κ, με αυτή τη σειρά. Δίνονται οι ακόλουθες σειρές διαδοχικών πράξεων (να θεωρήσετε ότι η λειτουργία της ώθησης παριστάνεται με το γράμμα ω και η λειτουργία της απώθησης παριστάνεται με το γράμμα α):

  1. ω, ω, ω, α, α, α
  2. ω, α, ω, α, ω, α
  3. ω, ω, α, α, ω, α
  4. ω, ω, α, ω, α, α
  5. ω, α, ω, ω, α, α

Για καθεμιά από τις παραπάνω σειρές πράξεων να γράψετε στο τετράδιό σας τον αριθμό της (1 έως 5) και, δίπλα, μόνο τα στοιχεία που θα απωθηθούν με τη σειρά απώθησής τους.

Μονάδες 10

ΛΥΣΗ

  1. Κ, Δ, Μ
  2. Μ, Δ, Κ
  3. Δ, Μ, Κ
  4. Δ, Κ, Μ
  5. Μ, Κ, Δ

Θέμα B, Ερώτημα 1, 2016, Επαναληπτικές, Νέο

Δίνεται μια λίστα η οποία αποτελείται από 5 κόμβους. Το πρώτο πεδίο του κάθε κόμβου είναι ένα γράμμα και το δεύτερο πεδίο είναι η διεύθυνση του επόμενου κόμβου, όπως φαίνεται στο παρακάτω διάγραμμα, που σχηματίζει τη λέξη ΔΕΚΤΗ:
rg1thv2016imerneo-1

Η λίστα αυτή απεικονίζεται στη μνήμη με τη μορφή που φαίνεται στο παρακάτω σχήμα.

rg1thv2016imerneo-2

α. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από τη διαγραφή του κατάλληλου κόμβου από την αρχική λίστα, ώστε να σχηματιστεί η λέξη ΔΕΤΗ. (μονάδες 2)

β. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από την εισαγωγή, στην αρχική λίστα, του κόμβου με πρώτο πεδίο το γράμμα Α στη θέση 21, ώστε να σχηματιστεί η λέξη ΔΕΚΑΤΗ. (μονάδες 4)

Μονάδες 6

ΛΥΣΗ

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Γ, 2016, Επαναληπτικές, Νέο

Στο πλαίσιο μιας μελέτης, ένας φιλόλογος θέλει να ελέγξει τη χρήση ενός δείγματος εκατό (100) ναυτικών λέξεων σε σύγχρονα νεοελληνικά κείμενα. Για τον σκοπό αυτό:

Γ1.    Να κατασκευάσετε υποπρόγραμμα, με όνομα ΑΝΑΖΗΤΗΣΗ, το οποίο να δέχεται

  • ένα μονοδιάστατο πίνακα χαρακτήρων Π[100],
  • μια ακέραια μεταβλητή Ν,
  • μια αλφαριθμητική μεταβλητή Χ και να επιστρέφει
  • μια λογική μεταβλητή ΒΡΕΘΗΚΕ και
  • μια ακέραια μεταβλητή ΘΕΣΗ.

Το υποπρόγραμμα να αναζητά μια λέξη, την τιμή της μεταβλητής Χ στις θέσεις 1 έως Ν του πίνακα Π. Αν βρεθεί η λέξη, το υποπρόγραμμα να επιστρέφει την τιμή ΑΛΗΘΗΣ και τη θέση που βρέθηκε. Αν δεν βρεθεί, να επιστρέφει την τιμή ΨΕΥΔΗΣ και την τιμή 0.

Μονάδες 5

Στη συνέχεια να κατασκευάσετε κύριο πρόγραμμα το οποίο:

Γ2. Να ζητά 100 ναυτικές λέξεις και να τις καταχωρίζει σε πίνακα ΛΕΞΕΙΣ[100]. Κάθε λέξη που δίνεται να τη δέχεται, μόνο εφόσον ελέγξει ότι δεν έχει ήδη καταχωριστεί στον πίνακα. Ο έλεγχος να γίνεται με τη χρήση του υποπρογράμματος ΑΝΑΖΗΤΗΣΗ.

Μονάδες 5

Γ3. Να ζητά, με τη σειρά, τις λέξεις ενός νεοελληνικού κειμένου. Η εισαγωγή να τερματίζεται όταν δοθεί ως λέξη η ακολουθία χαρακτήρων «ΤΕΛΟΣ_ΚΕΙΜΕΝΟΥ».

Μονάδες 2

Γ4. Να εμφανίζει τις σπανιότερες ναυτικές λέξεις του δείγματος που υπάρχουν στο νεοελληνικό κείμενο, δηλαδή τις λέξεις με τη μικρότερη συχνότητα εμφάνισης, χρησιμοποιώντας κατάλληλα το υποπρόγραμμα ΑΝΑΖΗΤΗΣΗ.

Μονάδες 8

ΛΥΣΗ (περισσότερα…)

Θέμα Δ, 2016, Επαναληπτικές, Νέο

Στον αρχαιολογικό χώρο της Πύλου διασώθηκαν θραύσματα κεραμικών πινακίδων στα οποία είχαν καταγραφεί σε γραμμές βασικά αγαθά με τις ποσότητες τους, τα οποία είχε συλλέξει η πόλη κατά τη διάρκεια καλλιεργητικών περιόδων. Σε κάθε θραύσμα, αναφέρονται τα πλήρη στοιχεία (όνομα αγαθού, περίοδος, ποσότητα) για ένα ή περισσότερα αγαθά. Βρέθηκαν στοιχεία για δεκαπέντε (15) βασικά αγαθά και πέντε (5) καλλιεργητικές περιόδους. Όλα τα αγαθά υπάρχουν και στις πέντε περιόδους

Σε κάθε γραμμή οι πρώτοι δέκα χαρακτήρες αντιστοιχούν στο όνομα του αγαθού, ο ενδέκατος στην καλλιεργητική περίοδο και ο δωδέκατος στην ποσότητα που συλλέχτηκε. Οι πέντε καλλιεργητικές περίοδοι αναπαρίστανται από τους χαρακτήρες Α, Β, Γ, Δ και Ε. Η ποσότητα που συλλέχτηκε αναπαρίσταται από τους χαρακτήρες Ι, Κ, Λ, Μ, Ν, Ξ και Ο. Έχει βρεθεί ότι η ποσότητα που αντιστοιχεί σε αυτούς είναι: Ι = 10, Κ = 50, Λ = 100, Μ = 500, Ν  =  1.000,  Ξ  =  5.000  και   Ο  =  10.000.

Συνολικά τα στοιχεία των θραυσμάτων μπορούν να αναπαρασταθούν με ένα δισδιάστατο πίνακα Π[75,12]. Κάθε γραμμή του πίνακα περιέχει τα στοιχεία των αγαθών (όνομα αγαθού, καλλιεργητική περίοδος, ποσότητα). Κάθε στοιχείο του πίνακα περιέχει ένα μόνο χαρακτήρα.

Να γράψετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Δ1.  α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδα 1)

β. Να εισάγει σε πίνακα χαρακτήρων Π[75,12] τα στοιχεία των αγαθών που βρέθηκαν στα θραύσματα των πινακίδων. (μονάδες 2)

Μονάδες 3

Δ2. Να ταξινομεί κατά αύξουσα σειρά τον πίνακα Π, με βάση την καλλιεργητική περίοδο, και, για την ίδια καλλιεργητική περίοδο, να ταξινομεί τα αγαθά, με βάση τον πρώτο χαρακτήρα κάθε αγαθού. (Θεωρήστε ότι ο πρώτος χαρακτήρας κάθε αγαθού είναι μοναδικός).

Μονάδες 6

Δ3. α. Να δημιουργεί έναν πίνακα ακεραίων Α[75]. Κάθε στοιχείο του πίνακα Α αντιστοιχεί σε μια γραμμή του ταξινομημένου πίνακα Π και περιέχει την αντίστοιχη ποσότητα του αγαθού που συλλέχτηκε. Η μετατροπή της ποσότητας από χαρακτήρα σε αριθμό να γίνει με βάση την αντιστοιχία που δόθηκε παραπάνω.  (μονάδες 2)

β. Να βρίσκει και να εμφανίζει για κάθε αγαθό το πρώτο γράμμα του ονόματός του και την καλλιεργητική του περίοδο με τη μέγιστη ποσότητα που συλλέχτηκε. (Θεωρήστε ότι η μέγιστη ποσότητα κάθε αγαθού είναι μοναδική).  (μονάδες 4)

Μονάδες 6

Δ4. Να δημιουργεί έναν πίνακα ακεραίων Σ[15]. Κάθε στοιχείο του πίνακα Σ αντιστοιχεί σε ένα αγαθό (όπως αυτό εμφανίζεται στις δεκαπέντε πρώτες σειρές του πίνακα Π) και περιέχει την συνολική ποσότητα του αγαθού που συλλέχτηκε στις πέντε καλλιεργητικές περιόδους.

Μονάδες 5

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ (pdf)

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Για τη γραφική απεικόνιση της δομής ενός προβλήματος χρησιμοποιείται συχνά η διαγραμματική αναπαράσταση.
  2. Κάθε μεταβλητή παίρνει τιμή μόνο με εντολή εκχώρησης.
  3. Σε μια δομή δεδομένων η διαγραφή αποτελεί την αντίστροφη πράξη της συγχώνευσης.
  4. Οι συμβολικές γλώσσες είναι ανεξάρτητες από την αρχιτεκτονική κάθε υπολογιστή.
  5. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση των παρενθέσεων.

Μονάδες 10

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

  1. Σωστό 2. Λάθος 3. Λάθος 4. Λάθος 5. Σωστό