Επιλογή Σελίδας

Σε ένα πρόγραμμα περιβαλλοντικής εκπαίδευσης συμμετέχουν 20 σχολεία. Στα πλαίσια αυτού του προγράμματος, εθελοντές μαθητές των σχολείων, που συμμετέχουν στο πρόγραμμα, μαζεύουν ποσότητες τριών υλικών (γυαλί, χαρτί και αλουμίνιο).

Να αναπτύξετε έναν αλγόριθμο, ο οποίος:
α.   να διαβάζει τις ποσότητες σε κιλά των παραπάνω υλικών που μάζεψαν οι μαθητές σε κάθε σχολείο
Μονάδες 4

β.    να υπολογίζει τη συνολική ποσότητα σε κιλά του κάθε υλικού που μάζεψαν οι μαθητές σε όλα τα σχολεία
Μονάδες 8

γ. αν η συνολική ποσότητα του χαρτιού που μαζεύτηκε από όλα τα σχολεία είναι λιγότερη των 1000 κιλών, να εμφανίζεται το μήνυμα «Συγχαρητήρια». Αν η ποσότητα είναι από 1000 κιλά και πάνω, αλλά λιγότερο από 2000, να εμφανίζεται το μήνυμα «Δίνεται έπαινος» και τέλος αν η ποσότητα είναι από 2000 κιλά και πάνω να εμφανίζεται το μήνυμα «Δίνεται βραβείο».
Μονάδες 8

Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες είναι θετικοί αριθμοί.

ΛΥΣΗ:

Αλγόριθμος Περιβαλλοντική
 ΣΓ <-- 0             ! Σύνολο γυαλιού
 ΣΧ <-- 0             ! Σύνολο χαρτιού
 ΣΑ <-- 0             ! Σύνολο αλουμίνιου
 Για i από 1 μέχρι 20
      Διάβασε Γ, Χ, Α
      ΣΓ <-- ΣΓ + Γ
      ΣΧ <-- ΣΧ + X
      ΣΑ <-- ΣΑ + A
 Τέλος_επανάληψης
 Αν ΣΧ < 1000 τότε
     Εμφάνισε 'Συγχαρητήρια'
 αλλιώς_αν ΣΧ < 2000 τότε
     Εμφάνισε 'Δίνεται έπαινος'
 αλλιώς
     Εμφάνισε 'Δίνεται βραβείο'
 Τέλος_αν
 Τέλος Περιβαλλοντική

Θέματα σε pdf, 2001, Ημερήσια, Μαΐου-Ιουνίου

Share This