ΘΕΜΑ Α2, 2017, Επαναληπτικές

α.Η επιβράβευση αγορών με χρήση κάποιας πιστωτικής κάρτας γίνεται κλιμακωτά με βάση το ποσό ως εξής:
Για ποσά μέχρι 100 ευρώ 1%
Για τα επόμενα 900 ευρώ 0,8%
Για το υπόλοιπο ποσό 0,6%

Να γράψετε στο τετράδιό σας τις εντολές σε Γλώσσα που κωδικοποιούν τον υπολογισμό του ποσού της παραπάνω επιβράβευσης. (μονάδες 6)

β. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν, όταν εκτελεστεί το παρακάτω τμήμα προγράμματος:

j<-1
k <- 2
Για i από 1 μέχρι 4
    f <- j + k
    Γράψε f
    j <- k
    k <- f
Τέλος_επανάληψης

(μονάδες 4)

Μονάδες 10

ΘΕΜΑ Β2, 2017, Επαναληπτικές

Β2. Δίνεται μονοδιάστατος πίνακας Π[6] με τις τιμές που φαίνονται παρακάτω.

1 2 3 4 5 6
18 29 40 51 62 73

Για την αναζήτηση μιας τιμής στον πίνακα Π δίνεται το παρακάτω τμήμα αλγόριθμου:

Διάβασε Χ 
Θέση <- 0 
Βρέθηκε <- Ψευδής Υπάρχει <- Αληθής 
i <- 1
Αρχή_επανάληψης 
   Αν Π[i]=Χ τότε
      Βρέθηκε <- Αληθής 
      Θέση<- i 
   Αλλιώς_αν Π[i]>Χ τότε
      Υπάρχει <- Ψευδής 
   Τέλος_αν
   i <- i +1 
Μέχρις_ότου i>6 ή Βρέθηκε = Αληθής ή Υπάρχει = Ψευδής

Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.
 

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα B, Ερώτημα 2, 2012, Επαναληπτικές, Ημερήσια

Δίνονται οι πίνακες DATA[7], L[7], R[7], οι οποίοι περιέχουν δεδομένα, όπως φαίνονται στα παρακάτω σχήματα:
er2themabaepp-2012-imerisia-epanaliptikes
Χρησιμοποιώντας τους ανωτέρω πίνακες, να εκτελέσετε το παρακάτω τμήμα αλγορίθμου και να συμπληρώσετε τον πίνακα τιμών, αφού τον μεταφέρετε στο τετράδιό σας.
ΓΡΑΜΜΑ <- ΄Σ΄
Κ <- 1
Όσο DATA[K] <> ΓΡΑΜΜΑ
επανάλαβε
Εκτύπωσε DATA[K]
Αν DATA[K] > ΓΡΑΜΜΑ τότε
Κ <- L[K]
αλλιώς
Κ <- R[K]
Τέλοςαν
Τέλος
επανάληψης
Εκτύπωσε DATA[K]

Πίνακας τιμών

ΓΡΑΜΜΑ Κ ΟΘΟΝΗ (ΕΚΤΥΠΩΣΗ)
Σ

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

 

Ερώτημα 2, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο πίνακας Α τεσσάρων στοιχείων με τιμές:
Α[1]=3, Α[2]=5, Α[3]=8, Α[4]=13 και το παρακάτω τμήμα αλγορίθμου:
i <- 1 j <- 4
Όσο i<=3 επανάλαβε
πρόχειρο <- Α[j]
A[j] <- Α[i]
Α[i] <- πρόχειρο
Γράψε   Α[1], Α[2], Α[3]
i <- i + 1
j <- j – 1
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανισθούν κατά την εκτέλεσή του.
Μονάδες 9

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΔΣ4, Κεφάλαιο 2, Τετράδιο Εργασιών

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Ελεγχος_Ανάθεσης
 Διάβασε x
 Όσο x > 1 επανάλαβε
         Αν x mod 2 = 0 τότε      ! Αν χ είναι άρτιος τότε
            x ← x/2               ! Αλλαγή σε DIV για να εκτελεστεί στη ΓΛΩΣΣΑ
         αλλιώς 
            x ←3*x+1
        Τέλος_αν
        Γράψε x                   ! Πίνακας τιμών μεταβλητής
  Τέλος_επανάληψης                       
 Αποτελέσματα // x //
 Τέλος Ελεγχος_Ανάθεσης
 Να γράψεις τα αποτελέσματα αυτού του αλγορίθμου για x=13, x=9 και x=22. Τι παρατηρείς;

Λύση:  (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Δ <- Αληθής
Για α από 1 μέχρι Ν
Δ <- ΟΧΙ   Δ
Τέλος_επανάληψης
Εμφάνισε Δ
Να το εκτελέσετε για καθεμία από τις παρακάτω περιπτώσεις:
1)     Ν=0     2) Ν=1     3) Ν=4     4) Ν=2011     5)   Ν=8128
και να γράψετε στο τετράδιό σας τον αριθμό καθεμίας από τις παραπάνω περιπτώσεις 1-5 και δίπλα τη λογική τιμή που θα εμφανιστεί μετά την εκτέλεση της αντίστοιχης περίπτωσης.
Μονάδες 5

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 2, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω πρόγραμμα και ένα υποπρόγραμμα:

Πρόγραμμα ΘέμαΒ Διαδικασία Διαδ(w,z)
Μεταβλητές Μεταβλητές
Ακέραιες: z,w Ακέραιες: z,w
Αρχή Αρχή
z <- 1 w <- w+z
w <- 3 z <- z+2
Όσο z<=35 επανάλαβε Γράψε z
Κάλεσε Διαδ(z,w) Τέλος_Διαδικασίας
Γράψε z
Τέλος_επανάληψης
Tέλος_Προγράμματος

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος με τη σειρά που θα εμφανιστούν.

Μονάδες 10

 Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2010, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές:

  1. j<-1
  2. i<-2
  3. Αρχή_επανάληψης
  4. i<-i + j
  5. j<-i – j
  6. Εμφάνισε i
  7. Μέχρις_ότου i ≥ 5

Επίσης δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής συνθήκη έξοδος i j

Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ,   εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγόριθμου.
Να  μεταφέρετε  τον  πίνακα  στο  τετράδιό σας και να τον συμπληρώσετε     εκτελώντας τις εντολές του τμήματος αλγορίθμου ως εξής:
Για κάθε εντολή που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμά της στην αντίστοιχη στήλη.
Σημείωση: Η εντολή της γραμμής 3 δεν χρειάζεται να αποτυπωθεί στον πίνακα.

Μονάδες 20

ΛΥΣΗ (περισσότερα…)