Θέμα Α1, 2019, Eπαναληπτικές, Hμερήσια και Eσπερινά

Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω  προτάσεις 1 έως 5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή,  ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη

  1. Ο αριθμός που προκύπτει από την ολίσθηση ενός θετικού αριθμού  προς τα δεξιά είναι πάντα μεγαλύτερος από τον αρχικό. 
  2. Η μεταβλητή Χ είναι πραγματικού τύπου στην εντολή εκχώρησης: Χ α/2 
  3. Η σύνθετη συνθήκη Χ<= -5 ΚΑΙ Χ>5, δεν αληθεύει για καμία τιμή του Χ. 
  4. Η εντολή ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ 4 εκτελείται 5 φορές. 
  5. Η δημιουργία του εκτελέσιμου προγράμματος γίνεται μόνο στην  περίπτωση που το αρχικό πρόγραμμα δεν περιέχει λογικά λάθη. 

Μονάδες 10 

Θέμα Α3, 2019, Eπαναληπτικές, Hμερήσια και Eσπερινά

Α3.
Α3. Δίνεται το παρακάτω τμήμα προγράμματος σε ΓΛΩΣΣΑ:

sum<-0 
ΓΙΑ i AΠΟ 6 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -2 
    sum <- sum + i 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Να μετατραπεί σε ισοδύναμο τμήμα προγράμματος με χρήση της δομής ΟΣΟ…ΕΠΑΝΑΛΑΒΕ (μονάδες 5)
β. Να μετατραπεί σε ισοδύναμο τμήμα προγράμματος με χρήση της δομής ΑΡΧΗΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣΟΤΟΥ (μονάδες 5)
Μονάδες 10

Θέμα Α4, 2018, Ιούνιου, Hμερήσια και Eσπερινά

ΘΕΜΑ Α4
Δίνεται το παρακάτω τμήμα αλγορίθμου που περιέχει ένα κενό:

κ<-0 
Για i από 1 μέχρι 7 
    λ<-…(1)… 
    κ<-κ+λ 
Τέλος_επανάληψης 

Το τμήμα αυτό μπορεί να χρησιμοποιηθεί για τον υπολογισμό καθεμιάς από τις παρακάτω αριθμητικές παραστάσεις:
α) 4+5+6+7+8+9+10
β) 1+22+32+42+52+62+72
γ) 21+22+23+24+25+26+27
δ) 3+5+7+9+11+13+15

Να γράψετε στο τετράδιό σας τα γράμματα α, β, γ, δ, ε, που αντιστοιχούν στις παραστάσεις αυτές και δίπλα από κάθε γράμμα την έκφραση που πρέπει να συμπληρωθεί στο κενό του αλγορίθμου (1), ώστε να υπολογίζεται σωστά η αντίστοιχη παράσταση.
Μονάδες 10

Θέμα Α4, 2018, επαναληπτικές, ημερήσια και εσπερινά

Α4. Ο παρακάτω αλγόριθμος αντιγράφει τα στοιχεία ενός μονοδιάστατου πίνακα Α[Y], όπου Υ=Μ*N, σε δισδιάστατο πίνακα Β[Μ,Ν] ξεκινώντας από την πρώτη στήλη και συνεχίζοντας με κάθε επόμενη στήλη γεμίζοντας καθεμιά από πάνω προς τα κάτω:

Αλγόριθμος Αντιγραφή 
Δεδομένα // Α,Μ,Ν // 
χ…(1)… 
Για κ από 1 μέχρι …(2)... 
    Για λ από 1 μέχρι …(3)… 
        χ…(4)… 
        Β[λ,κ]  Α[…(5)…] 
     Τέλος_Επανάληψης 
Τέλος_Επανάληψης 
Αποτελέσματα // Β // 
Τέλος Αντιγραφή 

Ο αλγόριθμος περιέχει αριθμημένα κενά (1 έως 5). Να γράψετε στο τετράδιό σας τους αριθμούς των κενών και δίπλα από κάθε αριθμό την έκφραση που πρέπει να συμπληρωθεί ώστε ο αλγόριθμος να επιτελεί τη λειτουργία που περιγράφεται.
Μονάδες 10

Θέμα Β2, 2018, επαναληπτικές, ημερήσια και εσπερινά

Β2. Δίνεται το παρακάτω υποπρόγραμμα σε ΓΛΩΣΣΑ με όνομα Π_Μ το οποίο ελέγχοντας τα στοιχεία 200 ατόμων υπολογίζει το πλήθος των ανήλικων ατόμων που έχουν κάποιο συγκεκριμένο όνομα.

(1) ………………… 
ΣΤΑΘΕΡΕΣ 
(2) ………………… 
ΜΕΤΑΒΛΗΤΕΣ 
(3) ΑΚΕΡΑΙΕΣ:………………… 
(4) ΧΑΡΑΚΤΗΡΕΣ: ………………… 
ΑΡΧΗ 
Π  0 
Για i από 1 μέχρι Ν 
     Αν ΗΛ[i] < 18 ΚΑΙ Ο[i]= Χ τότε 
        Π  Π+1 
     Τέλος_αν 
Τέλος_επανάληψης 
Π_Μ  Π 
(5) ………………… 

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5 των γραμμών και δίπλα από κάθε αριθμό ό,τι χρειάζεται να συμπληρωθεί ώστε να είναι σωστή και πλήρης η σύνταξη του υποπρογράμματος.
Μονάδες 10

ΘΕΜΑ Α2, 2017, Επαναληπτικές

α.Η επιβράβευση αγορών με χρήση κάποιας πιστωτικής κάρτας γίνεται κλιμακωτά με βάση το ποσό ως εξής:
Για ποσά μέχρι 100 ευρώ 1%
Για τα επόμενα 900 ευρώ 0,8%
Για το υπόλοιπο ποσό 0,6%

Να γράψετε στο τετράδιό σας τις εντολές σε Γλώσσα που κωδικοποιούν τον υπολογισμό του ποσού της παραπάνω επιβράβευσης. (μονάδες 6)

β. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν, όταν εκτελεστεί το παρακάτω τμήμα προγράμματος:

j<-1
k <- 2
Για i από 1 μέχρι 4
    f <- j + k
    Γράψε f
    j <- k
    k <- f
Τέλος_επανάληψης

(μονάδες 4)

Μονάδες 10

Θέμα A, Ερώτημα 1, 2017, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η έκφραση ΟΧΙ(Κ=10 ΚΑΙ Χ>7) είναι ισοδύναμη με την έκφραση (Κ<>10 Ή Χ<=7).
  2. Η χρησιμοποίηση του διερμηνευτή για τη μετάφραση ενός προγράμματος έχει ως αποτέλεσμα την ταχύτερη εκτέλεσή του.
  3. Οι εντολές στη δομή επανάληψης «ΓΙΑ» εκτελούνται τουλάχιστον μία φορά.
  4. Πολύ συχνά οι εντολές που έχουν γραφτεί με εμφωλευμένα ΑΝ μπορούν να γραφτούν πιο απλά χρησιμοποιώντας σύνθετες εκφράσεις ή την εντολή επιλογής ΑΝ… ΤΟΤΕ… ΑΛΛΙΩΣ_ΑΝ.
  5. Κάθε υποπρόγραμμα μπορεί να σχεδιαστεί, να αναπτυχθεί και να συντηρηθεί αυτόνομα.

Μονάδες 10

Παράδειγμα 4, Κεφάλαιο 8, Βιβλίο, Άθροισμα Περιττών μέχρι το 100

Το παρακάτω πρόγραμμα υπολογίζει το άθροισμα των περιττών αριθμών που είναι μικρότεροι από το 100.

ΠΡΟΓΡΑΜΜΑ Περιττοί 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Άθροισμα, Αριθμός 
ΑΡΧΗ  
Άθροισμα <-- 0 
ΓΙΑ Αριθμός ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2   
    Άθροισμα <-- Άθροισμα + Αριθμός 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Άθροισμα περιττών αριθμών είναι: ', Άθροισμα 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 5, Κεφάλαιο 8, Βιβλίο, Προπαίδεια

Να γραφεί πρόγραμμα το οποίο να εκτυπώνει την προπαίδεια του πολλαπλασιασμού.

ΠΡΟΓΡΑΜΜΑ Προπαίδεια 
!Πρόγραμμα εκτύπωσης της προπαίδειας των αριθμών 1 έως 10 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Α, Β, Γ 
!A:Πολλαπλασιαστέος
!Β:Πολαπλασιαστής
!Γ:Γινόμενο
ΑΡΧΗ
ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10   
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
        Γ <- Α*Β
        ΓΡΑΨΕ A,'X',Β,'=',Γ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ  !Εισαγωγή κενής γραμμής στην εκτύπωση 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 8, Τετράδιο Εργασιών, Βολή μπάλας στον αέρα, μεταβολή γωνίας βολής και αρχικής ταχύτητας

Στο παράδειγμα 1 του προηγούμενου κεφαλαίου με την μπάλα που εκτοξεύεται στον αέρα η γωνία βολής μπορεί να μεταβάλλεται από 20 έως 80 μοίρες σε βήματα των 10 μοιρών. Επίσης η αρχική ταχύτητα μπορεί να μεταβάλλεται από 10 μ/sec έως 40 μ/sec σε βήματα των 10 μ/sec. Να γραφεί πρόγραμμα που να υπολογίζει την οριζόντια απόσταση (το βεληνεκές) για κάθε συνδυασμό γωνίας και αρχικής ταχύτητας.

ΠΡΟΓΡΑΜΜΑ Τροχιά_μπάλας2 
ΣΤΑΘΕΡΕΣ 
G = 9.81 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ:V0,VX0,VY0,Θ, Βεληνεκές 
ΑΡΧΗ 
ΓΙΑ Θ ΑΠΟ 20 ΜΕΧΡΙ 80 ΜΕ ΒΗΜΑ 10 
    ΓΡΑΨΕ 'Γωνία:',Θ 
    ΓΙΑ V0 ΑΠΟ 10 ΜΕΧΡΙ 40 ΜΕ ΒΗΜΑ 10
        VX0 <-- V0*ΣΥΝ(Θ) 
        VY0 <-- V0*ΗΜ(Θ) 
        Βεληνεκές <-- 2*VX0*VY0/G
        ΓΡΑΨΕ 'Ταχύτητα:',V0,'Βεληνεκές:',Βεληνεκές 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΤ4, Κεφάλαιο 8, Τμήμα προγράμματος, βρες τη λειτουργία, τον αριθμό επαναλήψεων, κάνε μετατροπή σε άλλες δομές

Έστω το παρακάτω τμήμα προγράμματος:

Κ <- 0 
ΓΙΑ Ι ΑΠΟ 0 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 5 
    Α <- Ι^3 
    Κ <- Κ+Α 
    ΓΡΑΨΕ Ι, Α 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Κ

Πόσες φορές θα εκτελεστεί ο βρόχος; Ποια η λειτουργία των εντολών; Γράψτε τις παραπάνω εντολές χρησιμοποιώντας την εντολή επανάληψης ΟΣΟ και την εντολή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. Ποιον από τους τρεις τρόπους προτιμάς και γιατί;

ΛΥΣΗ (περισσότερα…)

Παράδειγμα 3, Τετράδιο Εργασιών, Υπολογισμός μέσου όρου

Σε ένα Λύκειο υπάρχουν τρία τμήματα για την Γ΄ Λυκείου και κάθε τμήμα έχει 35 μαθητές. Να γραφεί ένας αλγόριθμος που θα διαβάζει το μέσο όρο βαθμολογίας κάθε μαθητή και θα υπολογίζει το γενικό μέσο όρο βαθμολογίας για όλη την τάξη της Γ΄ Λυκείου. Ο αλγόριθμος που ακολουθεί υπολογίζει τον παραπάνω μέσο όρο με χρήση της δομής του πίνακα.

ΛΥΣΗ: (περισσότερα…)