ΘΕΜΑ Β1, 2017, Επαναληπτικές

Δίνεται το παρακάτω τμήμα αλγόριθμου, που υλοποιεί την πρώτη φάση της συγχώνευσης των ταξινομημένων πινάκων Α[100] και Β[200] σε πίνακα Γ[300]. Ο πίνακας Α είναι ταξινομημένος σε αύξουσα σειρά και ο πίνακας Β σε φθίνουσα. Το τμήμα αυτό επεξεργάζεται τους πίνακες Α και Β τοποθετώντας τα στοιχεία τους στον πίνακα Γ σε αύξουσα σειρά. Η διαδικασία σταματά, όταν εξαντληθούν τα στοιχεία ενός από τους πίνακες Α και Β. Το τμήμα αλγόριθμου έχει 8 κενά αριθμημένα από 1-8. Σε κάθε κενό αντιστοιχεί ένας τελεστής ή μία μεταβλητή. Για κάθε ένα από τα κενά να γράψετε στο τετράδιό σας τον αριθμό του και δίπλα τον τελεστή ή την μεταβλητή που αντιστοιχεί.

I<- 1
j<- 200
k<- 1
Όσο i … (1) 100 και j … (2) 1 επανάλαβε
    Αν Α[i] … (3) Β[j] τότε
       Γ[… ( 4)]<- Α[i]
       i<- i … (5) 1 
    Αλλιώς
       Γ[...(6)] <- Β[...(7)]
       J<- j … (8)1 
    Τέλος_αν
    k<- k +1
Τέλος_επανάληψης

 

Μονάδες 8
Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

ΘΕΜΑ Β2, 2017, Επαναληπτικές

Β2. Δίνεται μονοδιάστατος πίνακας Π[6] με τις τιμές που φαίνονται παρακάτω.

1 2 3 4 5 6
18 29 40 51 62 73

Για την αναζήτηση μιας τιμής στον πίνακα Π δίνεται το παρακάτω τμήμα αλγόριθμου:

Διάβασε Χ 
Θέση <- 0 
Βρέθηκε <- Ψευδής Υπάρχει <- Αληθής 
i <- 1
Αρχή_επανάληψης 
   Αν Π[i]=Χ τότε
      Βρέθηκε <- Αληθής 
      Θέση<- i 
   Αλλιώς_αν Π[i]>Χ τότε
      Υπάρχει <- Ψευδής 
   Τέλος_αν
   i <- i +1 
Μέχρις_ότου i>6 ή Βρέθηκε = Αληθής ή Υπάρχει = Ψευδής

Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.
 

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

Θέμα Β, 2017, Ημερήσια

ΘΕΜΑ Β
Β1. Δίνεται το παρακάτω απόσπασμα αλγορίθμου:
i<– …(1)
Όσο i≤ …(2) επανάλαβε
Αν i …(3) <> …(4) τότε
Γράψε i
Τέλοςαν
i <– i +  …(5)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του παραπάνω αποσπάσματος, και δίπλα σε κάθε αριθμό τι πρέπει να συμπληρωθεί, ώστε με την εκτέλεσή του να εμφανίζονται οι τιμές:
4, 8, 16, 20, 28, 32, 40
Μονάδες 10
Β2. Το ακόλουθο πρόγραμμα έχει σκοπό να διαβάζει 10 θετικούς αριθμούς και να υπολογίζει και να εμφανίζει το γινόμενο όσων από αυτούς είναι πολλαπλάσιοι και του 3 και του 5 (συγχρόνως). Στο πρόγραμμα, όμως, υπάρχουν λάθη.
α) Να εντοπίσετε τα λάθη αυτά και στο τετράδιό σας να γράψετε τον αριθμό της γραμμής που βρίσκεται το λάθος και τον χαρακτηρισμό του (συντακτικό ή λογικό).
β) Στη συνέχεια να γράψετε το σωστό πρόγραμμα διορθώνοντας τα λάθη που εντοπίσατε.
1. Πρόγραμμα Αριθμοί
2. Μεταβλητές
3.    Πραγματικές: Χ
4.    Ακέραιες: Ρ, i
5. Αρχή
6. Ρ <– 0
7. Για i από 1 μέχρι 10
8.      Διάβασε Χ
9.     Αν Χ MOD 3 = 0 Ή MOD 5 = 0 τότε
10         Ρ <– Ρ * Χ
11.    Τέλοςεπανάληψης
12. Τέλος
επανάληψης
13. Γράψε Ρ
14 Τέλος_προγράμματος
Σημείωση: Θεωρείστε ότι κατά την εκτέλεση του προγράμματος θα δοθεί τουλάχιστον ένας τέτοιος αριθμός.
Μονάδες 10

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Νέο

Ο αριθμός π εκφράζει το πηλίκο της περιμέτρου ενός κύκλου προς τη διάμετρό του. Η τιμή του μπορεί να υπολογιστεί, κατά προσέγγιση, από την παρακάτω παράσταση:
er1the-v-aepp-2016-imerisia-neo
Ο υπολογισμός της τιμής της παράστασης, για 100 όρους του αθροίσματος, γίνεται από το παρακάτω τμήμα αλγορίθμου που περιλαμβάνει 5 κενά.

παρονομαστής < (1)   
 Σ< 0
 πρόσημο < 1
 Για i από 1 μέχρι 100
       όρος < 1/παρονομαστής
       όρος<  (2)  * πρόσημο
       (3)   < Σ + όρος
       πρόσημο < πρόσημο * ( (4) )
       παρονομαστής < παρονομαστής + 2 
 Τέλος_Επανάληψης
 π <- (5) * Σ

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε ο αλγόριθμος να υπολογίζει την τιμή του π όπως περιγράφηκε.
Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Νέο

Κατά την είσοδό τους σε μια τράπεζα οι πελάτες παίρνουν διαδοχικούς αριθμούς προτεραιότητας 1, 2, 3… που καθορίζουν τη σειρά τους στην ουρά του μοναδικού ταμείου.

Κάθε 2 λεπτά της ώρας προσέρχεται ένας νέος πελάτης και προστίθεται στην ουρά. Ο ταμίας εξυπηρετεί κάθε φορά τον πρώτο πελάτη στην ουρά και η εξυπηρέτησή του διαρκεί 3 λεπτά ακριβώς. Μετά την εξυπηρέτησή του ο πελάτης αποχωρεί από την ουρά.

Κατά την αρχή της διαδικασίας (χρόνος 0) στην ουρά υπάρχει μόνο ο πελάτης με αριθμό προτεραιότητας 1.

Να γράψετε διαδοχικά, σε ξεχωριστές γραμμές, με τη σωστή σειρά, τους αριθμούς προτεραιότητας των πελατών που βρίσκονται στην ουρά του ταμείου αμέσως μετά το 1ο , 2ο , 3ο , 4ο , 5ο και 6ο λεπτό.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ

(περισσότερα…)

Θέμα B, Ερώτημα 1, 2016, Επαναληπτικές, Νέο

Δίνεται μια λίστα η οποία αποτελείται από 5 κόμβους. Το πρώτο πεδίο του κάθε κόμβου είναι ένα γράμμα και το δεύτερο πεδίο είναι η διεύθυνση του επόμενου κόμβου, όπως φαίνεται στο παρακάτω διάγραμμα, που σχηματίζει τη λέξη ΔΕΚΤΗ:
rg1thv2016imerneo-1

Η λίστα αυτή απεικονίζεται στη μνήμη με τη μορφή που φαίνεται στο παρακάτω σχήμα.

rg1thv2016imerneo-2

α. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από τη διαγραφή του κατάλληλου κόμβου από την αρχική λίστα, ώστε να σχηματιστεί η λέξη ΔΕΤΗ. (μονάδες 2)

β. Να σχεδιάσετε στο τετράδιό σας την απεικόνιση της μνήμης μετά από την εισαγωγή, στην αρχική λίστα, του κόμβου με πρώτο πεδίο το γράμμα Α στη θέση 21, ώστε να σχηματιστεί η λέξη ΔΕΚΑΤΗ. (μονάδες 4)

Μονάδες 6

ΛΥΣΗ

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου.
01 ΔΙΑΒΑΣΕ X
02 ΠΛ<– 0
03 ΑΡ <– 1
04 ΔΕ <– 12
05 Β <– ΨΕΥΔΗΣ
ΟΣΟ Β = ΨΕΥΔΗΣ ΚΑΙ ΑΡ <= ΔΕ ΕΠΑΝΑΛΑΒΕ
06 Μ <– (ΑΡ + ΔΕ) DIV 2
AN A[M] = X TOTE
07 B <– ΑΛΗΘΗΣ
ΑΛΛΙΩΣ_ΑΝ Α[Μ] < Χ ΤΟΤΕ
08 ΑΡ <– Μ + 1
ΑΛΛΙΩΣ
09 ΔΕ <– Μ – 1
ΤΕΛΟΣ  ΑΝ
10 ΠΛ <– ΠΛ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Β = ΑΛΗΘΗΣ ΤΟΤΕ
11 ΕΜΦΑΝΙΣΕ Μ
ΑΛΛΙΩΣ
12 ΕΜΦΑΝΙΣΕ “ΔΕΝ ΒΡΕΘΗΚΕ”, ΠΛ
ΤΕΛΟΣ_ΑΝ

Για την παρακολούθηση της εκτέλεσης του τμήματος αλγορίθμου με τιμή εισόδου Χ = 35 και με δεδομένο τον πίνακα

1 2 3 4 5 6 7 8 9 10 11 12
Α 3 10 18 20 26 32 35 48 55 60 75 90
δίνεται το παρακάτω υπόδειγμα πίνακα τιμών,συμπληρωμένο ως εξής:
  • Στη στήλη με τίτλο «Αρ. Γρ.» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «Έξοδος» καταγράφεται η τιμή εξόδουεφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Οι  υπόλοιπες στήλες του πίνακα τμήματος του αλγορίθμου αντιστοιχούν στις μεταβλητές του τμήματος του αλγορίθμου.
Αρ.Γρ. Χ ΠΛ ΑΡ ΔΕ Β Μ Έξοδος
01 35
02 0
03 1
04 12
05 ΨΕΥΔΗΣ
……

Να μεταφέρετε τον πίνακα τιμών στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του τμήματος αλγορίθμου ως εξής: για κάθε αριθμημένη εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Δίνεται ο πίνακας αριθμών Χ[50], ταξινομημένος κατά φθίνουσα σειρά, και ο πίνακας Υ[100], ταξινομημένος κατά αύξουσα σειρά. Να θεωρήσετε ότι οι τιμές κάθε πίνακα είναι διαφορετικές μεταξύ τους και ότι οι δύο πίνακες δεν έχουν κοινές τιμές.

Το παρακάτω ημιτελές τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Ζ[10], ταξινομημένο σε φθίνουσα σειρά, με τις δέκα μεγαλύτερες τιμές από τις εκατόν πενήντα (150) τιμές των δύο πινάκων.

i <--(1)
j <-- (2)
Για k από 1 μέχρι 10
      Αν Χ[ i ] (3) Υ[ j ] τότε 
            Ζ[ k ] <-- Χ[ i ] 
            i <-- i (4) 1 
     Αλλιώς
            Ζ[ k ] <-- Υ[ j ] 
             j <-- j (5) 1 
    Τέλος_αν
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν