Επιλογή Σελίδας

Θέμα A, Ερώτημα 1, 2017, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η έκφραση ΟΧΙ(Κ=10 ΚΑΙ Χ>7) είναι ισοδύναμη με την έκφραση (Κ<>10 Ή Χ<=7).
  2. Η χρησιμοποίηση του διερμηνευτή για τη μετάφραση ενός προγράμματος έχει ως αποτέλεσμα την ταχύτερη εκτέλεσή του.
  3. Οι εντολές στη δομή επανάληψης «ΓΙΑ» εκτελούνται τουλάχιστον μία φορά.
  4. Πολύ συχνά οι εντολές που έχουν γραφτεί με εμφωλευμένα ΑΝ μπορούν να γραφτούν πιο απλά χρησιμοποιώντας σύνθετες εκφράσεις ή την εντολή επιλογής ΑΝ… ΤΟΤΕ… ΑΛΛΙΩΣ_ΑΝ.
  5. Κάθε υποπρόγραμμα μπορεί να σχεδιαστεί, να αναπτυχθεί και να συντηρηθεί αυτόνομα.

Μονάδες 10

Παράδειγμα 3, Κεφάλαιο 8, Βιβλίο, Άθροισμα και Πλήθος αριθμών

Στο προηγούμενο παράδειγμα ας υποθέσουμε ότι οι μετρήσεις είναι υποχρεωτικά θετικοί αριθμοί και ότι μετά την εισαγωγή κάθε αριθμού υπάρχει η ερώτηση αν θα εισαγάγουμε άλλο. Η διαδικασία θα τελειώσει, όταν η απάντηση θα είναι Όχι (ο ή Ο).

ΠΡΟΓΡΑΜΜΑ Άθροισμα2 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ:Επιλογή 
ΑΡΧΗ 
Πλήθος <-- 0 
Άθροισμα <-- 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
       ! Έλεγχος δεδομένων 
       ΓΡΑΨΕ 'Δώσε Αριθμό' 
       ΔΙΑΒΑΣΕ Χ 
       ΑΝ Χ <= 0 ΤΟΤΕ 
          ΓΡΑΨΕ 'Λάθος Αριθμός, Παρακαλώ δώστε ξανά...' 
       ΤΕΛΟΣ_ΑΝ 
       ! Αν το X δεν είναι θετικό εισάγουμε νέο αριθμό 
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Νέα μέτρηση ;' 
    ΔΙΑΒΑΣΕ Επιλογή ! Αν η επιλογή είναι Ο ή ο τότε σταματάει η επανάληψη
ΜΕΧΡΙΣ_ΟΤΟΥ Επιλογή='Ο' Ή Επιλογή='ο' 
ΜΟ <-- Άθροισμα/Πλήθος 
ΓΡΑΨΕ 'Άθροισμα =' , Άθροισμα 
ΓΡΑΨΕ 'Μέσος όρος =', ΜΟ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Παράδειγμα 5, Κεφάλαιο 8, Βιβλίο, Προπαίδεια

Να γραφεί πρόγραμμα το οποίο να εκτυπώνει την προπαίδεια του πολλαπλασιασμού.

ΠΡΟΓΡΑΜΜΑ Προπαίδεια 
!Πρόγραμμα εκτύπωσης της προπαίδειας των αριθμών 1 έως 10 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Α, Β, Γ 
!A:Πολλαπλασιαστέος
!Β:Πολαπλασιαστής
!Γ:Γινόμενο
ΑΡΧΗ
ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10   
    ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
        Γ <- Α*Β
        ΓΡΑΨΕ A,'X',Β,'=',Γ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ  !Εισαγωγή κενής γραμμής στην εκτύπωση 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 8, Τετράδιο Εργασιών, Βολή μπάλας στον αέρα, μεταβολή γωνίας βολής και αρχικής ταχύτητας

Στο παράδειγμα 1 του προηγούμενου κεφαλαίου με την μπάλα που εκτοξεύεται στον αέρα η γωνία βολής μπορεί να μεταβάλλεται από 20 έως 80 μοίρες σε βήματα των 10 μοιρών. Επίσης η αρχική ταχύτητα μπορεί να μεταβάλλεται από 10 μ/sec έως 40 μ/sec σε βήματα των 10 μ/sec. Να γραφεί πρόγραμμα που να υπολογίζει την οριζόντια απόσταση (το βεληνεκές) για κάθε συνδυασμό γωνίας και αρχικής ταχύτητας.

ΠΡΟΓΡΑΜΜΑ Τροχιά_μπάλας2 
ΣΤΑΘΕΡΕΣ 
G = 9.81 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ:V0,VX0,VY0,Θ, Βεληνεκές 
ΑΡΧΗ 
ΓΙΑ Θ ΑΠΟ 20 ΜΕΧΡΙ 80 ΜΕ ΒΗΜΑ 10 
    ΓΡΑΨΕ 'Γωνία:',Θ 
    ΓΙΑ V0 ΑΠΟ 10 ΜΕΧΡΙ 40 ΜΕ ΒΗΜΑ 10
        VX0 <-- V0*ΣΥΝ(Θ) 
        VY0 <-- V0*ΗΜ(Θ) 
        Βεληνεκές <-- 2*VX0*VY0/G
        ΓΡΑΨΕ 'Ταχύτητα:',V0,'Βεληνεκές:',Βεληνεκές 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Θέμα Γ, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Ένα ξενοδοχείο χρεώνει την ενοικίαση των δωματίων του ανάλογα με τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, σύμφωνα με τον παρακάτω πίνακα:

ΑΡΙΘΜΟΣ ΗΜΕΡΝ ΤΟΥΡΙΣΤΙΚΗ ΠΕΡΙΟΔΟΣ
ΧΑΜΗΛΗ ΥΨΗΛΗ
1-3 40€ ανά ημέρα 70€ ανά ημέρα
4-7 30€ ανά ημέρα 55€ ανά ημέρα
>7 25€ ανά ημέρα 50€ ανά ημέρα

Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Γ 1.       Nα περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Γ2.       Για καθεμιά από τις 500 κρατήσεις του ξενοδοχείου κατά το προηγούμενο έτος:
α. Να διαβάζει τον αριθμό των ημερών ενοικίασης καθώς και την τουριστική περίοδο που έγινε η κράτηση, εξασφαλίζοντας ότι η επιτρεπτή τιμή για την τουριστική περίοδο είναι ΧΑΜΗΛΗ ή ΥΨΗΛΗ.   (μονάδες 3)
β. Να καλεί υποπρόγραμμα με είσοδο τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, το οποίο να υπολογίζει, με βάση τον προηγούμενο πίνακα, τη χρέωση της κράτησης. O υπολογισμός της χρέωσης δεν γίνεται κλιμακωτά.  (μονάδες 2)
γ.     Να εμφανίζει τη χρέωση της κράτησης.  (μονάδα 1)
Μονάδες 6

Γ3.      Nα υπολογίζει και να εμφανίζει τη συνολική χρέωση των κρατήσεων του ξενοδοχείου για καθεμιά τουριστική περίοδο του προηγούμενου έτους.
Μονάδες 4

Γ4.       Nα κατασκευάσετε το υποπρόγραμμα του ερωτήματος Γ2.β.
Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Θέμα Β, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα A, Ερώτημα 4, 2014, Ημερήσια

α.      Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων με εντολές ΓΙΑ. (μονάδες 6)

β.     Ποιος είναι ο ρόλος του συντάκτη σε ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

γ.     Ποιος είναι ο ρόλος του συνδέτη-φορτωτή σε ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

δ.     Ποιος είναι ο ρόλος  του μεταγλωττιστή σε  ένα προγραμματιστικό περιβάλλον; (μονάδες 2)

Μονάδες 12

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

 

Θέμα A, Ερώτημα 3, 2013, Επαναληπτικές, Ημερήσια

Να γράψετε συμπληρωμένο στο τετράδιό σας το ακόλουθο τμήμα αλγορίθμου, το οποίο πραγματοποιεί αναζήτηση όλων των στοιχείων του πίνακα W[10] στον πίνακα S[1000], έτσι ώστε τα στοιχεία του πίνακα W[10] να καταλαμβάνουν συνεχόμενες θέσεις στον πίνακα S[1000]. Ο αλγόριθμος βρίσκει τη θέση i του S, απ’ όπου αρχίζει η πρώτη εμφάνιση των στοιχείων του W[10].

F <- ΨΕΥΔΗΣ
i <- 1
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
j <- Ν + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ……ΤΟΤΕ
F <- ΑΛΗΘΗΣ
ΑΛΛΙΣ
i <i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΣ
ΓΡΑΨΕ ΄ΔΕ ΒΡΕΘΗΚΕ’
ΤΕΛΟΣ_ΑΝ

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα A, Ερώτημα 4, 2013, Επαναληπτικές, Ημερήσια

Πρώτος ονομάζεται ένας φυσικός αριθμός, όταν έχει ακριβώς δύο διαιρέτες: τον εαυτό του και τη μονάδα. Ο παρακάτω αλγόριθμος γράφτηκε, έτσι ώστε να εμφανίζει τους πρώτους αριθμούς από το 2 μέχρι και το 100.

ΑΛΓΟΡΙΘΜΟΣ πρώτοι
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
Μ <i
ΓΙΑ j ΑΠΟ 0 ΜΕΧΡΙ i
ΑΝ i / j = 0 ΤΟΤΕ
Μ <- Μ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ < 3 ΤΟΤΕ ΕΜΦΑΝΙΣΕ i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ πρώτοι
Ο παραπάνω αλγόριθμος έχει λάθη. Να τον γράψετε στο τετράδιό σας, κάνοντας τις απαραίτητες διορθώσεις, ώστε να λειτουργεί σωστά, χωρίς την προσθήκη νέων εντολών.

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Ερώτημα 3, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Να ξαναγράψετε στο τετράδιό σας καθένα από τα παρακάτω τμήματα αλγορίθμου, χρησιμοποιώντας μόνο μία δομή επανάληψης Για … Από …. Μέχρι και χωρίς τη χρήση δομής επιλογής.

(α)
i <- 1
j <- 1
Αρχή_επανάληψης
Εμφάνισε Α[i,j]
i <- i + 1
j <- j + 1
Μέχρις_ότου j > 100
(μονάδες 4)
(β)
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i = 50 τότε
Εμφάνισε Α[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης
(μονάδες 4)

Μονάδες 8

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια