Επιλογή Σελίδας

Θέμα A, Ερώτημα 3, 2017, Ημερήσια

i <– 0
k <–  12
Όσο i<=k επανάλαβε
         i <– i+2
         k <– k-1
         Γράψε i,k
Τέλος_επανάληψης
Να μεταφέρετε στο τετράδιό σας τον παρακάτω πίνακα και να συμπληρώσετε τις τιμές των μεταβλητών που θα εμφανίζει το παραπάνω απόσπασμα αλγορίθμου σε κάθε επανάληψη:

Οθόνη (εμφάνιση των i και k)

Επανάληψη 1
Επανάληψη 2

Μονάδες 10

Παράδειγμα 2, Κεφάλαιο 8, Βιβλίο, Άθροισμα και Πλήθος αριθμών

Να γραφεί πρόγραμμα το οποίο διαβάζει από το πληκτρολόγιο μία σειρά μετρήσεων, ακεραίων μη μηδενικών αριθμών, υπολογίζει και τυπώνει το άθροισμά τους καθώς και το μέσο τους όρο. Ως τέλος της διαδικασίας εισαγωγής στοιχείων χρησιμοποιείται η τιμή 0.

ΠΡΟΓΡΑΜΜΑ Άθροισμα1  !Παρόραμα - ίδιο όνομα μεταβλητής
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ 
ΑΡΧΗ 
Πλήθος <--0 
Άθροισμα <-- 0 
ΓΡΑΨΕ 'Δώσε Αριθμό' 
ΔΙΑΒΑΣΕ Χ 
ΟΣΟ Χ<>0 ΕΠΑΝΑΛΑΒΕ 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Δώσε Αριθμό' 
    ΔΙΑΒΑΣΕ Χ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Πλήθος >0 ΤΟΤΕ  
   ΜΟ <-- Άθροισμα/Πλήθος 
   ΓΡΑΨΕ 'Το Άθροισμα είναι : ', Άθροισμα 
   ΓΡΑΨΕ 'Ο Μέσος όρος είναι : ', ΜΟ
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Δεν δόθηκαν στοιχεία' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παρατηρήσεις:

Η χρήση τιμών για τον τερματισμό μίας επαναληπτικής διαδικασίας, όπως στο παράδειγμα η αυθαίρετη επιλογή του 0, είναι συνήθης στον προγραμματισμό. Η τιμή αυτή ορίζεται από τον προγραμματιστή και αποτελεί μια σύμβαση για το τέλος του προγράμματος. Η τιμή αυτή είναι τέτοια, ώστε να μην είναι λογικά σωστή για το πρόβλημα, για παράδειγμα η τιμή 0 αποκλείεται από τις μετρήσεις σύμφωνα με την εκφώνηση του παραδείγματος. Η τιμή αυτή συχνά αποκαλείται «τιμή φρουρός«.

*Το όνομα του προγράμματος Άθροισμα (όπως υπάρχει στο βιβλίο) έχει το ίδιο όνομα με μεταβλητή που χρησιμοποιείται μέσα στο πρόγραμμα. (παρόραμα). Έγινε Άθροισμα1.

 

Θέμα Α, Ερώτημα 4, 2016, Επαναληπτικές, Νέο

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές

Θέμα Α, Ερώτημα 2, 2015, Επαναληπτικές, Ημερήσια

α. Να αιτιολογήσετε γιατί ένα από τα πλεονεκτήματα του τμηματικού προγραμματισμού είναι το ότι απαιτεί λιγότερο χρόνο και προσπάθεια στη συγγραφή του προγράμματος   (μονάδες  2).

βΝα γράψετε τη σύνταξη της εντολής ΟΣΟ…  ΕΠΑΝΑΛΑΒΕ (μονάδα  1)
και να περιγράψετε τη λειτουργία της   (μονάδες  3).

Μονάδες  6

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΑΠΑΝΤΗΣΗ (περισσότερα…)

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 3, 2013, Επαναληπτικές, Ημερήσια

Να γράψετε συμπληρωμένο στο τετράδιό σας το ακόλουθο τμήμα αλγορίθμου, το οποίο πραγματοποιεί αναζήτηση όλων των στοιχείων του πίνακα W[10] στον πίνακα S[1000], έτσι ώστε τα στοιχεία του πίνακα W[10] να καταλαμβάνουν συνεχόμενες θέσεις στον πίνακα S[1000]. Ο αλγόριθμος βρίσκει τη θέση i του S, απ’ όπου αρχίζει η πρώτη εμφάνιση των στοιχείων του W[10].

F <- ΨΕΥΔΗΣ
i <- 1
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
ΟΣΟ …… ΚΑΙ ……ΕΠΑΝΑΛΑΒΕ
j <- Ν + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ……ΤΟΤΕ
F <- ΑΛΗΘΗΣ
ΑΛΛΙΣ
i <i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΣ
ΓΡΑΨΕ ΄ΔΕ ΒΡΕΘΗΚΕ’
ΤΕΛΟΣ_ΑΝ

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Β, 2013, Επαναληπτικές, Ημερήσια

Να μετατραπεί το παρακάτω διάγραμμα ροής σε ισοδύναμο αλγόριθμο με ψευδογλώσσα.

themav2013epanhmer

Μονάδες 11

Β2. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παραπάνω αλγορίθμου.

Μονάδες 9

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα A, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη.

  1. Ένας πίνακας έχει σταθερό περιεχόμενο αλλά μεταβλητό μέγεθος.
  2. Οι εντολές που βρίσκονται μέσα σε εντολή επανάληψης «Όσο … επανάλαβε» εκτελούνται τουλάχιστον μία φορά.
  3. Η χρήση των πινάκων σε ένα πρόγραμμα αυξάνει την απαιτούμενη μνήμη.
  4. Οι δυναμικές δομές δεδομένων αποθηκεύονται πάντα σε συνεχόμενες θέσεις μνήμης.
  5. Η μέθοδος επεξεργασίας «πρώτο μέσα πρώτο έξω» (FIFO) εφαρμόζεται στη δομή δεδομένων ΟΥΡΑ.

Μονάδες 5

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, το οποίο εμφανίζει τα τετράγωνα των περιττών αριθμών από το 99 μέχρι το 1 με φθίνουσα σειρά.

Για i από 99 μέχρι 1 μεβήμα -2
x <- i ^2
εμφάνισε x
Τέλος
επανάληψης

α. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Όσο … επανάλαβε».

(μονάδες 5)

β. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Αρχήεπανάληψης … Μέχριςότου».

(μονάδες 5)

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η τιμή μιας μεταβλητής και ο τύπος της μπορούν να αλλάζουν κατά την εκτέλεση ενός προγράμματος.
  2. Όταν υπάρχουν δυο βρόχοι, ο ένας εμφωλευμένος μέσα στον άλλο, αυτός που ξεκινάει τελευταίος πρέπει να ολοκληρώνεται πρώτος.
  3. Μια διαφορά της εντολής Όσο σε σχέση με την εντολή Μέχρις_ότου οφείλεται στη θέση της λογικής συνθήκης στη ροή εκτέλεσης των εντολών.
  4. Αν Α=2, Β=3, Γ=4 και Δ=ΑΛΗΘΗΣ, τότε η τιμή της έκφρασης (Β*Γ>Α+Β) ΚΑΙ (ΟΧΙ(Δ)) είναι ΑΛΗΘΗΣ.
  5. Κατά την εκτέλεση της εντολής ΔΙΑΒΑΣΕ, το πρόγραμμα διακόπτει την εκτέλεσή του και περιμένει την εισαγωγή τιμών από το πληκτρολόγιο.
  6. Οι πίνακες δεν μπορούν να έχουν περισσότερες από δύο διαστάσεις.

Μονάδες 6