Επιλογή Σελίδας

Παράδειγμα 1, Κεφάλαιο 8, Τετράδιο Εργασιών, Μέτρηση Ατμοσφαιρικών Ρύπων

Για τη μέτρηση της ποιότητας της ατμόσφαιρας στην Αθήνα, όπως και σε κάθε μεγάλη πόλη που έχει πρόβλημα μόλυνσης της ατμόσφαιρας, μετρούνται συνεχώς τα επίπεδα συγκεκριμένων βλαβερών συστατικών της, που είναι γνωστά ως ρύποι. Οι ρύποι αυτοί είναι το διοξείδιο του αζώτου (ΝO2), το μονοξείδιο του άνθρακα (CO), το διοξείδιο του θείου (SO2), το όζον (O3) και ο καπνός. Για τον περιορισμό της ρύπανσης σε περιπτώσεις που σημειώνεται σημαντική αύξηση των τιμών των ρύπων χρησιμοποιούνται τα όρια εκτάκτων μέτρων. Τα όρια αυτά που ισχύουν για την περιοχή της Αθήνας για δύο από τους πλέον συχνά εμφανιζόμενους ρύπους O3 και ΝO2 παρουσιάζονται στον παρακάτω πίνακα.

Να γραφεί πρόγραμμα το οποίο διαβάζει τις τιμές του ΝΟ2 και του Ο3 και να τυπώνει το αντίστοιχο μήνυμα σύμφωνα με τον παρακάτω πίνακα.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ρύποι 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:ΝO2, O3 
ΑΡΧΗ 
ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου' 
ΔΙΑΒΑΣΕ ΝO2 
ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος'
ΔΙΑΒΑΣΕ O3 
ΑΝ ΝO2>700 Ή O3 > 500 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ' 
ΑΛΛΙΩΣ_ΑΝ ΝO2 > 500 Ή O3 > 300 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
ΑΛΛΙΩΣ_ΑΝ ΝO2 > 400 Ή O3 > 250 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Ρύποι μέσα στα όρια' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 2, Κεφάλαιο 8, Τετράδιο Εργασιών, Κλίμακα χρέωσης κατανάλωσης νερού (λογαριασμός νερού)

Ο λογαριασμός του νερού είναι τριμηνιαίος και υπολογίζεται με βάση την κατανάλωση νερού. Η αξία του νερού υπολογίζεται από τον παρακάτω πίνακα.

Στην αξία του νερού προστίθεται το πάγιο (έστω 1,47€), η αποχέτευση 40% της αξίας του νερού, άλλες επιβαρύνσεις 1% καθώς και το ΦΠΑ που είναι 18% στο σύνολο του λογαριασμού. Να γραφεί πρόγραμμα που διαβάζει το ονοματεπώνυμο του καταναλωτή, τον αριθμό του μετρητή νερού, την κατανάλωση (ανά τρίμηνο) και να υπολογίζει και να τυπώνει τα ποσά του λογαριασμού. Η διαδικασία επαναλαμβάνεται συνεχώς για διάφορους καταναλωτές και τερματίζεται με την είσοδο του 0 ως αριθμού μετρητή.

ΛΥΣΗ

Παραθέτουμε τη λύση του, μέ τη χρήση ΑΛΛΙΩΣ ΑΝ (αντί της ΕΠΙΛΕΞΕ)

ΠΡΟΓΡΑΜΜΑ ΛΟΓΑΡΙΑΣΜΟΣ_ΝΕΡΟΥ 
ΣΤΑΘΕΡΕΣ 
ΦΠΑ=0.18 
ΤΙΜΗ1=0,34 
ΤΙΜΗ2=0,52 
ΤΙΜΗ3=1,51 
ΤΙΜΗ4=2,11 
ΤΙΜΗ5=2,64 
ΠΑΓΙΟ=1,47 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Μετρητής 
ΠΡΑΓΜΑΤΙΚΕΣ: Κατανάλωση, Τιμή, Αποχέτευση, Άλλα, Αξία_ΦΠΑ, Αξία, & Τελική_Τιμή 
ΧΑΡΑΚΤΗΡΕΣ: Όνομα, Επώνυμο 
ΑΡΧΗ 
ΓΡΑΨΕ 'Δώσε Αριθμό του μετρητή (0 για τέλος)' 
ΔΙΑΒΑΣΕ Μετρητής 
ΟΣΟ Μετρητής <> 0 ΕΠΑΝΑΛΑΒΕ 
    ΓΡΑΨΕ 'Δώσε το Ονοματεπώνυμο'
    ΔΙΑΒΑΣΕ Επώνυμο, Όνομα 
    ΓΡΑΨΕ 'Δώσε την Κατανάλωση' 
    ΔΙΑΒΑΣΕ Κατανάλωση 
    ΑΝ Κατανάλωση <= 15 ΤΟΤΕ
       Αξία <- Κατανάλωση*ΤΙΜΗ1 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 60 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + (Κατανάλωση-15)*ΤΙΜΗ2 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 81 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + 45*ΤΙΜΗ2 + (Κατανάλωση-60)*ΤΙΜΗ3 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 105 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + 45*ΤΙΜΗ2 + 21*ΤΙΜΗ3 + (Κατανάλωση-81)*ΤΙΜΗ4 
    ΑΛΛΙΩΣ 
       Αξία <- 15*ΤΙΜΗ1+45*ΤΙΜΗ2+21*ΤΙΜΗ3+24*ΤΙΜΗ4+(Κατανάλωση-105)*ΤΙΜΗ5 
    ΤΕΛΟΣ_ΑΝ 
    Αποχέτευση <- Αξία*0.4 
    Άλλα <- Αξία*0.01 Τιμή <- Αξία+ Αποχέτευση+ Άλλα+ ΠΑΓΙΟ 
    Αξία_ΦΠΑ <- Τιμή* ΦΠΑ Τελική_τιμή <- Τιμή + Αξία_ΦΠΑ 
    ΓΡΑΨΕ 'Ο λογαριασμός του', Επώνυμο,' είναι ', Τελική_τιμή 
    ΓΡΑΨΕ 'Αξία νερού:', Αξία ΓΡΑΨΕ 'άλλα:', Αποχέτευση+ Άλλα, 'ΦΠΑ:', Αξία_ΦΠΑ 
    ΓΡΑΨΕ 'Δώσε Αριθμό του επόμενου μετρητή (0 για τέλος)' 
    ΔΙΑΒΑΣΕ Μετρητής 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 8, Τετράδιο Εργασιών, Βολή μπάλας στον αέρα, μεταβολή γωνίας βολής και αρχικής ταχύτητας

Στο παράδειγμα 1 του προηγούμενου κεφαλαίου με την μπάλα που εκτοξεύεται στον αέρα η γωνία βολής μπορεί να μεταβάλλεται από 20 έως 80 μοίρες σε βήματα των 10 μοιρών. Επίσης η αρχική ταχύτητα μπορεί να μεταβάλλεται από 10 μ/sec έως 40 μ/sec σε βήματα των 10 μ/sec. Να γραφεί πρόγραμμα που να υπολογίζει την οριζόντια απόσταση (το βεληνεκές) για κάθε συνδυασμό γωνίας και αρχικής ταχύτητας.

ΠΡΟΓΡΑΜΜΑ Τροχιά_μπάλας2 
ΣΤΑΘΕΡΕΣ 
G = 9.81 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ:V0,VX0,VY0,Θ, Βεληνεκές 
ΑΡΧΗ 
ΓΙΑ Θ ΑΠΟ 20 ΜΕΧΡΙ 80 ΜΕ ΒΗΜΑ 10 
    ΓΡΑΨΕ 'Γωνία:',Θ 
    ΓΙΑ V0 ΑΠΟ 10 ΜΕΧΡΙ 40 ΜΕ ΒΗΜΑ 10
        VX0 <-- V0*ΣΥΝ(Θ) 
        VY0 <-- V0*ΗΜ(Θ) 
        Βεληνεκές <-- 2*VX0*VY0/G
        ΓΡΑΨΕ 'Ταχύτητα:',V0,'Βεληνεκές:',Βεληνεκές 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ