Επιλογή Σελίδας

Παράδειγμα 1, Κεφάλαιο 9, Βιβλίο, Θερμοκρασίες μήνα σε πίνακα

Για παράδειγμα ένα πρόγραμμα το οποίο διαβάζει τις θερμοκρασίες διαφόρων ημερών του μήνα, έστω 30, και υπολογίζει τη μέση θερμοκρασία, μπορεί πολύ απλά να γραφεί ως εξής:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο  
ΑΚΕΡΑΙΕΣ: i, Ημέρες 
ΑΡΧΗ  
Σύνολο <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΓΡΑΨΕ 'Δώσε τη θερμοκρασία'  
    ΔΙΑΒΑΣΕ Θερμοκρασία[i]   
    Σύνολο <-- Σύνολο+ Θερμοκρασία[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ  
Μέση <-- Σύνολο/30  
Ημέρες <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΑΝ Θερμοκρασία[i] < Μέση ΤΟΤΕ    
       Ημέρες <-- Ημέρες+1  
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Μέση Θερμοκρασία:', Μέση 
ΓΡΑΨΕ 'Ημέρες με μικρότερη θερμοκρασία', Ημέρες 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 2, Κεφάλαιο 9, Βιβλίο, Στατιστικά μεγέθη στοιχείων πίνακα, μέση τιμή, τυπική απόκλιση, διάμεσος τιμή

Να γραφεί πρόγραμμα το οποίο να υπολογίζει τα βασικά στατιστικά μεγέθη, τη μέση τιμή, την τυπική απόκλιση και τη διάμεσο τιμή Ν ακεραίων αριθμών, όπου το Ν είναι από 2 μέχρι 100.
Τα δεδομένα εισάγονται από το πληκτρολόγιο και καταχωρούνται στον πίνακα Χ.

Η μέση τιμή μ δίνεται από τον τύπο  

Η τυπική απόκλιση σ δίνεται από τον τύπο 

Για να βρεθεί η διάμεσος τιμή πρέπει υποχρεωτικά οι αριθμοί να ταξινομηθούν κατά αύξουσα σειρά. Τότε διάμεσος τιμή, είναι η τιμή για την οποία οι μισοί αριθμοί είναι μικρότεροι και οι άλλοι μισοί μεγαλύτεροι. Στην περίπτωση που το πλήθος των αριθμών είναι περιττό, τότε διάμεσος είναι ο μεσαίος, ενώ στην περίπτωση που είναι άρτιο, τότε διάμεσος είναι το ημιάθροισμα των δύο μεσαίων αριθμών. Η ταξινόμηση των στοιχείων γίνεται με τη μέθοδο ταξινόμησης ευθείας ανταλλαγής, η οποία παρουσιάστηκε στο κεφάλαιο 3.

ΠΡΟΓΡΑΜΜΑ Στατιστική 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ : i, Ν, Χ[100], Άθροισμα, Άθροισμα_2, Βοηθητική, ΝΖ, ΝΜ, j ! Παρόραμα δεν δηλώθηκε η j
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΤ, Τυπ_Απόκλιση, Διάμεσος 
ΑΡΧΗ 
! Εισαγωγή δεδομένων 
ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)' 
ΔΙΆΒΑΣΕ Ν 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
    ΓΡΑΨΕ 'Δώσε τον ',i,'-το αριθμό' 
    ΔΙΑΒΑΣΕ Χ[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός αθροισμάτων 
Άθροισμα <-- 0 
Άθροισμα_2 <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
   ! ΓΡΑΨΕ 'Δώσε τον',i,'-το αριθμό'  Παρόραμα - Ξαναδιαβάζει τους αριθμούς
   ! ΔΙΑΒΑΣΕ Χ[i] 
    Άθροισμα <-- Άθροισμα + Χ[i] 
    Άθροισμα_2 <-- Άθροισμα_2 + Χ[i]^2 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός μέσου όρου 
ΜΤ <-- Άθροισμα/Ν 
!Υπολογισμός τυπικής απόκλισης 
Τυπ_Απόκλιση <-- Τ_Ρ(Άθροισμα_2/Ν - ΜΤ^2) 
!Ταξινόμηση των στοιχείων του πίνακα 
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν 
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1 
       ΑΝ Χ[j-1] > Χ[j] ΤΟΤΕ 
! Αντιμετάθεση των στοιχείων j και j-1 
      Βοηθητική <-- Χ[j-1] 
      Χ[j-i] <-- Χ[j] 
      Χ[j] <-- Βοηθητική 
      ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! j 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! i 
!Υπολογισμός διαμέσου
ΝΖ <--Ν DIV 2
ΝΜ <--(Ν DIV 2) + 1
ΑΝ Ν MOD 2 =0 ΤΟΤΕ 
   Διάμεσος <-- (Χ[Ν div 2]+Χ[(Ν div 2)]+1)/2 !Παρόραμα - Πρόβλημα με την δήλωση τύπου του Ν
ΑΛΛΙΩΣ 
   Διάμεσος <-- Χ[(Ν+1)div 2] ! Παρόραμα
ΤΕΛΟΣ_ΑΝ 
! Εκτύπωση αποτελεσμάτων 
ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ' 
ΓΡΑΨΕ '============' 
ΓΡΑΨΕ 'Πλήθος τιμών =', Ν 
ΓΡΑΨΕ 'Μέση τιμή = ', ΜΤ 
ΓΡΑΨΕ 'Τυπική απόκλιση = ', Τυπ_Απόκλιση 
ΓΡΑΨΕ 'Διάμεσος = ', Διάμεσος 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράδειγμα 3, Κεφάλαιο 9, Βιβλίο, Μέση Θερμοκρασία πόλεων

Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον προηγούμενο πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες 10 πόλεων). Επίσης, για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση.

ΛΥΣΗ (περισσότερα…)

Παράδειγμα 4, Κεφάλαιο 9, Βιβλίο, Εισπράξεις κινηματογράφων

Να γραφεί πρόγραμμα το οποίο:
α. Να διαβάζει τα ονόματα δέκα κινηματογράφων και τις αντίστοιχες εισπράξεις τους για κάθε ημέρα μίας εβδομάδας.
β. Να υπολογίζει και να εκτυπώνει το άθροισμα των εισπράξεων κάθε κινηματογράφου, καθώς και τον κινηματογράφο με τη μέγιστη συνολική είσπραξη.
γ. Να υπολογίζει και να εκτυπώνει το άθροισμα των εισπράξεων κάθε ημέρας, καθώς και την ημέρα με τη μέγιστη συνολική είσπραξη.

Για την επίλυση του προβλήματος πρέπει να χρησιμοποιηθούν δύο πίνακες. Ο πρώτος θα περιέχει μόνο τα ονόματα των κινηματογράφων, θα είναι δηλαδή ένας μονοδιάστατος πίνακας χαρακτήρων με δέκα γραμμές. Ο δεύτερος θα περιέχει τις εισπράξεις, θα είναι ένας πίνακας δισδιάστατος ακεραίων αριθμών με δέκα γραμμές, μία για κάθε κινηματογράφο και επτά στήλες, μία για κάθε ημέρα. Το πρόγραμμα ουσιαστικά αποτελείται από τρία τμήματα:

  1. Την ανάγνωση των δεδομένων και την καταχώρησή του στους αντίστοιχους πίνακες, Ονόματα και Εισπράξεις.
  2. Τον υπολογισμό του συνόλου των εισπράξεων ανά κινηματογράφο και την εύρεση της μέγιστης συνολικής είσπραξης, δηλαδή του αθροίσματος των γραμμών του πίνακα.
  3. Τον υπολογισμό του συνόλου των εισπράξεων ανά ημέρα και την εύρεση της μέγιστης συνολικής είσπραξης, δηλαδή του αθροίσματος των στηλών του πίνακα.

Προσέξτε τις διαφορές του δεύτερου και του τρίτου τμήματος. Και οι δύο χρησιμοποιούν δύο εμφωλευμένους βρόχους, ένα για τις γραμμές και ένα για τις στήλες αλλά σε διαφορετική σειρά.

ΛΥΣΗ (περισσότερα…)