ΘΕΜΑ Α4, 2017, Επαναληπτικές

Να γράψετε στο τετράδιό σας:

α. Έναν αριθμητικό τελεστή
β. Έναν συγκριτικό τελεστή
γ. Έναν λογικό τελεστή
δ. Μια αριθμητική σταθερά
ε. Μια λογική μεταβλητή
στ. Μια απλή λογική έκφραση
ζ. Μια σύνθετη λογική έκφραση
από το παρακάτω τμήμα αλγορίθμου:

Α <- 1
Β <- Ψευδής
Σ <- 10
Αρχή_επανάληψης 
   Σ <- Σ+Α
   Αν Σ MOD 3 = 1 τότε
      Β <- Όχι Β
      Α <- Α+2 
   Αλλιώς
      Α <- Α+3
  Τέλος_αν
Μέχρις_ότου Β ή Σ>100

Μονάδες 7

 

ΘΕΜΑ Β2, 2017, Επαναληπτικές

Β2. Δίνεται μονοδιάστατος πίνακας Π[6] με τις τιμές που φαίνονται παρακάτω.

1 2 3 4 5 6
18 29 40 51 62 73

Για την αναζήτηση μιας τιμής στον πίνακα Π δίνεται το παρακάτω τμήμα αλγόριθμου:

Διάβασε Χ 
Θέση <- 0 
Βρέθηκε <- Ψευδής Υπάρχει <- Αληθής 
i <- 1
Αρχή_επανάληψης 
   Αν Π[i]=Χ τότε
      Βρέθηκε <- Αληθής 
      Θέση<- i 
   Αλλιώς_αν Π[i]>Χ τότε
      Υπάρχει <- Ψευδής 
   Τέλος_αν
   i <- i +1 
Μέχρις_ότου i>6 ή Βρέθηκε = Αληθής ή Υπάρχει = Ψευδής

Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.
 

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Ερώτημα 5, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω ημιτελής αλγόριθμος αναζήτησης ενός αριθμού key σε έναν αριθμητικό πίνακα table N στοιχείων, στον οποίο ο key μπορεί να εμφανίζεται περισσότερες από μία φορές.
Αλγόριθμος Αναζήτηση
Δεδομένα // table, N, key //
Βρέθηκε <- Ψευδής
ΔενΒρέθηκε <- ……………………….
i <- 1
Όσο ΔενΒρέθηκε = Αληθής και i<=N επανάλαβε
Αν…………………….. τότε
Εμφάνισε “Βρέθηκε στη θέση”, i
Βρέθηκε <-   ……………………..
Αλλιώς_αν ………………………  τότε
ΔενΒρέθηκε <- ……………………….
Τέλος_αν
i <- i + 1
Τέλος_επανάληψης
Αποτελέσματα // Βρέθηκε //
Τέλος Αναζήτηση
Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο με τα κενά συμπληρωμένα, έτσι ώστε να εμφανίζονται όλες οι θέσεις στις οποίες βρίσκεται ο αριθμός key στον πίνακα table. Ο αλγόριθμος να σταματάει αμέσως μόλις διαπιστωθεί ότι ο αριθμός key δεν υπάρχει στον πίνακα. Εκμεταλλευτείτε το γεγονός ότι τα στοιχεία του πίνακα είναι ταξινομημένα σε αύξουσα σειρά.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Θέμα Β, 2010, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές:

  1. j<-1
  2. i<-2
  3. Αρχή_επανάληψης
  4. i<-i + j
  5. j<-i – j
  6. Εμφάνισε i
  7. Μέχρις_ότου i ≥ 5

Επίσης δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής συνθήκη έξοδος i j

Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ,   εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
Στη συνέχεια του πίνακα υπάρχει μια στήλη για κάθε μεταβλητή του αλγόριθμου.
Να  μεταφέρετε  τον  πίνακα  στο  τετράδιό σας και να τον συμπληρώσετε     εκτελώντας τις εντολές του τμήματος αλγορίθμου ως εξής:
Για κάθε εντολή που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμά της στην αντίστοιχη στήλη.
Σημείωση: Η εντολή της γραμμής 3 δεν χρειάζεται να αποτυπωθεί στον πίνακα.

Μονάδες 20

ΛΥΣΗ (περισσότερα…)

Ερώτημα 3, Θέμα Α, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Αν Α≥5 τότε
     Αν Β<7 τότε
Α←Α+1
     αλλιώς
Α←Α-1
     Τέλος_αν
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

Επίσης δίνονται παρακάτω δύο τμήματα αλγορίθμων από τα οποία λείπουν οι συνθήκες:

α.  Αν ………………….  τότε
Α←Α+1
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

β.   Αν………………… τότε
Α<-Α-1
      αλλιώς
Α<-Α+1
      Τέλος_αν
      Εμφάνισε Α

Να γράψετε στο τετράδιό σας τις συνθήκες που λείπουν, ώστε κάθε ένα από τα τμήματα α, β να εμφανίζει το ίδιο αποτέλεσμα με το αρχικό.

Μονάδες 10

 

Ερώτημα 4, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση
Δεδομένα //Π,Ν,Χ//
flag <- ψευδής
Ι <- 1
Όσο   Ι ≤ Ν  και   flag=ψευδής  επανάλαβε
          Αν Π[Ι]=Χ  τότε
flag <- αληθής
         Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //flag//
Τέλος Αναζήτηση

  1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών; (Μονάδες 2)

Να αιτιολογήσετε την απάντησή σας. (Μονάδες 3)

Μονάδες 5

  1. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Θέμα Γ, 2002, Επαναληπτικές

Σε ένα κέντρο νεοσύλλεκτων υπάρχει η πρόθεση να δημιουργηθούν δύο ειδικές διμοιρίες. Η διμοιρία Α θα αποτελείται από νεοσύλλεκτους πτυχιούχους τριτοβάθμιας εκπαίδευσης, ηλικίας από 24 έως και 28 χρόνων. Η διμοιρία Β θα αποτελείται από νεοσύλλεκτους απόφοιτους δευτεροβάθμιας εκπαίδευσης, ηλικίας από 18 έως και 24 χρόνων. Οι υπόλοιποι νεοσύλλεκτοι δεν κατατάσσονται σε καμία από αυτές τις διμοιρίες. Να αναπτύξετε αλγόριθμο ο οποίος:

α. διαβάζει το ονοματεπώνυμο, την ηλικία και έναν αριθμό που καθορίζει το επίπεδο σπουδών του νεοσύλλεκτου και παίρνει τιμές από 1 έως 3 (1: τριτοβάθμια εκπαίδευση, 2: δευτεροβάθμια εκπαίδευση, 3: κάθε άλλη περίπτωση)
Μονάδες 5

β. εκτυπώνει:
i) το ονοματεπώνυμο του νεοσύλλεκτου ii) το όνομα της διμοιρίας (Α ή Β), εφόσον ο νεοσύλλεκτος κατατάσσεται σε μία από αυτές.
Μονάδες 15

ΛΥΣΗ: (περισσότερα…)