Μονοδιάστατοι Πινακες

1.SUM,MIN,MAX |2.ΘΕΣΗ ΜΙΝ(MAX) |3.ΑΝΑΖΗΤΗΣΗ | 4.ΑΝΑΖΗΤΗΣΗ,ΠΛΗΘΟΣ | 5.ΑΝΑΖΗΤΗΣΗ,ΠΛΗΘΟΣ,ΘΕΣΕΙΣ | 6.ΑΝΑΖΗΤΗΣΗ,ΤΑΞΙΝΟΜΗΜΕΝΟΣ |7.ΕΝΩΣΗ |8.ΔΙΑΧΩΡΙΣΜΟΣ | 9 | 10 | 11 |12 |13 | 14.ΣΥΓΧΩΝΕΥΣΗ

Άσκηση 1.
Δίνεται ο αρχικός πίνακας Α[9] = [3, 4, 7, 10, 11, 6, 4, 2, 9]. Να υπολογιστεί το άθροισμα των στοιχείων του, κατόπιν το μέγιστο και ελάχιστο στοιχείο του. (Άθροισμα, ελάχιστο, μέγιστο στοιχείων πίνακα).

ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ_ΜΙΝ_ΜΑΧ_ΜΟΝΟΔΙΑΣΤΑΤΟΥ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[9], i
ΑΡΧΗ
Α[1] <-   3
Α[2] <-   4
Α[3] <-   7
Α[4] <-   10
Α[5] <-   11
Α[6] <-   6
Α[7] <-   4
Α[8] <-   2
Α[9] <-   9
! ΆΘΡΟΙΣΜΑ ΣΤΟΙΧΕΙΩΝ ΜΟΝΟΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ
SUM <-   0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 9 
SUM <-  SUM + A[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! ΕΥΡΕΣΗ ΜΙΝ ΣΤΟΙΧΕΙΟΥ  ΜΟΝΟΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ
ΜΙΝ <-   Α[1]
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 9 
ΑΝ A[i] < ΜΙΝ ΤΟΤΕ
ΜΙΝ <-   A[i]
ΤΕΛΟΣ_ΑΝ  
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! ΕΥΡΕΣΗ ΜΑΧ ΣΤΟΙΧΕΙΟΥ  ΜΟΝΟΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ
ΜΑΧ <-   Α[1]
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 9 
ΑΝ A[i] > ΜΑΧ ΤΟΤΕ
ΜΑΧ <-   A[i]
ΤΕΛΟΣ_ΑΝ  
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 2.
Επέκταση στην άσκηση 1, να εμφανίσετε σε ποια θέση βρίσκεται το ελάχιστο και το μέγιστο στοιχείο

! ΤΡΟΠΟΠΟΙΗΣΗ ΤΟΥ ΤΜΗΜΑΤΟΣ ΚΩΔΙΚΑ ΑΣΚΗΣΗΣ 1
! ΕΥΡΕΣΗ ΜΙΝ (ΜΑΧ) ΣΤΟΙΧΕΙΟΥ ΜΟΝΟΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ
ΜΙΝ (ΜΑΧ) <- Α[1]
ΘΕΣΗ <- 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 9 
    ΑΝ A[i] < (>) ΜΙΝ (ΜΑΧ) ΤΟΤΕ
       ΜΙΝ (ΜΑΧ) <-   A[i]
       ΘΕΣΗ <-  i
    ΤΕΛΟΣ_ΑΝ  
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Άσκηση 3.
Να διαβάσετε ένα στοιχείο από το πληκτρολόγιο και να ελέγξετε αν υπάρχει στον πίνακα Α[9] = [10, 7, 4, 0, 11, 6, -24, 2, 9]. (Αναζήτηση ύπαρξης στοιχείου σε πίνακα)

ΠΡΟΓΡΑΜΜΑ ΥΠΑΡΞΗ_ΣΤΟΙΧΕΙΟΥ_ΜΟΝΟΔΙΑΣΤΑΤΟΥ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[9], i
ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ
Α[1] <-  10
Α[2] <-  7
Α[3] <-  4
Α[4] <-  0
Α[5] <-  11
Α[6] <-  6
Α[7] <-  - 24
Α[8] <-  2
Α[9] <-  9
! ΥΠΑΡΞΗ ΣΤΟΙΧΕΙΟΥ ΣΕ ΜΟΝΟΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ
ΔΙΑΒΑΣΕ ΣΤΟΙΧΕΙΟ
!Α ΤΡΟΠΟΣ
i <-  1
ΒΡΕΘΗΚΕ <-  ΨΕΥΔΗΣ
ΟΣΟ ΒΡΕΘΗΚΕ = ΨΕΥΔΗΣ ΚΑΙ Ι <= 9 ΕΠΑΝΑΛΑΒΕ 
    ΑΝ ΣΤΟΙΧΕΙΟ <> A[i] ΤΟΤΕ 
       i <-   i + 1
    ΑΛΛΙΩΣ 
       ΒΡΕΘΗΚΕ <-  ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΒΡΕΘΗΚΕ = ΑΛΗΘΗΣ ΤΟΤΕ 
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ”
ΑΛΛΙΩΣ
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΔΕ ΒΡΕΘΗΚΕ”
ΤΕΛΟΣ_ΑΝ

!Β ΤΡΟΠΟΣ
i <- 1
ΟΣΟ ΣΤΟΙΧΕΙΟ <> A[i] ΚΑΙ Ι <= 9 ΕΠΑΝΑΛΑΒΕ 
    i <- i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ i > 9 ΤΟΤΕ 
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ”
ΑΛΛΙΩΣ
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΔΕ ΒΡΕΘΗΚΕ”
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 4.
Επέκταση της άσκησης 3, να ελέγξετε αν και πόσες φορές υπάρχει το στοιχείο που αναζητάτε. (Αναζήτηση ύπαρξης και πλήθους στοιχείου σε πίνακα)

! ΤΡΟΠΟΠΟΙΗΣΗ ΤΜΗΜΑΤΟΣ ΑΣΚΗΣΗΣ 3
ΠΛΗΘΟΣ <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 9 
    ΑΝ ΣΤΟΙΧΕΙΟ = A[i] ΤΟΤΕ 
       ΠΛΗΘΟΣ <-  ΠΛΗΘΟΣ + 1
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΠΛΗΘΟΣ > 0 ΤΟΤΕ 
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ ”, ΠΛΗΘΟΣ, “ ΦΟΡΕΣ‘
ΑΛΛΙΩΣ
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΔΕ ΒΡΕΘΗΚΕ”
ΤΕΛΟΣ_ΑΝ

Άσκηση 5.
Επέκταση της άσκησης 3, να ελέγξετε αν, πόσες φορές και σε ποιες θέσεις υπάρχει το στοιχείο που αναζητάτε.(Αναζήτηση ύπαρξης, πλήθους, θέσης στοιχείου σε πίνακα)

ΠΡΟΓΡΑΜΜΑ ΥΠΑΡΞΗ_ΠΛΗΘΟΣ_ΘΕΣΗ_ΣΤΟΙΧΕΙΩΝ_ΜΟΝΟΔΙΑΣΤΑΤΟΥ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[9], ΘΕΣΗ[9], i, j, ΠΛΗΘΟΣ
ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ
Α[1] <-  10
Α[2] <-  7
Α[3] <-  4
Α[4] <-  0
Α[5] <-  11
Α[6] <-  6
Α[7] <-  - 24
Α[8] <-  2
Α[9] <-  9
! ΥΠΑΡΞΗ, ΠΛΗΘΟΣ, ΘΕΣΗ ΣΤΟΙΧΕΙΟΥ ΣΕ ΜΟΝΟΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ
ΔΙΑΒΑΣΕ ΣΤΟΙΧΕΙΟ
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 9 
    ΘΕΣΗ [j] <-  0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
j <-  1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 9 
    ΑΝ ΣΤΟΙΧΕΙΟ = A[i] ΤΟΤΕ 
       ΘΕΣΗ [j] <-  i
       j <-  j + 1
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΠΛΗΘΟΣ <- j - 1
ΑΝ j > 1 ΤΟΤΕ 
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ ”, ΠΛΗΘΟΣ , “ ΦΟΡΕΣ‘
ΑΛΛΙΩΣ
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΔΕ ΒΡΕΘΗΚΕ”
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 6.
Επέκταση της άσκησης 3. Να διαβάσετε ένα στοιχείο από το πληκτρολόγιο και να ελέγξετε αν υπάρχει στον πίνακα Α[9] = [-24, 0, 2, 4, 6, 9, 10, 11] . (Ταξινομημένος σε αύξουσα σειρά)

!ΤΡΟΠΟΠΟΙΗΣΗ ΤΜΗΜΑΤΟΣ ΑΣΚΗΣΗΣ 3
i <-   1
! ΑΞΙΟΠΟΙΩ ΤΟ ΕΧΤRA ΔΕΔΟΜΕΝΟ ΤΩΝ ΤΑΞ.ΣΤΟΙΧΕΊΩΝ
ΟΣΟ ΣΤΟΙΧΕΙΟ <> A[i] ΚΑΙ i <= 9 ΚΑΙ ΣΤΟΙΧΕΙΟ <= A[i] ΕΠΑΝΑΛΑΒΕ 
    i <-   i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ i > 9 ΤΟΤΕ 
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΗΚΕ”
ΑΛΛΙΩΣ
   ΓΡΑΨΕ “ΤΟ ΣΤΟΙΧΕΙΟ ΔΕ ΒΡΕΘΗΚΕ”
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 7.
Δίνονται οι αρχικοί πίνακες Α[5] = [3, 4, 7, 10, 11] και Β[4] = [6, 4, 2, 9]. Να γίνει τελικός πίνακας Γ[9] όπου θα αντιγράφουν στις πρώτες 5 θέσεις τα στοιχεία του πίνακα Α και στις υπόλοιπες τα στοιχεία του πίνακα Β. (Ένωση Πινάκων)

ΠΡΟΓΡΑΜΜΑ ΕΝΩΣΗ_ΠΙΝΑΚΩΝ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[5], Β[4], Γ[9], i, j, k
ΑΡΧΗ
! εισαγωγή στοιχείων πίνακα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΔΙΑΒΑΣΕ Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΔΙΑΒΑΣΕ Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    Γ[i] <-  Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! α τρόπος 
ΓΙΑ i ΑΠΟ 6 ΜΕΧΡΙ 9
    Γ[i] <-  Β[i-5]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! b τρόπος 
j <- 1          ! ξεχωριστός δείκτης για τον πίνακα β
ΓΙΑ i ΑΠΟ 6 ΜΕΧΡΙ 9   (4 επαναλήψεις)
    Γ[i] <-  Β[j] 
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΈΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 8.
Δίνονται οι πίνακες Α[12] και Β[5] και Γ[7]. Να αντιγραφούν τα 5 πρώτα στοιχεία του Α στον Β και τα υπόλοιπα στον Γ. (Διαχωρισμός Πινάκων)

ΠΡΟΓΡΑΜΜΑ ΔΙΑΧΩΡΙΣΜΟΣ_ΠΙΝΑΚΩΝ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[12], Β[5], Γ[7], i, j, k
ΑΡΧΗ
! εισαγωγή στοιχείων πίνακα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12
    ΔΙΑΒΑΣΕ Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
    Β[i] <- Α[i]  
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!α τρόπος
j <- 1
ΓΙΑ i ΑΠΟ 8 ΜΕΧΡΙ 12         ! 5 επαναλήψεις
    Γ[j] <- Α[i]
    j <- j +1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!β τρόπος
ΓΙΑ i ΑΠΟ 8 ΜΕΧΡΙ 12         ! 5 επαναλήψεις
    Γ[i-7] <- Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΈΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 9.
Δίνονται οι πίνακες Α[10] και Β[10] και Γ[20]. Να αντιγραφούν τα στοιχεία του πίνακα Α και Β εναλλάξ στον πίνακα Γ, δηλαδή Γ[1] = Α[1], Γ[2]=Β[1] κοκ.

ΠΡΟΓΡΑΜΜΑ ΜΟΝΟΔΙΑΣΤΑΤΟΙ_9
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[12], Β[5], Γ[7], i, j, k
ΑΡΧΗ
! εισαγωγή στοιχείων πίνακα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΔΙΑΒΑΣΕ Α[i], B[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
j <- 1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 19 ΜΕ ΒΗΜΑ_2
    Γ[i] <- A[j]
    j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
k <- 1
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20 ΜΕ ΒΗΜΑ_2
    Γ[i] <- B[k]
    k <- k+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 10.
Δίνονται οι πίνακες Α[10], Β[10]. Να αντιγραφούν τα στοιχεία του πίνακα Α στον πίνακα Β ως εξής: Β[10]<- Α[1], Β[9]<- Α[2].

ΠΡΟΓΡΑΜΜΑ ΜΟΝΟΔΙΑΣΤΑΤΟΙ_10
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[10], i, B[10], j
ΑΡΧΗ
j <- 10
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Β[j] <- A[i]
    j <- j-1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!β τρόπος (μαθηματική σχέση με τον i)
            ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
  Β[10-i+1]<- A[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 11.
Δίνεται οι πίνακας Α[11]. Να αντιστραφούν τα στοιχεία του πίνακα Α ως προς το στοιχείο 6 ως εξής:
Α[1]<->Α[11], Α[2]<->Α[9], Α[3]<->Α[8], Α[4]<->Α[7], Α[5]<->Α[7].

ΠΡΟΓΡΑΜΜΑ ΜΟΝΟΔΙΑΣΤΑΤΟΙ_11
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[11], i
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    tmp  <- A[i]
    A[i] <- A[11-i+1]
    A[11-i+1] <- temp
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Λύση με βοηθητικό πίνακα
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    B[i] <- A[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
j <- 1
ΓΙΑ i ΑΠΟ 11 ΜΕΧΡΙ 7
   A[j] <- A[i]
   j <- j+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
j <- 1
ΓΙΑ i ΑΠΟ 11 ΜΕΧΡΙ 7
    A[i]<- B[j]
    j<- j+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 12.
Δίνεται ο αρχικός πίνακας Α[6] και ο τελικός Β [12]. Να αντιγραφούν σε διπλότυπα τα στοιχεία του πίνακα Α στον πίνακα Β. Δηλαδή Α[1] = Β [1] = Β [2] κοκ.

ΠΡΟΓΡΑΜΜΑ ΜΟΝΟΔΙΑΣΤΑΤΟΙ_12
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[6], Β[12], i, j
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΔΙΑΒΑΣΕ Α[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! α τρόπος
! j=1,3,5,7,9,11 (6 τιμές)
! j+1=2,4,6,8,10,12

j <- 1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    Β [j] <- Α[i]
    Β [j+1] <- Α[i]
    j <- j + 2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! β τρόπος
! j=1,3,5,7,9,11 (6 τιμές)
j <- 1
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    Β [j] <- Α[i]
j <- j + 2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  j=2,4,6,8,10,12 (6 τιμές)
j <- 2
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    Β [j] <- Α[i]
    j <- j + 2
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 13.
Δίνεται ένας πίνακας Γ[20]. Να αναζητήσετε το στοιχείο key και στη θέση του να διαχωριστεί ο πίνακας σε δυο πίνακες Α και Β. Το key θα είναι το πρώτο στοιχείο του Β (Διαχωρισμός πινάκων).

ΠΡΟΓΡΑΜΜΑ ΜΟΝΟΔΙΑΣΤΑΤΟΙ_13
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α[20], Β[20], Γ[20], i, j, key
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ Γ[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ  key
ΒΡΕΘΗΚΕ ← ΨΕΥΔΗΣ 
i <- 1
ΟΣΟ ΒΡΕΘΗΚΕ = ΨΕΥΔΗΣ ΚΑΙ i<= 20 ΕΠΑΝΑΛΑΒΕ
    AN Γ[i] = key ΤΟΤΕ
       ΒΡΕΘΗΚΕ← ΑΛΗΘΗΣ
       θ <- i
    ΑΛΛΙΩΣ
       i<- i + 1
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΒΡΕΘΗΚΕ =ΑΛΗΘΗΣ ΤΟΤΕ
   !α τρόπος
   i<- 1
   ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ θ-1
       Α[i]<- Γ[k]
       i<- i  + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   !β τρόπος
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ θ-1
       Α[i]<- Γ[i]
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   i<- 1
   ΓΙΑ k ΑΠΟ θ ΜΕΧΡΙ 20
       Β[i]<- Γ[k]
       i<- i  + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 14.
Δίνονται 2 ταξινομημένοι πίνακες Α[Ν] & B[M]. Να ενωθούν σε έναν πίνακα Γ ώστε να είναι επίσης ταξινομημένος. (Συγχώνευση ταξινομημένων πινάκων)

ΠΡΟΓΡΑΜΜΑ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Άσκηση 15.
Δίνεται πίνακας 9 στοιχείων. Κατόπιν δίνεται αριθμός Χ και θέση όπου θα τοποθετηθεί. Να καταχωρηθεί ο Χ μέσα στον πίνακα. (Εισαγωγή στοιχείου σε πίνακα). Παρατήρηση: Ο πίνακας έχει 10 θέσεις και η 10η είναι κενή.

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[10] 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 17.
Δίνεται πίνακας 9 στοιχείων, ταξινομημένος σε αύξουσα σειρά. (Να δοθούν τα στοιχεία του ταξινομημένα απ' το χρήστη). Κατόπιν δίνεται αριθμός Χ. Να καταχωρηθεί ο Χ μέσα στον πίνακα έτσι ώστε να συνεχίσει να είναι ταξινομημένος. Παρατήρηση: Ο πίνακας έχει 10 θέσεις και η 10η είναι κενή. (Εισαγωγή στοιχείου σε ταξινομημένο πίνακα)

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 16.
Να γραφεί πρόγραμμα το οποίο θα διαγράφει ένα στοιχείο από έναν πίνακα. Προσοχή, ίσως το στοιχείο δεν ανήκει στον πίνακα. Ο πίνακας δεν θα έχει κενές θέσεις (Διαγραφή στοιχείου από ταξινομημένο πίνακα)

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
Share This