Επιλογή Σελίδας

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα Β, 2013, Επαναληπτικές, Ημερήσια

Να μετατραπεί το παρακάτω διάγραμμα ροής σε ισοδύναμο αλγόριθμο με ψευδογλώσσα.

themav2013epanhmer

Μονάδες 11

Β2. Να σχεδιάσετε στο τετράδιό σας τον πίνακα Π μαζί με τις τιμές, που θα έχει μετά την εκτέλεση του παραπάνω αλγορίθμου.

Μονάδες 9

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα Β, Ερώτημα 2,2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

er2th2-aepp_2012_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Θέμα B, Ερώτημα 1, 2012, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος
Αλγόριθμος
Διοφαντική
Για x από 0 μέχρι 100
Για y από 0 μέχρι 100
Για z από 0 μέχρι 100
Αν 3*x+2*y-7*z=5 τότε εκτύπωσε x,y,z
         Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Διοφαντική

Να κατασκευάσετε στο τετράδιό σας το διάγραμμα ροής που αντιστοιχεί στον παραπάνω αλγόριθμο.
Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Παράδειγμα 5, Κεφάλαιο 2, Τετράδιο Εργασιών, Φοίτηση στο Πανεπιστήμιο

Σε κάποια Σχολή υπάρχει ένα 3ετές Τμήμα με διαφορετικό αριθμό φοιτητών/φοιτητριών ανά έτος φοίτησης. Συνολικά το Τμήμα αυτό έχει 200 φοιτητές. Να σχεδιασθεί ένα διάγραμμα ροής και να γραφεί ένας αλγόριθμος που θα διαβάζει το έτος κάθε φοιτητή του Τμήματος και θα υπολογίζει τον αριθμό των φοιτητών για κάθε έτος φοίτησης.

Λύση: (περισσότερα…)

ΔΤ9, Κεφάλαιο 2, Τετράδιο Εργασιών

Σε ένα φυτώριο υπάρχουν 3 είδη δένδρων που θα δοθούν για δενδροφύτευση. Το 1ο είδος δένδρου θα δοθεί στην περιοχή της Μακεδονίας, το 2ο στην περιοχή της Θράκης και το 3ο είδος στην περιοχή της Πελοποννήσου. Να σχεδιασθεί το διάγραμμα ροής και να γραφεί ένας αλγόριθμος που θα διαβάζει τον αριθμό του είδους του δένδρου και θα εκτυπώνει την περιοχή στην οποία θα γίνει η δενδροφύτευση.

Λύση:  (περισσότερα…)

ΔΣ2, Κεφάλαιο 2, Τετράδιο Εργασιών

Έστω ότι σου έχουν δώσει ένα μεταχειρισμένο ηλεκτρονικό υπολογιστή για 6 μήνες. Θέλεις να διαπραγματευτείς την τιμή αυτού του υπολογιστή για να δεις αν μπορείς να τον αλλάξεις με κάποιο άλλο μοντέλο. Η αρχική τιμή του υπολογιστή που πήρες είναι 295.600 δρχ. και σου τον προσφέρουν για 256.000 δρχ. Είναι χρήσιμο να υπολογίσεις το ποσοστό της απαξίωσης για τον υπολογιστή αυτό δεδομένου ότι το ετήσιο ποσοστό υποτίμησης υπολογίζεται από τον παρακάτω τύπο:
ds2-kef2-te
Να σχεδιασθεί το διάγραμμα ροής και να γραφεί ένας αλγόριθμος που θα υπολογίζει το ποσοστό απαξίωσης για τον υπολογιστή που πήρες για τους 6 μήνες. Στη συνέχεια να γενικεύσεις τον αλγόριθμο, έτσι ώστε να δουλεύει επαναληπτικά για έναν αριθμό από διαφορετικά είδη των οποίων ξέρεις το αρχικό ποσό, το ποσό της προσφοράς και το χρονικό διάστημα για το οποίο θέλεις να υπολογίσεις τα ποσοστά απαξίωσης.

Λύση:  (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

aepp_2011_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2010, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια