Επιλογή Σελίδας

ΔΕ1, Κεφάλαιο 9, Βιβλίο, Μέσος αριθμός τερμάτων (μέσος όρος), εύρος (απόσταση) τερμάτων

Να γράψετε ένα πρόγραμμα το οποίο να διαβάζει τον αριθμό των τερμάτων που σημειώθηκαν στους αγώνες ποδοσφαίρου μίας αγωνιστικής της Α κατηγορίας (9 τιμές), να υπολογίζει το μέσο αριθμό τερμάτων καθώς και το εύρος των τερμάτων (δηλαδή τη διαφορά της μεγαλύτερης από τη μικρότερη τιμή).

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ποδόσφαιρο
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: αγώνας, Άθροισμα, εύρος, μέγιστος, ελάχιστος, Τέρματα[9]
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΓΡΑΨΕ 'Δώσε αριθμό τερμάτων αγώνα ', αγώνας
    ΔΙΑΒΑΣΕ Τέρματα[Αγώνας]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΘΡΟΙΣΜΑ <-- 0
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    Άθροισμα <-- Άθροισμα + Τέρματα[Αγώνας]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <-- Άθροισμα / 9
ΓΡΑΨΕ 'Ο μέσος αριθμός τερμάτων είναι ', ΜΟ

μέγιστος <-- Τέρματα[1]
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΑΝ Τέρματα[αγώνας] > μέγιστος ΤΟΤΕ
       μέγιστος <-- Τέρματα[αγώνας]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ελάχιστος <-- Τέρματα[1]
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΑΝ Τέρματα[αγώνας] < ελάχιστος ΤΟΤΕ
       ελάχιστος <-- Τέρματα[αγώνας]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

εύρος <-- μέγιστος - ελάχιστος
ΓΡΑΨΕ 'Το εύρος τερμάτων είναι ', εύρος
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕ2, Κεφάλαιο 9, Βιβλίο, Εφαρμογή του παραδείγματος 2

Να γράψετε το πρόγραμμα του παραδείγματος 2 (επίπεδα θορύβου αυτοκινήτων) και να το εκτελέσετε για τις τιμές που δίνονται στον πίνακα του παραδείγματος. Το πρόγραμμά σας να τυπώνει τον πίνακα με τα επίπεδα θορύβου για κάθε μοντέλο. ΔΕΣ Παράδειγμα 2

ΔΕ3, Κεφάλαιο 9, Βιβλίο, Λύση της ΔΕ4, κεφ. 8 με χρήση πινάκων

Να γράψετε την άσκηση ΔΕ4 (ρύπανση ατμόσφαιρας) του προηγουμένου κεφαλαίου χρησιμοποιώντας πίνακες για την αποθήκευση των τιμών καθώς και των ονομάτων των σταθμών μέτρησης.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ρύποι
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:NO2[5,6], O3[5,6], μετρήσεις, σταθμός
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ_NO2[5], ΜΟ_O3[5], max_NO2, max_O3, Αθροιστής_NO2, Αθροιστής_O3
ΑΡΧΗ 
ΓΙΑ σταθμός ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Μετρήσεις Σταθμού ', σταθμός
    ΓΙΑ μετρήσεις ΑΠΟ 1 ΜΕΧΡΙ 6 
        ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου ', μετρήσεις, ' από 6'
        ΔΙΑΒΑΣΕ NO2[σταθμός, μετρήσεις]
        ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος', μετρήσεις, ' από 6'
        ΔΙΑΒΑΣΕ O3[σταθμός, μετρήσεις] 
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Αθροιστής_NO2 <-- 0
Αθροιστής_O3 <-- 0 
ΓΙΑ σταθμός ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ μετρήσεις ΑΠΟ 1 ΜΕΧΡΙ 6
        Αθροιστής_NO2 <-- Αθροιστής_NO2 + NO2[σταθμός, μετρήσεις] 
        Αθροιστής_O3 <-- Αθροιστής_O3 + O3[σταθμός, μετρήσεις]  
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΜΟ_NO2[σταθμός] <-- Αθροιστής_NO2 / 6 
ΜΟ_O3[σταθμός] <-- ΑΘροιστής_O3 / 6 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
max_NO2 <-- ΜΟ_NO2[1] 
max_O3 <-- ΜΟ_O3[1] 
ΓΙΑ σταθμός ΑΠΟ 2 ΜΕΧΡΙ 5  
    ΑΝ max_NO2 < ΜΟ_NO2[σταθμός] ΤΟΤΕ 
       max_NO2 <-- ΜΟ_NO2[σταθμός]  
    ΤΕΛΟΣ_ΑΝ  
    ΑΝ max_O3 < ΜΟ_O3[σταθμός] ΤΟΤΕ 
       max_O3 <-- ΜΟ_O3[σταθμός] 
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΝ max_NO2 > 700 Ή max_O3 > 500 ΤΟΤΕ  
       ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ' 
    ΑΛΛΙΩΣ_ΑΝ max_NO2 > 500 Ή max_O3 > 300 ΤΟΤΕ 
           ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
    ΑΛΛΙΩΣ_ΑΝ max_NO2 > 400 Ή max_O3 > 250 ΤΟΤΕ  
           ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
ΑΛΛΙΩΣ  
       ΓΡΑΨΕ 'Ρύποι μέσα στα όρια' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΕ4, Κεφάλαιο 9, Βιβλίο, Ταξινόμηση μοντέλων του παραδείγματος 2

Να γράψετε πρόγραμμα το οποίο να ταξινομεί τα μοντέλα αυτοκινήτων του παραδείγματος 2, κατά αύξουσα σειρά του μέσου επιπέδου θορύβου κάθε μοντέλου.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΗΧΟΡΥΠΑΝΣΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ταχύτητα[5], Θόρυβος[4,5], i, j, Ολ_Θόρυβος
ΠΡΑΓΜΑΤΙΚΕΣ: Μέσος_Θόρυβος[4], βοηθητική1
ΧΑΡΑΚΤΗΡΕΣ: Μοντέλο[4], βοηθητική2
ΑΡΧΗ
!Εισαγωγή Δεδομένων
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Δώσε ταχύτητα'
    ΔΙΑΒΑΣΕ Ταχύτητα[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ 'Δώσε Μοντέλο'
    ΔΙΑΒΑΣΕ Μοντέλο[i]
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
        ΓΡΑΨΕ 'Δώσε τα επίπεδα θορύβου του μοντέλου ', Μοντέλο[i], 'στα ', Ταχύτητα[j], 'Km/h'
        ΔΙΑΒΑΣΕ Θόρυβος[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Άθροισμα κατά γραμμές του Θόρυβος 
!Υπολογισμός του μέσου θόρυβου ανά μοντέλο.
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    Ολ_Θόρυβος <--0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
        Ολ_Θόρυβος <-- Ολ_Θόρυβος + Θόρυβος[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Μέσος_Θόρυβος[i] <-- Ολ_Θόρυβος / 5
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Ταξινόμηση του Μοντέλα με βάση το επίπεδο θορύβου (Μέσος_Θόρυβος)
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 5 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
       ΑΝ Μέσος_Θόρυβος[j-1]>Μέσος_Θόρυβος[j] ΤΟΤΕ
          βοηθητική1 <-- Μέσος_Θόρυβος[j]
          Μέσος_Θόρυβος[j] <-- Μέσος_Θόρυβος[j-1]
          Μέσος_Θόρυβος[j-1]<-- βοηθητική1
          βοηθητική2 <-- Μοντέλο[j]
          Μοντέλο[j] <-- Μοντέλο[j-1]
          Μοντέλο[j] <-- βοηθητική2
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ Μοντέλο[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ