Επιλογή Σελίδας

Δίνεται η δομή επανάληψης.

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

Να μετατρέψετε την παραπάνω δομή σε ισοδύναμη δομή επανάληψης Όσο … επανάλαβε.

Σημείωση: Αντί του Όσο … επανάλαβε μπορεί ισοδύναμα να χρησιμοποιηθεί όσο … κάνε. Επίσης αντί του:

Για i από τιμή1 μέχρι τιμή2 με_βήμα β

Εντολές

Τέλος_επανάληψης

μπορεί ισοδύναμα να χρησιμοποιηθεί το:

για i:= τιμή1 μέχρι τιμή2 μεταβολή β κάνε

Εντολές

τέλοςγια

Μονάδες 9

ΛΥΣΗ: 

i <- τιμή1

Όσο i <= τιμή2 επανάλαβε

Εντολές

i<- i +β

Τέλος επανάληψης

Θέματα σε pdf, 2001, Ημερήσια, Μαΐου-Ιουνίου

Share This