Επιλογή Σελίδας

ΔΤ4, Κεφάλαιο 8, Τμήμα προγράμματος, βρες τη λειτουργία, τον αριθμό επαναλήψεων, κάνε μετατροπή σε άλλες δομές

Έστω το παρακάτω τμήμα προγράμματος:

Κ <- 0 
ΓΙΑ Ι ΑΠΟ 0 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 5 
    Α <- Ι^3 
    Κ <- Κ+Α 
    ΓΡΑΨΕ Ι, Α 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Κ

Πόσες φορές θα εκτελεστεί ο βρόχος; Ποια η λειτουργία των εντολών; Γράψτε τις παραπάνω εντολές χρησιμοποιώντας την εντολή επανάληψης ΟΣΟ και την εντολή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. Ποιον από τους τρεις τρόπους προτιμάς και γιατί;

ΛΥΣΗ (περισσότερα…)

ΔΤ5, Κεφάλαιο 8, Διόρθωσε τα λάθη του προγράμματος

Διάβασε προσεκτικά τα παρακάτω τμήματα προγράμματος. Ποια είναι τα λάθη; Διόρθωσέ τα, ώστε να λειτουργούν σωστά.Εκτέλεσε εικονικά τις εντολές στο χαρτί και σημείωνε τα αποτελέσματα που προκύπτουν. Με αυτόν τον τρόπο θα δεις τα λάθη και στη συνέχεια θα κάνεις τις διορθώσεις.

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2016, Ημερήσια, Νέο

Ο αριθμός π εκφράζει το πηλίκο της περιμέτρου ενός κύκλου προς τη διάμετρό του. Η τιμή του μπορεί να υπολογιστεί, κατά προσέγγιση, από την παρακάτω παράσταση:
er1the-v-aepp-2016-imerisia-neo
Ο υπολογισμός της τιμής της παράστασης, για 100 όρους του αθροίσματος, γίνεται από το παρακάτω τμήμα αλγορίθμου που περιλαμβάνει 5 κενά.

παρονομαστής < (1)   
 Σ< 0
 πρόσημο < 1
 Για i από 1 μέχρι 100
       όρος < 1/παρονομαστής
       όρος<  (2)  * πρόσημο
       (3)   < Σ + όρος
       πρόσημο < πρόσημο * ( (4) )
       παρονομαστής < παρονομαστής + 2 
 Τέλος_Επανάληψης
 π <- (5) * Σ

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε ο αλγόριθμος να υπολογίζει την τιμή του π όπως περιγράφηκε.
Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2016, Επαναληπτικές, Νέο

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Θέμα Α, Eρώτημα 5, 2015, Ημερήσια

α. Δίνονται οι παρακάτω προτάσεις σε φυσική γλώσσα:

  1. Αύξησε το Χ κατά 2.
  2. Εκχώρησε στο Υ τον μέσο όρο των Κ, Λ, Μ.
  3. Το τελευταίο ψηφίο του Α είναι
  4. Ο Β είναι διψήφιος.

Να θεωρήσετε ότι οι Α και Β είναι θετικοί ακέραιοι. Να γράψετε στο τετράδιό σας τον αριθμό της κάθε πρότασης και δίπλα την κωδικοποίησή της σε ΓΛΩΣΣΑ. (μονάδες 4)
β. Δίνεται το παρακάτω τμήμα αλγορίθμου:

 Διάβασε Χ 
 Αν Χ > 15 τότε
     Γράψε 1 
 αλλιώς_αν Χ > 23 τότε
     Γράψε 2 
 αλλιώς
     Γράψε 3 
 Τέλος_αν

Μια εντολή εξόδου στο παραπάνω τμήμα δεν πρόκειται να εκτελεστεί, όποια και αν είναι η τιμή του Χ.

  1. Ποια είναι η εντολή αυτή; (μονάδες 2)
  2. Να γράψετε τις εντολές εξόδου που είναι δυνατόν να εκτελεστούν και, δίπλα σε καθεμία από αυτές, το διάστημα τιμών του Χ για το οποίο θα εκτελεστεί η εντολή. (μονάδες 4)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.5.α.

  1. Χ ← Χ + 2

  2. Υ ← ( Κ + Λ + Μ ) /3

  3. Α mod 10 = 5

  4. B >= 10 KAI B < 100

A.5.β

  1. Η εντολή Γράψε 2

  2. Γράψε 1 για x > 15

Γράψε 3 για x <= 15

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα Α, Ερώτημα 4, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, με αριθμημένες τις γραμμές του:

  1. max <- Π[1]
  2. Για i από 2 μέχρι 5
  3. Αν Π[i] > max τότε
  4. max <- Π[i]
  5. Τέλος_αν
  6. Τέλος_επανάληψης

α.   Τι υπολογίζει αυτό το τμήμα αλγορίθμου; (μονάδες 2)
β.   Πόσες φορές τουλάχιστον θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
γ.   Πόσες φορές το πολύ θα εκτελεστεί η εντολή στη γραμμή 4; (μονάδες 2)
δ. Να αιτιολογήσετε γιατί ο πίνακας Π δεν μπορεί να είναι πίνακας λογικών τιμών (μονάδες 4).
Μονάδες 10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα Β, 2015, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)