Επιλογή Σελίδας

Ένας τρόπος υπολογισμού των τριγωνομετρικών συναρτήσεων που χρησιμοποιείται συχνά από τους υπολογιστές είναι με τον υπολογισμό των παρακάτω σειρών:

Να γράψεις πρόγραμμα το οποίο να διαβάζει τη γωνία x σε μοίρες και να υπολογίζει το ημίτονο και το συνημίτονό της σύμφωνα με τους παραπάνω τύπους. Ποια μπορεί να είναι τα κριτήρια για διακοπή των επαναλήψεων; Υπόδειξη: Να μετατρέψεις αρχικά τη γωνία x σε ακτίνια.

Λύση
!Προσεγγίζουμε τη λύση υπολογίζοντας νέους όρους, μέχρι που η διαφορά 2 συνεχόμενων όρων να γίνει μικρότερη από μια προκαθορισμένη τιμή Δχ.
!Μετά από αυτό το σημείο θεωρούμε ότι η άθροιση νέων όρων βοηθά πολύ λίγο (αργά) στη προσέγγιση της ακριβούς τιμής.

ΠΡΟΓΡΑΜΜΑ ΗΜΧ_ΣΕΙΡΑ
ΣΤΑΘΕΡΕΣ
 π=3.14
 Δχ=0.0001 
ΜΕΤΑΒΛΗΤΕΣ
 ΠΡΑΓΜΑΤΙΚΕΣ: ΗΜΧ, χ, i, k , ΠΡΟΗΓ_ΟΡΟΣ, ΠΑΡΑΓΟΝΤΙΚΟ, ΟΡΟΣ
 ΑΚΕΡΑΙΕΣ: ΠΡΟΣΗΜΟ
ΑΡΧΗ
 ΔΙΑΒΑΣΕ χ
 χ <-- χ * π / 180
 i <-- 3
 ΠΡΟΗΓ_ΟΡΟΣ <-- 0
 ΠΡΟΣΗΜΟ <-- -1
 ΗΜΧ <-- χ
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
     ΠΑΡΑΓΟΝΤΙΚΟ <-- 1
     ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ i
         ΠΑΡΑΓΟΝΤΙΚΟ <-- ΠΑΡΑΓΟΝΤΙΚΟ * k
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΟΡΟΣ <-- ΠΡΟΣΗΜΟ * χ^i / ΠΑΡΑΓΟΝΤΙΚΟ
    ΠΡΟΣΗΜΟ <-- ΠΡΟΣΗΜΟ * (-1)
    i <-- i + 2
    ΗΜΧ <-- ΗΜΧ + ΟΡΟΣ 
 ΜΕΧΡΙΣ_ΟΤΟΥ Α_Τ(ΠΡΟΗΓ_ΟΡΟΣ - ΟΡΟΣ) < Δχ
 ΓΡΑΨΕ ΗΜΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This