ΘΕΜΑ Α1, 2017, Επαναληπτικές

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η μεταβλητή Χ είναι ακέραιου τύπου στην εντολή εκχώρησης Χ <- Α_Μ(α) / 2
  2. Κάθε συνάρτηση επιστρέφει μόνο μία τιμή.
  3. Οι δυναμικές δομές αποθηκεύονται πάντα σε συνεχόμενες θέσεις μνήμης.
  4. Ο μεταγλωττιστής διαβάζει μία προς μία τις εντολές του αρχικού προγράμματος και για κάθε μία εκτελεί αμέσως μία ισοδύναμη ακολουθία εντολών μηχανής.
  5. Τα συντακτικά λάθη εντοπίζονται στη φάση της μεταγλώττισης.

Μονάδες 10

ΘΕΜΑ Α2, 2017, Επαναληπτικές

α.Η επιβράβευση αγορών με χρήση κάποιας πιστωτικής κάρτας γίνεται κλιμακωτά με βάση το ποσό ως εξής:
Για ποσά μέχρι 100 ευρώ 1%
Για τα επόμενα 900 ευρώ 0,8%
Για το υπόλοιπο ποσό 0,6%

Να γράψετε στο τετράδιό σας τις εντολές σε Γλώσσα που κωδικοποιούν τον υπολογισμό του ποσού της παραπάνω επιβράβευσης. (μονάδες 6)

β. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν, όταν εκτελεστεί το παρακάτω τμήμα προγράμματος:

j<-1
k <- 2
Για i από 1 μέχρι 4
    f <- j + k
    Γράψε f
    j <- k
    k <- f
Τέλος_επανάληψης

(μονάδες 4)

Μονάδες 10

ΘΕΜΑ Α3, 2017, Επαναληπτικές

α.

  1. Τι ονομάζεται εμβέλεια σε προγραμματιστικό περιβάλλον; (μονάδες 2)
  2. Τι εμβέλεια χρησιμοποιείται στη Γλώσσα; (μονάδες 2)

β. Ποιοι είναι οι δύο πλέον διαδεδομένοι αλγόριθμοι αναζήτησης; Ποιος είναι ο πλέον αποδοτικός και τι περιορισμό έχει; (μονάδες 4)

Μονάδες 8

ΘΕΜΑ Α4, 2017, Επαναληπτικές

Να γράψετε στο τετράδιό σας:

α. Έναν αριθμητικό τελεστή
β. Έναν συγκριτικό τελεστή
γ. Έναν λογικό τελεστή
δ. Μια αριθμητική σταθερά
ε. Μια λογική μεταβλητή
στ. Μια απλή λογική έκφραση
ζ. Μια σύνθετη λογική έκφραση
από το παρακάτω τμήμα αλγορίθμου:

Α <- 1
Β <- Ψευδής
Σ <- 10
Αρχή_επανάληψης 
   Σ <- Σ+Α
   Αν Σ MOD 3 = 1 τότε
      Β <- Όχι Β
      Α <- Α+2 
   Αλλιώς
      Α <- Α+3
  Τέλος_αν
Μέχρις_ότου Β ή Σ>100

Μονάδες 7

 

ΘΕΜΑ Α5, 2017, Επαναληπτικές

Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α του παρακάτω πίνακα και δίπλα το γράμμα της στήλης Β που αντιστοιχεί σωστά στον τύπο της τιμής ή της έκφρασης.

Στήλη Α Στήλη Β
1. ´Ψευδής´ α. Ακέραια
2. Αληθής β. Πραγματική
3. 5.0 γ. Λογική
4. 8 δ. Χαρακτήρας
5. 8 DIV 3  

Μονάδες 5

Θέμα A, Ερώτημα 1, 2017, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η έκφραση ΟΧΙ(Κ=10 ΚΑΙ Χ>7) είναι ισοδύναμη με την έκφραση (Κ<>10 Ή Χ<=7).
  2. Η χρησιμοποίηση του διερμηνευτή για τη μετάφραση ενός προγράμματος έχει ως αποτέλεσμα την ταχύτερη εκτέλεσή του.
  3. Οι εντολές στη δομή επανάληψης «ΓΙΑ» εκτελούνται τουλάχιστον μία φορά.
  4. Πολύ συχνά οι εντολές που έχουν γραφτεί με εμφωλευμένα ΑΝ μπορούν να γραφτούν πιο απλά χρησιμοποιώντας σύνθετες εκφράσεις ή την εντολή επιλογής ΑΝ… ΤΟΤΕ… ΑΛΛΙΩΣ_ΑΝ.
  5. Κάθε υποπρόγραμμα μπορεί να σχεδιαστεί, να αναπτυχθεί και να συντηρηθεί αυτόνομα.

Μονάδες 10

Θέμα A, Ερώτημα 3, 2017, Ημερήσια

i <– 0
k <–  12
Όσο i<=k επανάλαβε
         i <– i+2
         k <– k-1
         Γράψε i,k
Τέλος_επανάληψης
Να μεταφέρετε στο τετράδιό σας τον παρακάτω πίνακα και να συμπληρώσετε τις τιμές των μεταβλητών που θα εμφανίζει το παραπάνω απόσπασμα αλγορίθμου σε κάθε επανάληψη:

Οθόνη (εμφάνιση των i και k)

Επανάληψη 1
Επανάληψη 2

Μονάδες 10

Θέμα A, Ερώτημα 4, 2017, Ημερήσια

Α4. Έστω ότι έχουμε το παρακάτω απόσπασμα αλγορίθμου:
S <– 0
Για i από 5 μέχρι 20 με βήμα 3
Διάβασε Χ
     S <– S + X
Τέλοςεπανάληψης
Να ξαναγράψετε το παραπάνω απόσπασμα αλγορίθμου χρησιμοποιώντας αντί για την εντολή Για… Τέλος
επανάληψης:
α) την εντολή Όσο…Τέλοςεπανάληψης
(μονάδες 5)
β) την εντολή Αρχή
επανάληψης…Μέχρις_ότου
(μονάδες 5)
Μονάδες 10

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Νέο

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. O χρόνος εκτέλεσης κάθε αλγορίθμου εξαρτάται από τη Γλώσσα προγραμματισμού που θα χρησιμοποιηθεί.
  2. Οι στατικές δομές στηρίζονται στην τεχνική της δυναμικής παραχώρησης μνήμης.
  3. Σε μια δομή σύνθετης επιλογής, μετά από τις εντολές που βρίσκονται μεταξύ των λέξεων ΤΟΤΕ και ΑΛΛΙΩΣ, εκτελούνται οι εντολές που βρίσκονται μεταξύ των λέξεων ΑΛΛΙΩΣ και ΤΕΛΟΣ_ΑΝ.
  4. Στο τμήμα δηλώσεων ενός προγράμματος, εκτός από τον τύπο ενός πίνακα, πρέπει να δηλώνεται και ο μεγαλύτερος αριθμός στοιχείων που μπορεί να έχει ο συγκεκριμένος πίνακας.
  5. Το πρόγραμμα Συντάκτης εντοπίζει τα συντακτικά λάθη του προγράμματος.

Μονάδες 10

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 2, 2016, Ημερήσια, Νέο

Δίδεται η λίστα:

er2-thema-v-aepp-2016-imerisia-neo

α. Να περιγράψετε τη διαδικασία για την εισαγωγή του κόμβου με δεδομένα Ε ανάμεσα στον δεύτερο και τρίτο κόμβο της λίστας. (μονάδες 3)

β. Να περιγράψετε τη διαδικασία για τη διαγραφή του κόμβου με δεδομένα Κ από την αρχική λίστα. (μονάδες 3)

Μονάδες 6

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2016, Ημερήσια, Νέο

α. Ποιες μεταβλητές ονομάζονται καθολικές; (μονάδες 2)

β. Η χρήση καθολικών μεταβλητών σε ένα πρόγραμμα καταστρατηγεί μία από τις βασικές αρχές του τμηματικού προγραμματισμού (ιδιότητες που πρέπει να διακρίνουν τα υποπρογράμματα). Να αναφέρετε ποια είναι αυτή η ιδιότητα και να εξηγήσετε γιατί καταστρατηγείται. (μονάδες 4)

Μονάδες 6

ΛΥΣΗ (περισσότερα…)