Επιλογή Σελίδας

Θέμα A, Ερώτημα 1, 2017, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η έκφραση ΟΧΙ(Κ=10 ΚΑΙ Χ>7) είναι ισοδύναμη με την έκφραση (Κ<>10 Ή Χ<=7).
  2. Η χρησιμοποίηση του διερμηνευτή για τη μετάφραση ενός προγράμματος έχει ως αποτέλεσμα την ταχύτερη εκτέλεσή του.
  3. Οι εντολές στη δομή επανάληψης «ΓΙΑ» εκτελούνται τουλάχιστον μία φορά.
  4. Πολύ συχνά οι εντολές που έχουν γραφτεί με εμφωλευμένα ΑΝ μπορούν να γραφτούν πιο απλά χρησιμοποιώντας σύνθετες εκφράσεις ή την εντολή επιλογής ΑΝ… ΤΟΤΕ… ΑΛΛΙΩΣ_ΑΝ.
  5. Κάθε υποπρόγραμμα μπορεί να σχεδιαστεί, να αναπτυχθεί και να συντηρηθεί αυτόνομα.

Μονάδες 10

Θέμα A, Ερώτημα 3, 2017, Ημερήσια

i <– 0
k <–  12
Όσο i<=k επανάλαβε
         i <– i+2
         k <– k-1
         Γράψε i,k
Τέλος_επανάληψης
Να μεταφέρετε στο τετράδιό σας τον παρακάτω πίνακα και να συμπληρώσετε τις τιμές των μεταβλητών που θα εμφανίζει το παραπάνω απόσπασμα αλγορίθμου σε κάθε επανάληψη:

Οθόνη (εμφάνιση των i και k)

Επανάληψη 1
Επανάληψη 2

Μονάδες 10

Θέμα A, Ερώτημα 4, 2017, Ημερήσια

Α4. Έστω ότι έχουμε το παρακάτω απόσπασμα αλγορίθμου:
S <– 0
Για i από 5 μέχρι 20 με βήμα 3
Διάβασε Χ
     S <– S + X
Τέλοςεπανάληψης
Να ξαναγράψετε το παραπάνω απόσπασμα αλγορίθμου χρησιμοποιώντας αντί για την εντολή Για… Τέλος
επανάληψης:
α) την εντολή Όσο…Τέλοςεπανάληψης
(μονάδες 5)
β) την εντολή Αρχή
επανάληψης…Μέχρις_ότου
(μονάδες 5)
Μονάδες 10

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Νέο

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. O χρόνος εκτέλεσης κάθε αλγορίθμου εξαρτάται από τη Γλώσσα προγραμματισμού που θα χρησιμοποιηθεί.
  2. Οι στατικές δομές στηρίζονται στην τεχνική της δυναμικής παραχώρησης μνήμης.
  3. Σε μια δομή σύνθετης επιλογής, μετά από τις εντολές που βρίσκονται μεταξύ των λέξεων ΤΟΤΕ και ΑΛΛΙΩΣ, εκτελούνται οι εντολές που βρίσκονται μεταξύ των λέξεων ΑΛΛΙΩΣ και ΤΕΛΟΣ_ΑΝ.
  4. Στο τμήμα δηλώσεων ενός προγράμματος, εκτός από τον τύπο ενός πίνακα, πρέπει να δηλώνεται και ο μεγαλύτερος αριθμός στοιχείων που μπορεί να έχει ο συγκεκριμένος πίνακας.
  5. Το πρόγραμμα Συντάκτης εντοπίζει τα συντακτικά λάθη του προγράμματος.

Μονάδες 10

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 2, 2016, Ημερήσια, Νέο

Δίδεται η λίστα:

er2-thema-v-aepp-2016-imerisia-neo

α. Να περιγράψετε τη διαδικασία για την εισαγωγή του κόμβου με δεδομένα Ε ανάμεσα στον δεύτερο και τρίτο κόμβο της λίστας. (μονάδες 3)

β. Να περιγράψετε τη διαδικασία για τη διαγραφή του κόμβου με δεδομένα Κ από την αρχική λίστα. (μονάδες 3)

Μονάδες 6

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2016, Ημερήσια, Νέο

α. Ποιες μεταβλητές ονομάζονται καθολικές; (μονάδες 2)

β. Η χρήση καθολικών μεταβλητών σε ένα πρόγραμμα καταστρατηγεί μία από τις βασικές αρχές του τμηματικού προγραμματισμού (ιδιότητες που πρέπει να διακρίνουν τα υποπρογράμματα). Να αναφέρετε ποια είναι αυτή η ιδιότητα και να εξηγήσετε γιατί καταστρατηγείται. (μονάδες 4)

Μονάδες 6

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2016, Ημερήσια, Νέο

Έστω ο μονοδιάστατος πίνακας Α:

5                 2                 3                 8                 7                 4                10               12

Να σχεδιάσετε τον πίνακα Β[6] μετά την εκτέλεση των παρακάτω εντολών:

  1. Β[Α[1] – Α[3]] <- Α[5]
  2. Β[Α[7] – Α[5]] <- Α[2] + Α[7]
  3. Β[Α[6]] <- Α[4]
  4. Β[Α[1] + Α[4] – Α[8]] <- Α[3] + Α[8]
  5. Β[Α[8] DIV 2] <- A[3] MOD 2
  6. B[A[1] MOD A[4]] <- A[6] + 4

Μονάδες 12

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2016, Επαναληπτικές, Νέο

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η λογική έκφραση (Α > Β) Ή   ΟΧΙ(Α > Β) είναι πάντα αληθής για οποιεσδήποτε τιμές των αριθμητικών μεταβλητών Α και Β.
  2. Στη ΓΛΩΣΣΑ ο χαρακτήρας είναι ένας τύπος δεδομένων.
  3. Το κύριο χαρακτηριστικό των δένδρων   είναι ότι από έναν κόμβο υπάρχει μόνο ένας επόμενος κόμβος.
  4. Έστω ο πίνακας ακεραίων Α[10]. Η εντολή Σ <- Α[10] εκχωρεί στη μεταβλητή Σ το άθροισμα όλων των στοιχείων του πίνακα Α.
  5. Στη στοίβα, ο ίδιος δείκτης μάς δίνει, τόσο τη θέση του στοιχείου που μπορεί να εξαχθεί, όσο και τη θέση εκείνου που εισήλθε τελευταίο.

Μονάδες 10

ΛΥΣΗ

  1. Σωστό         2. Σωστό         3. Λάθος          4. Λάθος          5. Σωστό

Θέμα Α, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Σε ποιες περιπτώσεις ένας αλγόριθμος Α χαρακτηρίζεται αποδοτικότερος από ένα αλγόριθμο Β; Να θεωρήσετε ότι η σύγκριση γίνεται κάτω από τις ίδιες ακριβώς συνθήκες (ίδια δεδομένα, ίδιος υπολογιστής, ίδια γλώσσα προγραμματισμού).

Μονάδες 6

Απάντηση

από την παράγραφο 5.1.4 Αποδοτικότητα αλγορίθμων  (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2016, Επαναληπτικές, Νέο

Δίνεται ο παρακάτω πίνακας                                                         

Εντολή Επανάληψης Καταλληλότητα Χρήσης
1.    Όσο … επανάλαβε

Τέλος_επανάληψης

α.   Γνωστός αριθμός επαναλήψεων
2.     Για … από … μέχρι … με βήμα …

Τέλος_επανάληψης

β.   Άγνωστος   αριθμός επαναλήψεων
3. Αρχή   επανάληψης …

μέχρις ότου …

γ. Άγνωστος   αριθμός επαναλήψεων, αλλά τουλάχιστον μία επανάληψη

Να   γράψετε στο τετράδιό σας τους αριθμούς της πρώτης στήλη και, δίπλα, το γράμμα της δεύτερης στήλης που αντιστοιχεί σωστά.

Μονάδες 6

ΛΥΣΗ (περισσότερα…)