Επιλογή Σελίδας

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επίλυση της δευτεροβάθμιας εξίσωσης αποτελεί ένα αδόμητο πρόβλημα.
  2. Η εντολή Αρχή_επανάληψης .. Μέχρις_ότου εκτελείται οπωσδήποτε μία φορά.
  3. Τα στοιχεία των στατικών δομών δεδομένων αποθηκεύονται σε μη συνεχόμενες θέσεις μνήμης.
  4. Οι μεταβλητές που χρησιμοποιούνται σ’ ένα πρόγραμμα αντιστοιχούνται από το μεταγλωττιστή σε συγκεκριμένες θέσεις μνήμης του υπολογιστή.
  5. Η ακολουθιακή δομή εντολών χρησιμοποιείται, όταν είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ
1. Λάθος
2. Σωστό
3. Λάθος
4. Σωστό
5. Σωστό

Παράδειγμα 4, Τετράδιο Εργασιών, Επίλυση δευτεροβάθμιας εξίσωσης

Η περίπτωση της δευτεροβάθμιας εξίσωσης είναι παρόμοια. Αρχικά είναι απαραίτητο η τιμή του Α να είναι μη μηδενική, πράγμα που ελέγχεται κατά την είσοδο. Στη συνέχεια, για την εύρεση πραγματικών ριζών της εξίσωσης Αx2+Βx+Γ=0, πρέπει να ελεγχθεί αν η διακρίνουσα είναι θετική. Και πάλι καλείται ο αλγόριθμος Ρίζα, που επιστρέφει την τετραγωνική ρίζα ενός θετικού αριθμού.

Αλγόριθμος ΕξίσωσηΒ
Αρχήεπανάληψης
Διάβασε a
Μέχρις
ότου a≠0
Διάβασε b
Διάβασε c
delta ← bb-4ac
Αν delta ≥ 0 τότε
solution1 ← (-b+Piζα(delta))/(2
a)
solution2 ← (-b-Ρίζα(delta))/(2*a)
Εκτύπωσε solution1,solution2
Τέλος_αν
Τέλος ΕξίσωσηΒ

Παράδειγμα 9. Βιβλίου, Εκτύπωση θετικών αριθμών με εντολή: αρχή_επανάληψης…μέχρις_ότου

par9bibliokef2Να διαβάζονται και να εκτυπώνονται όσοι θετικοί αριθμοί δίνονται από το πληκτρολόγιο. Ο αλγόριθμος τελειώνει, όταν δοθεί ένας αρνητικός αριθμός.
Αλγόριθμος Παράδειγμα9
Αρχή
επανάληψης
Διάβασε x
Εμφάνισε x
Μέχρις_ότου x < 0
Τέλος Παράδειγμα_9
Ας σημειωθεί ότι, στο παράδειγμα αυτό ο βρόχος επανάληψης θα εκτελεσθεί οπωσδήποτε τουλάχιστον μία φορά ακόμα και αν η αρχική τιμή της μεταβλητής x είναι αρνητική. Η βασική διαφοροποίηση αυτής της μορφής επαναληπτικής διαδικασίας σε σχέση με την επαναληπτική διαδικασία που παρουσιάσθηκε στο προηγούμενο παράδειγμα, οφείλεται στη θέση της λογικής συνθήκης στη ροή εκτέλεσης των εντολών.

Παρατήρηση: Η εντολή Αρχήεπανάληψης… Μέχριςότου εκτελείται οπωσδήποτε μια φορά

ΔΣ3, Κεφάλαιο 2, Τετράδιο Εργασιών

Ένας καταναλωτής πηγαίνει στο πολυκατάστημα και έχει στην τσέπη του 5.000 ευρώ. Ξεκινά να αγοράζει διάφορα είδη και ταυτόχρονα κρατά το συνολικό ποσό στο οποίο έχει φθάσει κάθε στιγμή που αγοράζει κάποιο είδος. Οι τιμές των ειδών που αγοράζει είναι σε δραχμές και είναι δεδομένο ότι 1 ευρώ=340,75 δραχμές. Να γραφεί σε φυσική γλώσσα, με ακολουθία βημάτων και με διάγραμμα ροής, ένας αλγόριθμος για τον υπολογισμό του ποσού από τα ψώνια που έγιναν και να σταματά η αγορά ειδών έτσι ώστε να μην ξεπεραστεί το ποσό που έχει διαθέσιμο ο καταναλωτής.

Λύση:  (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

aepp_2011_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2010, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα Α, 2009, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις, 1-5, και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Oι εντολές που βρίσκονται σε μια δομή ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ……..  ΜΕΧΡΙΣ_ΟΤΟΥ εκτελούνται τουλάχιστον μια φορά.
  2. Μία συνάρτηση είναι δυνατό να επιστρέφει μόνον ακέραιες ή πραγματικές τιμές.
  3. Η δυναμική παραχώρηση μνήμης χρησιμοποιείται στις δομές των πινάκων.
  4. Η λειτουργία της ώθησης σχετίζεται με τη δομή της στοίβας.
  5. Σε μια λογική έκφραση, οι συγκριτικοί τελεστές έχουν χαμηλότερη ιεραρχία από τους λογικούς τελεστές.

Μονάδες 10

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Ερώτημα 5, Θέμα A, 2008, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ <- 1

ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ -5 ΜΕ_ΒΗΜΑ -2

Κ <- Κ * i

ΓΡΑΨΕ Κ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Να μετατρέψετε το τμήμα αυτού του αλγορίθμου σε ισοδύναμο:

α.    με χρήση της αλγοριθμικής δομής ΟΣΟ

Μονάδες 3

β.    με χρήση της αλγοριθμικής δομής ΜΕΧΡΙΣ_ΟΤΟΥ

Μονάδες 3

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια

Ερώτημα 4, Θέμα Α, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου.

Για x από 1 μέχρι Κ

Εμφάνισε x

Τέλος_επανάληψης

Να μετατραπεί σε ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την εντολή Αρχή_Επανάληψης … Μέχρις_ Ότου

Μονάδες 10

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Θέμα Β, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:

ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: α, β, χ

ΑΡΧΗ

α <-1

β <- 2

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ α<= 4 ΤΟΤΕ

ΚΑΛΕΣΕ Διαδ1(α, β,χ)

ΑΛΛΙΩΣ

χ <- Συν1(α, β)

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ α, β, χ

ΜΕΧΡΙΣ_ΟΤΟΥ χ>11

ΓΡΑΨΕ χ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Διαδ1 (λ, κ, μ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: κ, λ, μ

ΑΡΧΗ

κ<-κ+1

λ<-λ+3

μ<-κ+λ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ε, ζ

ΑΡΧΗ

ζ<-ζ+2

ε<-ε*2

Συν1<-ε+ζ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.

Μονάδες 20

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Θέμα Α, Ερώτημα 3, 2005, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

S <- 0

Για Ι από 2 μέχρι 100 με_βήμα 2

S <- S + I

Τέλος_επανάληψης

Εμφάνισε S

  1. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Όσο
    … Επανάλαβε

Μονάδες 5

  1. Να μετατραπεί   σε   ισοδύναμο   με   χρήση   της   δομής
    αρχή_επανάληψης… μέχρις_ότου.

Μονάδες 5

Τα θέματα σε pdf, 2005, Ημερήσια

Ερώτημα 2, Θέμα Α, 2004, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τους αριθμούς της Στήλης Α και δίπλα τα γράμματα της Στήλης Β που αντιστοιχούν σωστά. (Να σημειωθεί ότι στις Εντολές της Στήλης Α αντιστοιχούν περισσότερες από μία Προτάσεις της Στήλης Β).

Στήλη Α Εντολές Στήλη Β Προτάσεις
1. Όσο συνθήκη επανάλαβε

          εντολές

   Τέλος_επανάληψης

α. Ο βρόχος επανάληψης τερματίζεται, όταν η συνθήκη είναι αληθής
2. Αρχή_επανάληψης

       εντολές

   Μέχρις_ότου συνθήκη

β. Ο βρόχος επανάληψης τερματίζεται, όταν η συνθήκη είναι ψευδής
γ. Ο βρόχος επανάληψης εκτελείται οπωσδήποτε μία φορά
δ. Ο βρόχος επανάληψης είναι δυνατό να μην εκτελεστεί

Μονάδες 8

Τα θέματα σε pdf, 2004, Μαΐου-Ιουνίου, Ημερήσια