Θέμα Α3, 2019, Eπαναληπτικές, Hμερήσια και Eσπερινά

Α3.
Α3. Δίνεται το παρακάτω τμήμα προγράμματος σε ΓΛΩΣΣΑ:

sum<-0 
ΓΙΑ i AΠΟ 6 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -2 
    sum <- sum + i 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Να μετατραπεί σε ισοδύναμο τμήμα προγράμματος με χρήση της δομής ΟΣΟ…ΕΠΑΝΑΛΑΒΕ (μονάδες 5)
β. Να μετατραπεί σε ισοδύναμο τμήμα προγράμματος με χρήση της δομής ΑΡΧΗΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣΟΤΟΥ (μονάδες 5)
Μονάδες 10

Θέμα Α3, 2018, Ιούνιου, Hμερήσια και Eσπερινά

ΘΕΜΑ Α3
Σε ένα πρόγραμμα επιλογής υποψηφίων απαιτείται η είσοδος τριών τιμών από τον χρήστη για τις οποίες ισχύουν οι εξής περιορισμοί:
ηλικία: από 18 έως και 21
φύλο: ένα από τα γράμματα Α (για τους άνδρες), Θ (για τις γυναίκες)
ύψος: πάνω από 1,70 για τους άνδρες και πάνω από 1,60 για τις γυναίκες.
Δίνεται το παρακάτω τμήμα αλγορίθμου το οποίο υλοποιεί τους συγκεκριμένους περιορισμούς. Το τμήμα αυτό περιέχει κενά που έχουν αριθμηθεί. Να γράψετε στο τετράδιό σας τους αριθμούς των κενών και δίπλα σε κάθε αριθμό τη συνθήκη που αντιστοιχεί.

Αρχή_επανάληψης 
   Διάβασε ηλικία  
Μέχρις_ότου …(1)… (μονάδες 2) 
Αρχή_επανάληψης 
   Διάβασε φύλο  
Μέχρις_ότου …(2)… (μονάδες 2)
Αρχή_επανάληψης 
   Διάβασε ύψος  
Μέχρις_ότου …(3)… (μονάδες 6) 

Μονάδες 10
Μονάδες 10

Θέμα Β1, 2018, Ιούνιου, Hμερήσια και Eσπερινά

ΘΕΜΑ Β1
Το παρακάτω τμήμα αλγορίθμου αποτελεί μια παραλλαγή της ταξινόμησης φυσαλίδας, η οποία όμως σταματάει τις επαναλήψεις μόλις διαπιστώσει ότι ο πίνακας έχει ταξινομηθεί ως εξής:
Μετά την ολοκλήρωση του εσωτερικού βρόχου, ελέγχει εάν έγιναν αντιμεταθέσεις στοιχείων και αν δεν έγιναν τότε ο αλγόριθμος τερματίζεται. Το τμήμα αλγορίθμου που δίνεται περιέχει κενά που έχουν αριθμηθεί.

i  ...(1)... 
Αρχή_επανάληψης 
stop  ΑΛΗΘΗΣ 
Για j από Ν μέχρι i με_βήμα -1 
    Αν table[j-1] > table[j] τότε 
       Αντιμετάθεσε table[j-1],table[j]  
       stop  ...(2)... 
    Τέλος_αν 
Τέλος_επανάληψης 
...(3)... 
Μέχρις_ότου i ...(4)... N ή stop= ...(5)...

Να γράψετε στο τετράδιό σας τους αριθμούς των κενών και δίπλα από κάθε αριθμό ό,τι πρέπει να συμπληρωθεί ώστε να επιτελείται η λειτουργία που περιγράφεται.
Μονάδες 10

Θέμα Β2, 2018, Ιούνιου, Hμερήσια και Eσπερινά

ΘΕΜΑ Β2
Δίνεται το παρακάτω τμήμα αλγορίθμου:

Να κωδικοποιήσετε σε ΓΛΩΣΣΑ αντίστοιχο τμήμα προγράμματος που να εκτελεί ακριβώς την ίδια ακολουθία εντολών (βημάτων). Μονάδες 10

ΘΕΜΑ Α4, 2017, Επαναληπτικές

Να γράψετε στο τετράδιό σας:

α. Έναν αριθμητικό τελεστή
β. Έναν συγκριτικό τελεστή
γ. Έναν λογικό τελεστή
δ. Μια αριθμητική σταθερά
ε. Μια λογική μεταβλητή
στ. Μια απλή λογική έκφραση
ζ. Μια σύνθετη λογική έκφραση
από το παρακάτω τμήμα αλγορίθμου:

Α <- 1
Β <- Ψευδής
Σ <- 10
Αρχή_επανάληψης 
   Σ <- Σ+Α
   Αν Σ MOD 3 = 1 τότε
      Β <- Όχι Β
      Α <- Α+2 
   Αλλιώς
      Α <- Α+3
  Τέλος_αν
Μέχρις_ότου Β ή Σ>100

Μονάδες 7

 

ΘΕΜΑ Β2, 2017, Επαναληπτικές

Β2. Δίνεται μονοδιάστατος πίνακας Π[6] με τις τιμές που φαίνονται παρακάτω.

1 2 3 4 5 6
18 29 40 51 62 73

Για την αναζήτηση μιας τιμής στον πίνακα Π δίνεται το παρακάτω τμήμα αλγόριθμου:

Διάβασε Χ 
Θέση <- 0 
Βρέθηκε <- Ψευδής Υπάρχει <- Αληθής 
i <- 1
Αρχή_επανάληψης 
   Αν Π[i]=Χ τότε
      Βρέθηκε <- Αληθής 
      Θέση<- i 
   Αλλιώς_αν Π[i]>Χ τότε
      Υπάρχει <- Ψευδής 
   Τέλος_αν
   i <- i +1 
Μέχρις_ότου i>6 ή Βρέθηκε = Αληθής ή Υπάρχει = Ψευδής

Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.
 

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επίλυση της δευτεροβάθμιας εξίσωσης αποτελεί ένα αδόμητο πρόβλημα.
  2. Η εντολή Αρχή_επανάληψης .. Μέχρις_ότου εκτελείται οπωσδήποτε μία φορά.
  3. Τα στοιχεία των στατικών δομών δεδομένων αποθηκεύονται σε μη συνεχόμενες θέσεις μνήμης.
  4. Οι μεταβλητές που χρησιμοποιούνται σ’ ένα πρόγραμμα αντιστοιχούνται από το μεταγλωττιστή σε συγκεκριμένες θέσεις μνήμης του υπολογιστή.
  5. Η ακολουθιακή δομή εντολών χρησιμοποιείται, όταν είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών.

Μονάδες 10

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ
1. Λάθος
2. Σωστό
3. Λάθος
4. Σωστό
5. Σωστό

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα A, Ερώτημα 5, 2014, Ημερήσια

Δίνεται το παρακάτω ημιτελές τμήμα αλγορίθμου:

Α <- …
Β <- …
Αρχή_επανάληψης
Β <- …
Α <- …
Μέχρις_ότου Α>200
Εμφάνισε Β

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με τα κενά συμπληρωμένα, έτσι ώστε να υπολογίζει και να εμφανίζει το άθροισμα των περιττών ακεραίων από το 100 έως το 200.

Μονάδες 8

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, το οποίο εμφανίζει τα τετράγωνα των περιττών αριθμών από το 99 μέχρι το 1 με φθίνουσα σειρά.

Για i από 99 μέχρι 1 μεβήμα -2
x <- i ^2
εμφάνισε x
Τέλος
επανάληψης

α. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Όσο … επανάλαβε».

(μονάδες 5)

β. Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου με αποκλειστική χρήση της δομής επανάληψης «Αρχήεπανάληψης … Μέχριςότου».

(μονάδες 5)

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η τιμή μιας μεταβλητής και ο τύπος της μπορούν να αλλάζουν κατά την εκτέλεση ενός προγράμματος.
  2. Όταν υπάρχουν δυο βρόχοι, ο ένας εμφωλευμένος μέσα στον άλλο, αυτός που ξεκινάει τελευταίος πρέπει να ολοκληρώνεται πρώτος.
  3. Μια διαφορά της εντολής Όσο σε σχέση με την εντολή Μέχρις_ότου οφείλεται στη θέση της λογικής συνθήκης στη ροή εκτέλεσης των εντολών.
  4. Αν Α=2, Β=3, Γ=4 και Δ=ΑΛΗΘΗΣ, τότε η τιμή της έκφρασης (Β*Γ>Α+Β) ΚΑΙ (ΟΧΙ(Δ)) είναι ΑΛΗΘΗΣ.
  5. Κατά την εκτέλεση της εντολής ΔΙΑΒΑΣΕ, το πρόγραμμα διακόπτει την εκτέλεσή του και περιμένει την εισαγωγή τιμών από το πληκτρολόγιο.
  6. Οι πίνακες δεν μπορούν να έχουν περισσότερες από δύο διαστάσεις.

Μονάδες 6