Παράρτημα Α – 1.7 Βασικές Έννοιες και Εντολές

1.7 Μη λυμένες Ασκήσεις
1. Ποιες από τις παρακάτω εντολές είναι σωστές, ποιες είναι λάθος και γιατί;

1. χ* χ <- α1 , ΛΑΘΟΣ, έκφραση αντί μεταβλητής στο αριστερό μέρος
2. χψ <- β , ΛΑΘΟΣ, έκφραση αντί μεταβλητής στο αριστερό μέρος 
3. ψ <- 5^2+3 ΑΚΕΡΑΙΕΣ
4. α <- ’χ > 3’ , ΧΑΡΑΚΤΗΡΕΣ
5. yx <- χ> 3 , ΛΟΓΙΚΗ
6. χ+ψβ <- 5  , ΛΑΘΟΣ, έκφραση αντί μεταβλητής στο αριστερό μέρος
7. 3κ <- α + β  , ΛΑΘΟΣ, μη προβλεπόμενο όνομα μεταβλητής (ξεκινά με αριθμό)
8. 1χ <- χ+ψ  , ΛΑΘΟΣ, μη προβλεπόμενο όνομα μεταβλητής (ξεκινά με αριθμό)
9. α1 <- 5+x  , ΑΡΙΘΜΗΤΙΚΗ (ΑΚΕΡΑΙΑ Ή ΠΡΑΓΜΑΤΙΚΗ)
10. x <- ’Ψευδής’  , ΧΑΡΑΚΤΗΡΑΣ
11. y <- Ψευδής  , ΛΟΓΙΚΗ
12. Όνομα <- ΜΑΡΙΑ , ότι και η μεταβλητή ΜΑΡΙΑ
13. Όνομα <- ’ΜΑΡΙΑ’ , ΧΑΡΑΚΤΗΡΑΣ
14. Τιμή <- ’12’ , ΧΑΡΑΚΤΗΡΑΣ
15. Τιμή <- 12 , ΑΚΕΡΑΙΑ
16. α <- 3 < 2 *5 , ΛΟΓΙΚΗ
17. α&β <- α  ΛΑΘΟΣ, μη προβλεπόμενο όνομα μεταβλητής (μόνο το σύμβολο_ είναι αποδεκτό)
18. ΑΛΗΘΗΣ <- α , ΛΑΘΟΣ , μη προβλεπόμενο όνομα μεταβλητής (Δεσμευμένη λέξη) 
19. χ <- 3 * 2^ 2+(10 - 6)^ 2 , ΑΡΙΘΜΗΤΙΚΗ (ΑΚΕΡΑΙΑ Ή ΠΡΑΓΜΑΤΙΚΗ) 
20. ΕΛΕΝΗ <- Χ + ψ , ότι και οι μεταβλητές στο δεξί μέρος

2.Να υπολογιστούν οι τιμές των παρακάτω αριθμητικών εκφράσεων:

1. (3^2+T_P(9))/2 
(9+3)/2 
12/2 = 6

2. A_T(10-5^2)+7 
A_T(10-25)+7
A_T(-15)+7 
15+7 = 22
3. 3 mod 2 + 5^2 – 2 div 3 
1 + 25 – 0 = 26 

4. (3*2 div 2) mod 5 
(6 div 2) mod 5 
(3) mod 5 = 3
5. T_P(3^2+4^2)/(2+1) 
 T_P(9+16)/3 
 T_P(25)/3 
= 5/3 
6. 7/2+6 
 3,5+6 = 9,5

7. (7+6)/2 
(13)/2 = 6,5
  1. Να γράψετε τις παρακάτω μαθηματικές εκφράσεις σε «ΓΛΩΣΣΑ»:

Λύση

1. (χ^2+y^2)/2
2. 5*β+ (2*α + β^2)/(α+β)
3. Τ_Ρ(χ+y)-4/(3+x)
4. Τ_Ρ(χ/7) + 5
5. Τ_Ρ((χ+5)/y) + A_T(α+β)
6. α^2 + (3+Τ_Ρ(χ))(Τ_Ρ(4+y^2))
  1. Να βρεθούν οι τιμές των παρακάτω λογικών εκφράσεων, αν η μεταβλητή Α έχει τη τιμή 6, η με ταβλητή Β έχει τη τιμή -2 και η μεταβλητή Γ έχει τη τιμή 20.
1. (Α > 12 ΚΑΙ Β > -6) Ή (ΟΧΙ Α < 6 ΚΑΙ Β > 11) 
2. ΟΧΙ (Α < 3 Ή Β > -1) 
3. (ΟΧΙ Α > -2) ΚΑΙ (ΟΧΙ Β < -13) 
4. (Α < 43 Ή Β > Γ) ΚΑΙ Α > Γ 
5. ΟΧΙ (Α > Β ΚΑΙ Α > Γ) 
6. ΟΧΙ (Α > Β) ΚΑΙ (Α > Γ)

Λύση
1. (Α > 12 ΚΑΙ Β > -6) Ή (ΟΧΙ Α < 6 ΚΑΙ Β > 11) = Ψ
Αντικαθιστώ τιμές:
(6 > 12 ΚΑΙ -2 > -6) Ή (ΟΧΙ 6 < 6 ΚΑΙ -2 > 11)
Κάνω τις αριθμητικές πράξεις: -
Κάνω τις συγκρίσεις:
(Ψ ΚΑΙ Α) Ή (ΟΧΙ Ψ ΚΑΙ Ψ)
Κάνω τις λογικές πράξεις:
(Ψ) Ή (Α ΚΑΙ Ψ)
(Ψ) Ή (Ψ)
Ψ

2. ΟΧΙ (Α < 3 Ή Β > -1) : Α
Αντικαθιστώ τιμές:
ΟΧΙ (6 < 3 Ή -2 > -1)
Κάνω τις συγκρίσεις:
ΟΧΙ (Ψ Ή Ψ)
Κάνω τις λογικές πράξεις:
ΟΧΙ (Ψ Ή Ψ)
ΟΧΙ (Ψ)
Α
3. (ΟΧΙ Α > -2) ΚΑΙ (ΟΧΙ Β < -13) :Α
Αντικαθιστώ τιμές:
(ΟΧΙ 6 > -2) ΚΑΙ (ΟΧΙ -2 < -13)
Κάνω τις συγκρίσεις:
(ΟΧΙ Α) ΚΑΙ (ΟΧΙ Ψ)
Κάνω τις λογικές πράξεις:
(Ψ) ΚΑΙ (Α)
Α

4. (Α < 43 Ή Β > Γ) ΚΑΙ Α > Γ
Αντικαθιστώ τιμές:
(6 < 43 Ή -2 > 20) ΚΑΙ 6 > 20
Κάνω τις συγκρίσεις:
(Α Ή Ψ) ΚΑΙ Ψ
Κάνω τις λογικές πράξεις:
(Α) ΚΑΙ Ψ
Ψ
5. ΟΧΙ (Α > Β ΚΑΙ Α > Γ) : Α
Αντικαθιστώ τιμές:
ΟΧΙ (6 > -2 ΚΑΙ 6 > 20)
Κάνω τις συγκρίσεις:
ΟΧΙ (Α ΚΑΙ Ψ)
Κάνω τις λογικές πράξεις (προηγούνται οι παρενθέσεις):
ΟΧΙ (Ψ)
Α
6. ΟΧΙ (Α > Β) ΚΑΙ (Α > Γ) :Ψ
Αντικαθιστώ τιμές:
ΟΧΙ (6 > -2) ΚΑΙ (6 > 20)
Κάνω τις συγκρίσεις:
ΟΧΙ Α ΚΑΙ Ψ
Κάνω τις λογικές πράξεις (ή άρνηση προηγείται της σύζευξης):
Ψ ΚΑΙ Ψ
Ψ
  1. Ποια είναι η τιμή της μεταβλητής x, όταν εκτελεστούν οι παρακάτω εντολές; Να γίνει πίνακας τιμών.
α ← 10
β ← α+3^2
γ ← α+β
x ← (β + γ* 2)* 100
α ← x
x ← β + α
  1. Τι εμφανίζουν τα παρακάτω προγράμματα για τιμές εισόδου 12 και 7;
ΠΡΟΓΡΑΜΜΑ Πρόγραμμα1
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: α, β, γ, δ, χ, ψ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε 2 ακέραιες τιμές τιμές' ΔΙΑΒΑΣΕ χ, ψ
γ <- χ div ψ
δ <- χ mod ψ
ΓΡΑΨΕ 'χ=', χ, ' ψ=', ψ
ΓΡΑΨΕ 'Υπόλοιπο=', δ
ΓΡΑΨΕ 'Πηλίκο=', γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πρόγραμμα1
ΠΡΟΓΡΑΜΜΑ Πρόγραμμα2
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x,y
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε το x'
ΔΙΑΒΑΣΕ x
ΓΡΑΨΕ 'Δώσε το y'
ΔΙΑΒΑΣΕ y
x ← 3 ^ 2+10 div 2^2
y ← 5+2 ^2 * 2+7 div 2
ΓΡΑΨΕ 'Νέα τιμή x =',x
ΓΡΑΨΕ 'Νέα τιμή y =',y
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πρόγραμμα2
  1. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το πλήθος των άτοκων δόσεων που επιθυμεί να πληρώσει ένας πελάτης για κάποια αγορά του και το ποσό της αγοράς. Να υπολογίζει και να εμφανίζει με κατάλληλο μήνυμα το ποσό της κάθε δόσης.
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_7
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΠΛΗΘΟΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΔΟΣΗ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε το Ποσό'
ΔΙΑΒΑΣΕ ΠΟΣΟ
ΓΡΑΨΕ 'Δώσε Αριθμό Δόσεων'
ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
ΔΟΣΗ<- ΠΟΣΟ/ΠΛΗΘΟΣ
ΓΡΑΨΕ 'Μηνιαία Δόση:', ΔΟΣΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
  1. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει έναν τριψήφιο αριθμό. Να υπολογίζει και να εμφανίζει το άθροισμα των ψηφίων του.
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_8
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: μον, δεκ, εκατ, τριψ, υπολ, αθρ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε τριψήφιο αριθμό'
ΔΙΑΒΑΣΕ τριψ
μον <- τριψ MOD 10
υπολ <- τριψ DIV 10
δεκ <- υπολ MOD 10
εκατ <- τριψ DIV 10
άθρ <- μον + δεκ + εκατ
ΓΡΑΨΕ αθρ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

!β τρόπος
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_8
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: μον, δεκ, εκατ, τριψ, υπολ, αθρ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε τριψήφιο αριθμό'
ΔΙΑΒΑΣΕ τριψ
εκατ <- τριψ DIV 100
υπολ <- υπολ MOD 100
δεκ <- υπολ DIV 10
εκατ <- υπολ MOD 10
άθρ <- μον + δεκ + εκατ
ΓΡΑΨΕ αθρ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

!γ τρόπος
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_8
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: μον, δεκ, εκατ, τριψ, υπολ, αθρ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε τριψήφιο αριθμό'
ΔΙΑΒΑΣΕ τριψ
εκατ <- Α_Μ(τριψ/100)
μον <- τριψ - (Α_Μ(τριψ/10) * 10)
δεκ <- (τριψ - εκατ * 100 - μον)/10
ΓΡΑΨΕ 'εκατοντάδες:',εκατ
ΓΡΑΨΕ 'δεκ:',δεκ
ΓΡΑΨΕ 'μον:',μον
άθρ <- μον + δεκ + εκατ
ΓΡΑΨΕ 'άθροισμα ψηφίων:',αθρ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  1. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το κεφάλαιο που κατατέθηκε σε κάποια τράπεζα με επιτόκιο 1,6%. Να υπολογίζει και να εμφανίζει τον τόκο που θα εισπράξουμε μετά από 3 χρόνια.
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_9
ΣΤΑΘΕΡΕΣ
  ΕΠΙΤΟΚΙΟ = 0.016
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΚΕΦΑΛΑΙΟ, ΤΟΚΟΣ1, ΤΟΚΟΣ2, ΤΟΚΟΣ3, ΤΟΚΟΣ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε ΚΕΦΑΛΑΙΟ'
  ΔΙΑΒΑΣΕ ΚΕΦΑΛΑΙΟ
  ΤΟΚΟΣ1 <- ΚΕΦΑΛΑΙΟ* ΕΠΙΤΟΚΙΟ
  ΓΡΑΨΕ ΤΟΚΟΣ1
  ΚΕΦΑΛΑΙΟ <- ΚΕΦΑΛΑΙΟ + ΤΟΚΟΣ1
  ΤΟΚΟΣ2 <- ΚΕΦΑΛΑΙΟ* ΕΠΙΤΟΚΙΟ
  ΓΡΑΨΕ ΤΟΚΟΣ2
  ΚΕΦΑΛΑΙΟ <- ΚΕΦΑΛΑΙΟ + ΤΟΚΟΣ2
  ΤΟΚΟΣ3 <- ΚΕΦΑΛΑΙΟ* ΕΠΙΤΟΚΙΟ
  ΓΡΑΨΕ ΤΟΚΟΣ3
  ΤΟΚΟΣ <- ΤΟΚΟΣ1 + ΤΟΚΟΣ2 + ΤΟΚΟΣ3
  ΓΡΑΨΕ 'ΤΟΚΟΙ ΤΡΙΕΤΙΑΣ:', ΤΟΚΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
  1. Ένας υπάλληλος σε μια εταιρεία, επιπλέον του βασικού μισθού του, παίρνει επίδομα 20€ για κάθε παιδί και 30€ επίδομα γάμου, ενώ έχει κρατήσεις 15% στο βασικό μισθό του. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», που να διαβάζει τον βασικό μισθό του υπαλλήλου, και τον αριθμό των παιδιών του (θεωρούμε ότι ο υπάλληλος είναι παντρεμένος). Να υπολογίζει και να εμφανίζει τον τελικό μισθό του, τυπώνοντας κατάλληλο μήνυμα.
ΠΡΟΓΡΑΜΜΑ παρ_α_1_7_10
ΣΤΑΘΕΡΕΣ
  ΕΠΙΔ_ΓΑΜΟΥ = 30
  ΕΠΙΔ_ΠΑΙΔΙΟΥ = 20
  ΠΟΣΟΣΤΟ_ΚΡΑΤΗΣΕΩΝ = 0.15
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΠΛΗΘΟΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΣΙΚΟΣ, ΠΛΗΡΩΤΕΟΣ, ΚΡΑΤΗΣΕΙΣ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε Βασικό Μισθό'
  ΔΙΑΒΑΣΕ ΒΑΣΙΚΟΣ
  ΓΡΑΨΕ 'Δώσε Αριθμό Παιδιών'
  ΔΙΑΒΑΣΕ ΠΛΗΘΟΣ
  ΚΡΑΤΗΣΕΙΣ <- ΠΟΣΟΣΤΟ_ΚΡΑΤΗΣΕΩΝ * ΒΑΣΙΚΟΣ
  ΠΛΗΡΩΤΕΟΣ <- ΒΑΣΙΚΟΣ + ΕΠΙΔ_ΓΑΜΟΥ + (ΕΠΙΔ_ΠΑΙΔΙΟΥ * ΠΛΗΘΟΣ) - ΚΡΑΤΗΣΕΙΣ
  ΓΡΑΨΕ 'Πληρωτέος Μισθός κατόπιν επιδομάτων και κρατήσεων: ', ΠΛΗΡΩΤΕΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This