Επιλογή Σελίδας

ΔΤ2, Κεφάλαιο 9, Ελάχιστο – Μεγιστο στοιχείο μονοδιάστατου πίνακα, Min – Max, Τυπικές επεξεργασίες

Έχουμε δύο πίνακες, ο ένας με τα μοντέλα των υπολογιστών και ο δεύτερος με τις τιμές τους. Να γράψετε τις εντολές που βρίσκουν και τυπώνουν το φθηνότερο μοντέλο καθώς και το ακριβότερο.

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Να αναφέρετε ονομαστικά τις τυπικές επεξεργασίες πινάκων.

Μονάδες 10

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

Θέμα Β, Ερώτημα 2, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται μονοδιάστατος πίνακας Α[40] και το παρακάτω ημιτελές τμήμα αλγορίθμου, το οποίο αντιγράφει όλα τα στοιχεία του Α σε ένα δισδιάστατο πίνακα Β[8,5] κατά γραμμή. Δηλαδή, τα 5 πρώτα στοιχεία του μονοδιάστατου πίνακα τοποθετούνται στην πρώτη γραμμή του πίνακα Β, τα επόμενα 5 στη δεύτερη γραμμή κ.ο.κ.

I <-- 1 
K <-- 1
Για M από 1 μέχρι …(1)…
             B[I, K] <-- A[…(2)…]
              …(3)... <-- …(4)…+ 1
             Αν …(5)… > …(6)… τότε
                        I <-- I + …(7)…
                        K <-- …(8)…
             Τέλος_αν 
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (8), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 8

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

I <-- 1 
K <-- 1 
Για M από 1 μέχρι  40  
    B[I, K] <-- A[ Μ ] 
    Κ  <--  Κ  + 1 
Αν  Κ  >  5  τότε 
I ← I +  1  
K ←  1  
Τέλος_αν 
Τέλος_επανάληψης

Θέμα Α, Ερώτημα 1, 2014, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Οι γλώσσες χαμηλού επιπέδου είναι τεχνητές γλώσσες, ενώ οι γλώσσες υψηλού επιπέδου είναι φυσικές γλώσσες.
  2. Η προσπέλαση, η διαγραφή και η αναζήτηση είναι όλες βασικές λειτουργίες επί των στατικών δομών δεδομένων.
  3. Ο πολλαπλασιασμός αλά ρωσικά είναι μία από τις βασικές λειτουργίες του υπολογιστή.
  4. Η ιεραρχία των λογικών τελεστών είναι μικρότερη των συγκριτικών.
  5. Κατά την κλήση ενός υποπρογράμματος, κάθε πραγματική παράμετρος και η αντίστοιχή της τυπική πρέπει να είναι του ίδιου τύπου.

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 5, 2014, Επαναληπτικές, Ημερήσια

α. Τι ονομάζεται πίνακας στη ΓΛΩΣΣΑ; (μονάδες 2)

β. Δίνεται o παρακάτω αλγόριθμος, ο οποίος αντιγράφει τα Ν στοιχεία ενός μονοδιάστατου πίνακα Α, ακολουθούμενα από τα Μ στοιχεία ενός μονοδιάστατου πίνακα Β, σε ένα μονοδιάστατο πίνακα Γ με Ν+Μ στοιχεία.

Αλγόριθμος Συνένωση
Δεδομένα //Α, Ν, Β, Μ//
Για i απόμέχρι
Γ[…]<-Α[…]
Τέλος_επανάληψης
Για i απόμέχρι
Γ[…] <Β[…]
Τέλος_επανάληψης
Αποτελέσματα //Γ//
Τέλος Συνένωση

Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο με τα κενά συμπληρωμένα, έτσι ώστε να επιτελεί την επιθυμητή λειτουργία. (μονάδες 8)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Ερώτημα 3, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

  1. Να αναφέρετε ονομαστικά τις κατηγορίες στις οποίες διακρίνονται τα προβλήματα, με κριτήριο το είδος της επίλυσης που επιζητούν αυτά.

Μονάδες 3

  1. Να αναφέρετε δύο βασικές λειτουργίες επί των δομών δεδομένων που δεν μπορούν να χρησιμοποιηθούν στους πίνακες. Να αιτιολογήσετε την απάντησή σας.

Μονάδες 4

  1. Ποια η διαφορά μεταξύ:

α.   μεταβλητών και παραμέτρων;

Μονάδες 3

β.    τυπικών και πραγματικών παραμέτρων;

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Ερώτημα 2, Θέμα A, 2008, Επαναληπτικές, Ημερήσια

 

ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ

Να γράψετε στο τετράδιό σας τους αριθμούς 1,2,3,4 της Στήλης Α και δίπλα ένα από τα γράμματα α,β,γ,δ,ε,στ της Στήλης Β που αντιστοιχεί στον σωστό ορισμό.

Στήλη Α Στήλη Β
1.  Προσθήκη νέων κόμβων σε μία υπάρχουσα δομή. α.   Προσπέλαση

β.   Αντιγραφή

γ.   Διαγραφή

δ.   Αναζήτηση

ε.    Εισαγωγή

στ.  Ταξινόμηση

2.   Οι κόμβοι μιας δομής διατάσσονται κατά αύξουσα ή φθίνουσα σειρά.
3.   Πρόσβαση σε ένα κόμβο με σκοπό να εξετασθεί ή να τροποποιηθεί το περιεχόμενό του.
4.  Όλοι οι κόμβοι ή μερικοί από τους κόμβους μιας δομής αντιγράφονται σε μία άλλη δομή.

ΣΗΜΕΙΩΣΗ: Δύο (2) στοιχεία της Στήλης Β δεν χρησιμοποιούνται.

Μονάδες 8

Τα θέματα σε pdf, 2008, Επαναληπτικές, Ημερήσια