Διδιάστατοι Πίνακες, Α

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8| 9
Άσκηση 1
[1] Να υλοποιηθεί αλγόριθμος ο οποίος: Α) να καταχωρεί τιμές σε διδιάστατο πίνακα Α[3,3] Β) να υπολογίζει το άθροισμα της κυρίας και δευτερεύουσας διαγωνίου του πίνακα.

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 2
[2] Να δημιουργηθεί τετραγωνικός πίνακας Α[Ν,Ν] έτσι ώστε όλα τα στοιχεία πάνω από την κύρια διαγώνιο (I<J) να έχουν την τιμή 1, τα στοιχεία της κυρίας διαγωνίου (I=J) την τιμή 0 και τα στοιχεία κάτω από την κύρια διαγώνιο (I>J) την τιμή 2.

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 3
[3]

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 4
[4]

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 5
[5]
Άσκηση 6
[6]
Άσκηση 7
[7] Να διαβαστούν τα στοιχεία ενός δισδιάστατου πίνακα με 10 γραμμές και 20 στήλες και να βρεθεί το πλήθος των θετικών και των αρνητικών αριθμών κάθε στήλης του πίνακα.

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 8
[8] Να διαβαστούν 20 αριθμοί σ’ έναν πίνακα και να γίνει αντιμετάθεσή τους. Δηλαδή, ο 1ος αριθμός να πάει στην 20η θέση, ο 2ος στην 19η θέση κοκ. (Αντιστροφή στοιχείων πίνακα)

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Άσκηση 9
[9] Δίνεται πίνακας Ν στοιχείων και ένας αριθμός Χ. Να βρεθεί η θέση ή οι θέσεις του Χ μέσα στον πίνακα. Να δεν ανήκει στον πίνακα, να τυπωθεί ανάλογο μήνυμα. (Χρήση flag: Αν βρεθεί το στοιχείο τότε flag=1 αλλιώς flag=0 ή flag=Αληθές αλλιώς Ψευδές).

ΠΡΟΓΡΑΜΜΑ 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: 
ΑΡΧΗ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
Share This