Επιλογή Σελίδας

Θέμα Β, 2017, Ημερήσια

ΘΕΜΑ Β
Β1. Δίνεται το παρακάτω απόσπασμα αλγορίθμου:
i<– …(1)
Όσο i≤ …(2) επανάλαβε
Αν i …(3) <> …(4) τότε
Γράψε i
Τέλοςαν
i <– i +  …(5)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του παραπάνω αποσπάσματος, και δίπλα σε κάθε αριθμό τι πρέπει να συμπληρωθεί, ώστε με την εκτέλεσή του να εμφανίζονται οι τιμές:
4, 8, 16, 20, 28, 32, 40
Μονάδες 10
Β2. Το ακόλουθο πρόγραμμα έχει σκοπό να διαβάζει 10 θετικούς αριθμούς και να υπολογίζει και να εμφανίζει το γινόμενο όσων από αυτούς είναι πολλαπλάσιοι και του 3 και του 5 (συγχρόνως). Στο πρόγραμμα, όμως, υπάρχουν λάθη.
α) Να εντοπίσετε τα λάθη αυτά και στο τετράδιό σας να γράψετε τον αριθμό της γραμμής που βρίσκεται το λάθος και τον χαρακτηρισμό του (συντακτικό ή λογικό).
β) Στη συνέχεια να γράψετε το σωστό πρόγραμμα διορθώνοντας τα λάθη που εντοπίσατε.
1. Πρόγραμμα Αριθμοί
2. Μεταβλητές
3.    Πραγματικές: Χ
4.    Ακέραιες: Ρ, i
5. Αρχή
6. Ρ <– 0
7. Για i από 1 μέχρι 10
8.      Διάβασε Χ
9.     Αν Χ MOD 3 = 0 Ή MOD 5 = 0 τότε
10         Ρ <– Ρ * Χ
11.    Τέλοςεπανάληψης
12. Τέλος
επανάληψης
13. Γράψε Ρ
14 Τέλος_προγράμματος
Σημείωση: Θεωρείστε ότι κατά την εκτέλεση του προγράμματος θα δοθεί τουλάχιστον ένας τέτοιος αριθμός.
Μονάδες 10

ΔΤ2, Κεφάλαιο 10, Διάφορα υποπρογράμματα, ύψωση σε δύναμη, άρτιος, ελάχιστος (min), υπολογισμός ΦΠΑ

Να γράψεις τα υποπρογράμματα που υλοποιούν τα παρακάτω:

Α) Να διαβάζει έναν αριθμό και να επιστρέφει το τετράγωνό του.

Β) Να δέχεται δύο αριθμούς και να επιστρέφει το μικρότερο από δύο αριθμούς.

Γ) Να δέχεται την τιμή ενός προϊόντος και να υπολογίζει και να τυπώνει την αξία του ΦΠΑ.

Δ) Να ελέγχει αν ένας αριθμός είναι άρτιος.

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 4, 2016, Ημερήσια, Νέο

Έστω ο μονοδιάστατος πίνακας Α:

5                 2                 3                 8                 7                 4                10               12

Να σχεδιάσετε τον πίνακα Β[6] μετά την εκτέλεση των παρακάτω εντολών:

  1. Β[Α[1] – Α[3]] <- Α[5]
  2. Β[Α[7] – Α[5]] <- Α[2] + Α[7]
  3. Β[Α[6]] <- Α[4]
  4. Β[Α[1] + Α[4] – Α[8]] <- Α[3] + Α[8]
  5. Β[Α[8] DIV 2] <- A[3] MOD 2
  6. B[A[1] MOD A[4]] <- A[6] + 4

Μονάδες 12

ΛΥΣΗ (περισσότερα…)

Θέμα B, Ερώτημα 2, 2016, Επαναληπτικές, Νέο

Δίνεται το παρακάτω τμήμα προγράμματος, το οποίο μετατρέπει έναν ακέραιο αριθμό από το δεκαδικό σύστημα στο δυαδικό.

Π <- 1 
Ι <- 0
ΔΙΑΒΑΣΕ Α 
ΟΣΟ Π <> 0 ΕΠΑΝΑΛΑΒΕ
    Ι <- Ι + 1
    Π <- A DIV 2
    Y<- A MOD 2
    Δ[I] <- Y
    A <- Π 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
     ΓΡΑΨΕ Δ[Κ] 
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α. Για την τιμή Α = 11 :
i) Να συμπληρώσετε τον παρακάτω πίνακα τιμών.

Π Υ Α Ι

(Μονάδες 5)

ii) Να γράψετε τον αριθμό Α και δίπλα του, διαδοχικά, τις τιμές που εμφανίζει το τμήμα του προγράμματος (οι αριθμοί αυτοί αποτελούν τη δυαδική αναπαράσταση του αριθμού Α).  (μονάδες 2)

βΝα επαναλάβετε τα ανωτέρω i) και ii) βήματα για την τιμή Α = 8. (μονάδες 5 + 2)

Μονάδες 14

 

ΛΥΣΗ  (περισσότερα…)

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Παλαιό

Να γράψετε στο τετράδιό σας τους αριθμούς της στήλης Α καιδίπλατο γράμμα της στήλης Β που αντιστοιχεί σωστά. (Να θεωρήσετε ότι ο είναι θετικός ακέραιος).
 
Στήλη   Α Στήλη  Β
1. X DIV 1000 = 0 α. Βρίσκει την τιμή του ψηφίου των χιλιάδων.
2. X DIV 1000 MOD 10 β. Ελέγχει αν ο αριθμός έχει τουλάχιστον τρία  ψηφία.
3. X DIV 100 <> 0 γ. Βρίσκει την τιμή του ψηφίου των εκατοντάδων.
4. X MOD 1000 DIV 100 δ. Ελέγχει  αν ο αριθμός έχει  το πολύ τρία ψηφία.

Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

1. δ
2. α
3. β
4. γ

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 3, 2014, Ημερήσια

Δίνονται οι τιμές των μεταβλητών Χ=8 και Ψ=4 και η παρακάτω έκφραση:

(ΟΧΙ (9 mod 5 = 20-4*2^2)) ΄ H (X>Ψ ΚΑΙ X>“Ψ”)

Να υπολογίσετε την τιμή της έκφρασης αναλυτικά, ως εξής:

α. Να αντικαταστήσετε τις μεταβλητές με τις τιμές τους.(μονάδα 1)

β. Να εκτελέσετε τις αριθμητικές πράξεις. (μονάδα 1)

γ. Να   αντικαταστήσετε τις συγκρίσεις με την τιμή ΑΛΗΘΗΣ, αν η σύγκριση είναι αληθής, ή με την τιμή ΨΕΥΔΗΣ, αν η σύγκριση είναι ψευδής. (μονάδα 1)

δ. Να εκτελέσετε τις λογικές πράξεις, ώστε να υπολογίσετε την τελική τιμή της έκφρασης. (μονάδες 2)

Μονάδες 5

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 3, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο πίνακας Α[10], στον οποίο επιθυμούμε να αποθηκεύσουμε όλους τους ακεραίους αριθμούς από το 10 μέχρι το 1 με φθίνουσα σειρά. Στον πίνακα έχουν εισαχθεί ορισμένοι αριθμοί, οι οποίοι εμφανίζονται στο παρακάτω σχήμα:

1 2 3 4 5 6 7 8 9 10
10 9 5 4 1

α. Να συμπληρώσετε τις επόμενες εντολές εκχώρησης, ώστε τα κενά κελιά του πίνακα να αποκτήσουν τις επιθυμητές τιμές.

Α[3] <- 3 + Α[…]

Α[9] <- Α[…] – 2

Α[8] <- Α[…] – 5

Α[4] <- 5 + Α[…]

Α[5] <- (Α[…] + Α[7]) div 2

(μονάδες 5)

β.     Να συμπληρώσετε το παρακάτω τμήμα αλγορίθμου, το οποίο αντιμεταθέτει τις τιμές των κελιών του πίνακα Α, έτσι ώστε η τελική διάταξη των αριθμών να είναι από 1 μέχρι 10.

Για i απόμέχρι

αντιμετάθεσε Α[…], Α[…]

Τέλος_επανάληψης

(μονάδες 4)

Μονάδες 9

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Θέμα A, Ερώτημα 5, 2012, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου που χρησιμοποιεί ένα μονοδιάστατο πίνακα Α[20]. Ο πίνακας περιέχει άρτιους και περιττούς θετικούς ακεραίους, σε τυχαίες θέσεις. Το τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Β[20] στον οποίο υπάρχουν πρώτα οι άρτιοι και μετά ακολουθούν οι περιττοί. Να γράψετε στο τετράδιό σας τον αλγόριθμο συμπληρώνοντας τα κενά:

Κ <- 0
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 = 0 τότε
Κ    <-    ………….
Β[………… ] <- A[i]
Τέλος_αν
Τέλος_επανάληψης
Για i από …………….  μέχρι…………….
Αν Α[i] mod 2 =…………….. τότε
………………..
Β[………… ] <- A[………….. ]
Τέλος_αν
Τέλος_επανάληψης

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια