Επιλογή Σελίδας

Παράδειγμα 1, Κεφάλαιο 8, Βιβλίο, Κλίμακα υπολογισμού τιμής Υπολογιστών

Στο πρόγραμμα του προηγούμενου κεφαλαίου (πωλήσεις υπολογιστών) υποθέτουμε ότι η τιμή των υπολογιστών εξαρτάται από την ποσότητα παραγγελίας. Συγκεκριμένα ισχύουν οι παρακάτω τιμές αγοράς υπολογιστών.

Ο υπολογισμός με χρήση εμφωλευμένων εντολών ΑΝ είναι:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ
  ΑΝ Ποσότητα<=100 ΤΟΤΕ 
     Κόστος <-- Ποσότητα*520 
  ΑΛΛΙΩΣ
     ΑΝ Ποσότητα<=200 ΤΟΤΕ 
        Κόστος <-- Ποσότητα*470 
     ΑΛΛΙΩΣ 
        Κόστος <-- Ποσότητα*440 
     ΤΕΛΟΣ_ΑΝ 
  ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΑΝ

Το ίδιο πρόγραμμα με τη χρήση της εντολής ΑΝ…ΤΟΤΕ…ΑΛΛΙΩΣ_ΑΝ έχει ως εξής:

ΑΝ Ποσότητα <= 50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=200 ΤΟΤΕ 
Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ 

Ένα συχνό λάθος που παρατηρείται στα προγράμματα είναι ο έλεγχος περιττών συνθηκών. Οι επιπλέον έλεγχοι αυξάνουν την πολυπλοκότητα του προγράμματος. Στο προηγούμενο παράδειγμα για το οποίο θεωρούμε ότι η ποσότητα είναι θετικός αριθμός, ένα παράδειγμα περιττών ελέγχων είναι το ακόλουθο:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 50 ΚΑΙ Ποσότητα <=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα>100 ΚΑΙ Ποσότητα <=200 ΤΟΤΕ
      Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
      Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ

Βλέπε επίσης: ΔΕ1, Κεφαλαίου 8

Θέμα Α, Ερώτημα 1, 2016, Ημερήσια, Νέο

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. O χρόνος εκτέλεσης κάθε αλγορίθμου εξαρτάται από τη Γλώσσα προγραμματισμού που θα χρησιμοποιηθεί.
  2. Οι στατικές δομές στηρίζονται στην τεχνική της δυναμικής παραχώρησης μνήμης.
  3. Σε μια δομή σύνθετης επιλογής, μετά από τις εντολές που βρίσκονται μεταξύ των λέξεων ΤΟΤΕ και ΑΛΛΙΩΣ, εκτελούνται οι εντολές που βρίσκονται μεταξύ των λέξεων ΑΛΛΙΩΣ και ΤΕΛΟΣ_ΑΝ.
  4. Στο τμήμα δηλώσεων ενός προγράμματος, εκτός από τον τύπο ενός πίνακα, πρέπει να δηλώνεται και ο μεγαλύτερος αριθμός στοιχείων που μπορεί να έχει ο συγκεκριμένος πίνακας.
  5. Το πρόγραμμα Συντάκτης εντοπίζει τα συντακτικά λάθη του προγράμματος.

Μονάδες 10

ΛΥΣΗ: (περισσότερα…)

Θέμα Α, Ερώτημα 3, 2016, Ημερήσια, Παλαιό

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Αν x > 0 ή y > 0 τότε
      Εμφάνισε “Ένας τουλάχιστον θετικός αριθμός” 
Αλλιώς_αν x < 0 και y < 0 τότε
      Εμφάνισε “Δύο αρνητικοί αριθμοί” 
Τέλος_αν

Να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο να παράγει το ίδιο αποτέλεσμα με το παραπάνω, χρησιμοποιώντας μόνο τις λογικές συνθήκες x > 0, x < 0, y > 0, y < 0 και χωρίς να χρησιμοποιήσετε λογικούς τελεστές.

Μονάδες 7

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

Αν x > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός' 
Αλλιώς_αν y > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός'
Αλλιώς
    Αν x < 0
       Αν y < 0
          Εμφάνισε 'Δύο αρνητικοί αριθμοί' 
       Τέλος_αν
    Τέλος_αν
Τέλος_αν

Θέμα Β, Ερώτημα 2, 2016, Ημερήσια, Παλαιό

Δίνεται ο πίνακας αριθμών Χ[50], ταξινομημένος κατά φθίνουσα σειρά, και ο πίνακας Υ[100], ταξινομημένος κατά αύξουσα σειρά. Να θεωρήσετε ότι οι τιμές κάθε πίνακα είναι διαφορετικές μεταξύ τους και ότι οι δύο πίνακες δεν έχουν κοινές τιμές.

Το παρακάτω ημιτελές τμήμα αλγορίθμου δημιουργεί ένα νέο πίνακα Ζ[10], ταξινομημένο σε φθίνουσα σειρά, με τις δέκα μεγαλύτερες τιμές από τις εκατόν πενήντα (150) τιμές των δύο πινάκων.

i <--(1)
j <-- (2)
Για k από 1 μέχρι 10
      Αν Χ[ i ] (3) Υ[ j ] τότε 
            Ζ[ k ] <-- Χ[ i ] 
            i <-- i (4) 1 
     Αλλιώς
            Ζ[ k ] <-- Υ[ j ] 
             j <-- j (5) 1 
    Τέλος_αν
Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (5), που αντιστοιχούν στα κενά του αλγορίθμου, και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 10

ΛΥΣΗ (περισσότερα…)

Θέμα Β, Ερώτημα 1, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος θέμα_Β1
                ΠΛ <-- 0
                Σ  <-- 0
                Για Ι από 100 μέχρι 10 με_βήμα -3 
                       Αν Ι mod 2 <> 0 τότε
                             Σ <-- Σ + Ι 
                       Αλλιώς
                             ΠΛ <-- ΠΛ + 1 
                       Τέλος_αν 
                Τέλος_επανάληψης 
                Εμφάνισε Σ, ΠΛ 
Τέλος θέμα_Β1

Να  σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 12

Τα θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Γ, 2016, Επαναληπτικές, Ημερήσια, Παλαιό

Ένα ξενοδοχείο χρεώνει την ενοικίαση των δωματίων του ανάλογα με τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, σύμφωνα με τον παρακάτω πίνακα:

ΑΡΙΘΜΟΣ ΗΜΕΡΝ ΤΟΥΡΙΣΤΙΚΗ ΠΕΡΙΟΔΟΣ
ΧΑΜΗΛΗ ΥΨΗΛΗ
1-3 40€ ανά ημέρα 70€ ανά ημέρα
4-7 30€ ανά ημέρα 55€ ανά ημέρα
>7 25€ ανά ημέρα 50€ ανά ημέρα

Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Γ 1.       Nα περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Γ2.       Για καθεμιά από τις 500 κρατήσεις του ξενοδοχείου κατά το προηγούμενο έτος:
α. Να διαβάζει τον αριθμό των ημερών ενοικίασης καθώς και την τουριστική περίοδο που έγινε η κράτηση, εξασφαλίζοντας ότι η επιτρεπτή τιμή για την τουριστική περίοδο είναι ΧΑΜΗΛΗ ή ΥΨΗΛΗ.   (μονάδες 3)
β. Να καλεί υποπρόγραμμα με είσοδο τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, το οποίο να υπολογίζει, με βάση τον προηγούμενο πίνακα, τη χρέωση της κράτησης. O υπολογισμός της χρέωσης δεν γίνεται κλιμακωτά.  (μονάδες 2)
γ.     Να εμφανίζει τη χρέωση της κράτησης.  (μονάδα 1)
Μονάδες 6

Γ3.      Nα υπολογίζει και να εμφανίζει τη συνολική χρέωση των κρατήσεων του ξενοδοχείου για καθεμιά τουριστική περίοδο του προηγούμενου έτους.
Μονάδες 4

Γ4.       Nα κατασκευάσετε το υποπρόγραμμα του ερωτήματος Γ2.β.
Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Θέμα Β, 2014, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα:

01  Πρόγραμμα Κλήση_Υποπρογραμμάτων
02  Μεταβλητές
03  Ακέραιες: α, β, γ, π
04  Αρχή
05 Διάβασε α
06 Β<-3
07 γ<-Φ(α,β)
08 α<-α+γ
09 Αν α>20 τότε
10                    γ<-Φ(β,α)
11        Αλλιώς
12                    γ<-Φ(γ,α)
13 Τέλος_αν
14 Π<-0
15 Όσο γ mod 10=0 επανάλαβε
16 π<-π+1
17 γ<-γ div 10
18 Τέλος_επανάληψης
19 Γράψε γ,π
20  Τέλος_προγράμματος

21 Συνάρτηση Φ(μ, λ): Ακέραια
22 Μεταβλητές
23        Ακέραιες: κ, λ, μ
24  Αρχή
25 κ<- λ+μ
26 Φ<-κ^μ
27  Τέλος_συνάρτησης

Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμή εισόδου α=2, δίνεται το παρακάτω υπόδειγμα πίνακα τιμών, μερικώς συμπληρωμένο ως εξής:

  • Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός γραμμής της εντολής που εκτελείται.
  • Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή που εκτελείται είναι εντολή εξόδου.
  • Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη.
  • Οι υπόλοιπες στήλες του πίνακα αντιστοιχούν στις μεταβλητές του κυρίου προγράμματος.
  • Σε όποια σημεία καλείται υποπρόγραμμα και κατά τη διάρκεια της εκτέλεσής του, ο πίνακας επεκτείνεται με μια στήλη για κάθε μεταβλητή του υποπρογράμματος.
Αριθμός γραμμής Έξοδος Συνθήκη α β γ π
05 2
06 3
07 Φ κ λ μ
3 2
25 5
26 25
07 25
……. …….. …….. ….

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να προσθέσετε τις γραμμές που χρειάζονται, συνεχίζοντας την εκτέλεση του προγράμματος, ως εξής: Για κάθε εντολή που εκτελείται, να γράψετε τον αριθμό της γραμμής της εντολής σε νέα γραμμή του πίνακα και το αποτέλεσμα της εκτέλεσης της εντολής στην αντίστοιχη στήλη.

Μονάδες 20

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 1, 2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κ<- 1
Χ<- -1
i<- 0
Όσο Χ<7 επανάλαβε
i<- i + 1
Κ<-Κ∗Χ
Εμφάνισε Κ, Χ
Αν i mod 2=0  τότε
X<- X+1
Αλλιώς
X<- X+2
ΤέλοςΑν
Τέλος
επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανίσει το τμήμα αλγορίθμου κατά την εκτέλεσή του με τη σειρά που θα εμφανιστούν.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 2,2012, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

er2th2-aepp_2012_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2012, Μαΐου-Ιουνίου, Ημερήσια

Παράδειγμα 3, Βιβλίο μαθητή, Σύγκριση αριθμών με σύνθετη επιλογή

Να διαβασθούν δύο αριθμοί και σε περίπτωση που ο πρώτος αριθμός είναι μικρότερος του δεύτερου, να υπολογισθεί και να εκτυπωθεί το άθροισμά τους, διαφορετικά να υπολογισθεί και να εκτυπωθεί το γινόμενό τους.

Αλγόριθμος Παράδειγμα_3
Διάβασε a, b
Αν a < b τότε
c ← a + b
αλλιώς
c ← a * b
Τέλος_αν
Εκτύπωσε c
Τέλος Παράδειγμα_3
Στο παράδειγμα αυτό χρησιμοποιείται η γενική μορφή της εντολής επιλογής, που είναι:

Αν συνθήκη τότε
εντολή ή εντολές
αλλιώς
εντολή ή εντολές
Τέλος_αν

par3kef2vm