Επιλογή Σελίδας

15, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ, 27ος Π.Δ.Π (2015) Α’ Φάση, Θέμα Λυκείου, Κυλικείο

Μια ομάδα παιδιών στέκονται σε μια ευθεία γραμμή, το ένα πίσω από το άλλο, περιμένοντας τη σειρά τους στο κυλικείο του σχολείου. Το πρώτο παιδί προφανώς βλέπει την είσοδο του κυλικείου, όσα παιδιά όμως στέκονται πίσω του δεν είναι σίγουρο ότι και αυτά τη βλέπουν. Για να βλέπει ένα παιδί την είσοδο του κυλικείου πρέπει όλα τα παιδιά που στέκονται μπροστά του να είναι κοντύτερα από αυτό.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο, αφού διαβάσει τα ύψη 20 παιδιών που βρίσκονται το ένα πίσω από το άλλο θα εμφανίζει τον αριθμό των παιδιών που βλέπουν την είσοδο του κυλικείου. ΕΠΥ, 27ος ΠΔΠ (2015), Α’ Φάση

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Eρώτημα 1, 2015, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμίας από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η επαναληπτικότητα των διαδικασιών είναι ένας από τους λόγους ανάθεσης της επίλυσης ενός προβλήματος σε υπολογιστή. (μονάδες 2)
  2. Ο βρόχος Για κ από 5 μέχρι 5 εκτελείται μία φορά. (μονάδες 2)
  3. Δεν υπάρχουν δομές δεδομένων δευτερεύουσας μνήμης. (μονάδες 2)
  4. Ένας από τους παράγοντες από τους οποίους εξαρτάται η επιλογή της καταλληλότερης γλώσσας προγραμματισμού για την ανάπτυξη μιας εφαρμογής είναι το είδος της εφαρμογής. (μονάδες 2)
  5. Ένα υποπρόγραμμα μπορεί να καλείται μόνο από το κύριο πρόγραμμα. (μονάδες 2)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ

  1. ΣΩΣΤΟ 2. ΣΩΣΤΟ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ

Θέμα Α, Eρώτημα 2, 2015, Ημερήσια

α. Να αναφέρετε ονομαστικά τις κατηγορίες στις οποίες διακρίνονται τα προβλήματα με κριτήριο το είδος της επίλυσης που επιζητούν. (μονάδες 3)

β. Έστω τα παρακάτω επιλύσιμα προβλήματα:

  1. Δίδεται ένας ακέραιος αριθμός Ν και ζητείται ποια είναι η παραγοντοποίηση του Ν με το μεγαλύτερο πλήθος παραγόντων.
  2. Δίδεται ένας ακέραιος αριθμός Ν και το πρόβλημα που τίθεται είναι αν ο Ν είναι άρτιος.
  3. Δίδεται ένας ακέραιος αριθμός Ν και ζητείται να βρεθεί πόσες διαφορετικές παραγοντοποιήσεις του Ν υπάρχουν.

Για καθένα από τα προβλήματα αυτά, να γράψετε στο τετράδιό σας τον αριθμό του (1, 2 ή 3) και δίπλα την κατηγορία στην οποία ανήκει με κριτήριο το είδος της επίλυσης που επιζητεί. (μονάδες 3)

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ (Βλ. παράγραφο 1.5)

Α.2.α 

  • Υπολογιστικά
  • Απόφασης
  • Βελτιστοποίησης

Α.2.β

  1. Βελτιστοποίησης
  2. Απόφασης
  3. Υπολογιστικό

Θέμα Α, Eρώτημα 3, 2015, Ημερήσια

α. Πόσοι δείκτες απαιτούνται για την υλοποίηση μιας ουράς με μονοδιάστατο πίνακα (μονάδες 2) και τι δείχνει ο καθένας; (μονάδες 2)

β. Ποιος δείκτης της ουράς μεταβάλλεται κατά τη λειτουργία της εξαγωγής; (μονάδες 2)

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΑΠΑΝΤΗΣΗ (Βλ. παράγραφο 3.5.)

A.3.α. Δύο δείκτες:

  • Ο Δείκτης εμπρός (front) που δείχνει στο επόμενο προς εξαγωγή στοιχείο
  • Ο Δείκτης πίσω (rear) που δείχνει στο τελευταίο στοιχεία που εισήχθηκε.

A.3.β.  Ο δείκτης εμπρός (front)

 

Θέμα Α, Eρώτημα 4, 2015, Ημερήσια

α. Δίνονται οι παρακάτω εντολές:

 λ <-- λ + 1 
 λ <-- λ - 2 
 λ <-- λ + 3

Να γράψετε στο τετράδιό σας μία εντολή εκχώρησης που παράγει το ίδιο αποτέλεσμα. (μονάδες 3)

β. Δίνονται τα τμήματα αλγορίθμου Ι και ΙΙ:

Ι ΙΙ
Αν ……….. τότε
Αν Χ>Y και Y≠1 τότε Αν ……… τότε
Ζ<- Χ/(Y-1) ……………………
Εμφάνισε Ζ αλλιώς
αλλιώς_αν Χ>Y και Y=1 τότε …………………
Ζ<-Y/X Τέλος αν
Εμφάνισε Ζ …………………………
Τέλος_αν Τέλος αν

Να γράψετε στο τετράδιό σας το τμήμα αλγορίθμου ΙΙ με συμπληρωμένα τα κενά, ώστε να παράγει το ίδιο αποτέλεσμα με το τμήμα αλγορίθμου Ι. (μονάδες 5)

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.4.α    λ <– λ + 2

Α.4.β  

Αν Χ > Υ τότε 
   Αν Υ <> 1 τότε 
      Ζ ← Χ / ( Υ - 1 ) 
   αλλιώς 
      Ζ ← Υ / Χ 
   Τέλος_αν 
   Εµφάνισε Ζ
Τέλος_αν

 

Θέμα Α, Eρώτημα 5, 2015, Ημερήσια

α. Δίνονται οι παρακάτω προτάσεις σε φυσική γλώσσα:

  1. Αύξησε το Χ κατά 2.
  2. Εκχώρησε στο Υ τον μέσο όρο των Κ, Λ, Μ.
  3. Το τελευταίο ψηφίο του Α είναι
  4. Ο Β είναι διψήφιος.

Να θεωρήσετε ότι οι Α και Β είναι θετικοί ακέραιοι. Να γράψετε στο τετράδιό σας τον αριθμό της κάθε πρότασης και δίπλα την κωδικοποίησή της σε ΓΛΩΣΣΑ. (μονάδες 4)
β. Δίνεται το παρακάτω τμήμα αλγορίθμου:

 Διάβασε Χ 
 Αν Χ > 15 τότε
     Γράψε 1 
 αλλιώς_αν Χ > 23 τότε
     Γράψε 2 
 αλλιώς
     Γράψε 3 
 Τέλος_αν

Μια εντολή εξόδου στο παραπάνω τμήμα δεν πρόκειται να εκτελεστεί, όποια και αν είναι η τιμή του Χ.

  1. Ποια είναι η εντολή αυτή; (μονάδες 2)
  2. Να γράψετε τις εντολές εξόδου που είναι δυνατόν να εκτελεστούν και, δίπλα σε καθεμία από αυτές, το διάστημα τιμών του Χ για το οποίο θα εκτελεστεί η εντολή. (μονάδες 4)

Μονάδες 10

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Α.5.α.

  1. Χ ← Χ + 2

  2. Υ ← ( Κ + Λ + Μ ) /3

  3. Α mod 10 = 5

  4. B >= 10 KAI B < 100

A.5.β

  1. Η εντολή Γράψε 2

  2. Γράψε 1 για x > 15

Γράψε 3 για x <= 15

Θέμα B, Eρώτημα 1, 2015, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου η μεταβλητή x έχει θετική ακέραια τιμή:

Αν x > 1 τότε 
   y <-- x
   Αρχή_επανάληψης 
      y <-- y-2 
      Εμφάνισε y 
   Μέχρις_ότου y ≤ 0 
Τέλος_αν

α. Να σχεδιάσετε στο τετράδιό σας το ισοδύναμο διάγραμμα ροής. (μονάδες 6)
β. Να ξαναγράψετε το τμήμα αυτό στο τετράδιό σας, χρησιμοποιώντας την εντολή Για αντί της εντολής Μέχρις_ότου. (μονάδες 8)
Μονάδες 14

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

Β1α.

Β1β.

Αν x>1 τότε 
   Για y από x-2 μέχρι -1 με βήμα –2 
       Εμφάνισε y
   Τέλος_επανάληψης
Τέλος_αν

β' τρόπος
Αν x>1 τότε 
  Για y από x µέχρι 1 µε_βήµα -2 
      Εµφάνισε y-2 
  Τέλος_επανάληψης 
Τέλος_αν

 

 

Θέμα B, Eρώτημα 2, 2015, Ημερήσια

Το παρακάτω ημιτελές τμήμα αλγορίθμου εισάγει αριθμητικές τιμές σε πίνακα 100 θέσεων ώστε:
α. οι τιμές να είναι διαφορετικές μεταξύ τους,
β. οι τιμές να εισάγονται σε αύξουσα σειρά.
Εάν κάποια εισαγόμενη τιμή δεν ικανοποιεί τις συνθήκες (α) και (β), επανεισάγεται.

Διάβασε Π[ ...(1)...] 
 Για i από ...(2)... μέχρι ...(3)...
     Αρχή_επανάληψης 
         Διάβασε Π[i]
     Μέχρις_ότου Π[ ...(4)...] ...(5)... Π[ ...(6)...]
 Τέλος_επανάληψης

Να γράψετε στο τετράδιό σας τους αριθμούς (1) έως (6), που αντιστοιχούν στα κενά του αλγορίθμου και, δίπλα σε κάθε αριθμό, ό,τι πρέπει να συμπληρωθεί, ώστε το τμήμα αλγορίθμου να επιτελεί τη λειτουργία που περιγράφεται.

Μονάδες 6

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

(1) 1 , (2) 2, (3) 100 , (4) i , (5) > , (6) i-1

Θέμα Γ, 2015, Ημερήσια, Μαΐου-Ιουνίου

Μία εταιρεία μεταφοράς δεμάτων διαθέτει δύο αποθήκες, Α και Β, στο αεροδρόμιο. Κατά την παραλαβή δεμάτων, κάθε δέμα τοποθετείται στην αποθήκη που έχει εκείνη τη στιγμή τον περισσότερο ελεύθερο χώρο. Αν ο ελεύθερος χώρος της αποθήκης Α είναι ίσος με τον ελεύθερο χώρο της αποθήκης Β, το δέμα τοποθετείται στην αποθήκη Α. Όταν όμως το δέμα δεν χωρά σε καμία από τις δύο αποθήκες, προωθείται στις κεντρικές εγκαταστάσεις της εταιρείας, που βρίσκονται εκτός αεροδρομίου.

Γ1. Να κατασκευάσετε πρόγραμμα που:

α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 2)

β. Να διαβάζει τα μεγέθη ελεύθερου χώρου των αποθηκών Α και Β. (μονάδες 2)

γ. Να διαβάζει το μέγεθος κάθε εισερχόμενου δέματος και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία θα τοποθετηθεί αυτό ή να εμφανίζει το μήνυμα «Προώθηση», όταν το δέμα δεν χωρά σε καμία από τις αποθήκες Α ή Β. Η διαδικασία παραλαβής τερματίζεται, όταν εισαχθεί ως μέγεθος δέματος η τιμή 0. (μονάδες 6)

δ. Στη συνέχεια, να καλεί υποπρόγραμμα, το οποίο να βρίσκει και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία τοποθετήθηκαν τα περισσότερα δέματα, ή το μήνυμα «Ισάριθμα» σε περίπτωση που στις δύο αποθήκες Α και Β τοποθετήθηκαν ισάριθμα δέματα, ή το μήνυμα «Καμία αποθήκευση στο αεροδρόμιο», αν κανένα δέμα δεν τοποθετήθηκε σε οποιαδήποτε από τις αποθήκες Α ή Β. (μονάδες 2)

Μονάδες 12

Γ2. Να κατασκευάσετε το υποπρόγραμμα που περιγράφεται στο ερώτημα Γ1.δ.

Μονάδες 8

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ (περισσότερα…)

Θέμα Δ, 2015, Ημερήσια

Ένας διαγωνισμός τραγουδιού διεξάγεται σε δύο φάσεις.

Στην πρώτη φάση γίνεται ακρόαση των 45 τραγουδιών που διαγωνίζονται και κάθε μέλος της επταμελούς κριτικής επιτροπής βαθμολογεί το κάθε τραγούδι με βαθμό από 1 έως 10.

Στη δεύτερη φάση προκρίνεται κάθε τραγούδι που συγκέντρωσε συνολική βαθμολογία μεγαλύτερη του 50 και το οποίο όλοι οι κριτές έχουν βαθμολογήσει τουλάχιστον με 5.

Να γραφεί αλγόριθμος, ο οποίος:

Δ1.        Για κάθε τραγούδι να διαβάζει τον τίτλο του και τον βαθμό που έδωσε κάθε κριτής. Δεν απαιτείται έλεγχος εγκυρότητας.

Μονάδες 3

Δ2.        Να υπολογίζει και να εμφανίζει τη συνολική βαθμολογία του κάθε τραγουδιού, η οποία προκύπτει ως το άθροισμα των βαθμών όλων των κριτών.

Μονάδες 2

Δ3. Να βρίσκει και να εμφανίζει τους τίτλους των τραγουδιών που προκρίνονται στη δεύτερη φάση του διαγωνισμού. Αν κανένα τραγούδι δεν προκρίνεται στη δεύτερη φάση, να εμφανίζει κατάλληλο μήνυμα.

Μονάδες 6

Δ4.  Να βρίσκει και να εμφανίζει το πλήθος των κριτών που έδωσαν τον μέγιστο βαθμό τους σε ένα μόνο τραγούδι.

Μονάδες 9

Τα θέματα σε pdf, 2015, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2015, Επαναληπτικές, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5  και, δίπλα, τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη  λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η πράξη της σύζευξης δύο λογικών εκφράσεων δίνει ως αποτέλεσμα την τιμή ΨΕΥΔΗΣ, μόνον όταν και οι δύο εκφράσεις έχουν την  τιμή  ΨΕΥΔΗΣ.
  2. Συνηθέστατα παρατηρείται το φαινόμενο μια δομή δεδομένων να είναι αποδοτικότερη από μια άλλη δομή, με κριτήριο κάποια λειτουργία.
  3. Ο ιεραρχικός προγραμματισμός χρησιμοποιεί τη στρατηγική της συνεχούς διαίρεσης  του  προβλήματος  σε  υποπροβλήματα.
  4. Οι εντολές που βρίσκονται μέσα στο βρόχο μιας εντολής ΓΙΑ εκτελούνται τουλάχιστον  μία  φορά.
  5. Σε μία εντολή εκχώρησης δεν μπορεί να υπάρχει αναφορά σε περισσότερες από  μία  συναρτήσεις.

Μονάδες  10

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

  1. Λάθος 2. Σωστό 3. Σωστό 4. Λάθος 5. Λάθος

 

Θέμα Α, Ερώτημα 2, 2015, Επαναληπτικές, Ημερήσια

α. Να αιτιολογήσετε γιατί ένα από τα πλεονεκτήματα του τμηματικού προγραμματισμού είναι το ότι απαιτεί λιγότερο χρόνο και προσπάθεια στη συγγραφή του προγράμματος   (μονάδες  2).

βΝα γράψετε τη σύνταξη της εντολής ΟΣΟ…  ΕΠΑΝΑΛΑΒΕ (μονάδα  1)
και να περιγράψετε τη λειτουργία της   (μονάδες  3).

Μονάδες  6

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΑΠΑΝΤΗΣΗ (περισσότερα…)