Επιλογή Σελίδας

Στο πρόγραμμα του προηγούμενου κεφαλαίου (πωλήσεις υπολογιστών) υποθέτουμε ότι η τιμή των υπολογιστών εξαρτάται από την ποσότητα παραγγελίας. Συγκεκριμένα ισχύουν οι παρακάτω τιμές αγοράς υπολογιστών.

Ο υπολογισμός με χρήση εμφωλευμένων εντολών ΑΝ είναι:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ
  ΑΝ Ποσότητα<=100 ΤΟΤΕ 
     Κόστος <-- Ποσότητα*520 
  ΑΛΛΙΩΣ
     ΑΝ Ποσότητα<=200 ΤΟΤΕ 
        Κόστος <-- Ποσότητα*470 
     ΑΛΛΙΩΣ 
        Κόστος <-- Ποσότητα*440 
     ΤΕΛΟΣ_ΑΝ 
  ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΑΝ

Το ίδιο πρόγραμμα με τη χρήση της εντολής ΑΝ…ΤΟΤΕ…ΑΛΛΙΩΣ_ΑΝ έχει ως εξής:

ΑΝ Ποσότητα <= 50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα<=200 ΤΟΤΕ 
Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ 

Ένα συχνό λάθος που παρατηρείται στα προγράμματα είναι ο έλεγχος περιττών συνθηκών. Οι επιπλέον έλεγχοι αυξάνουν την πολυπλοκότητα του προγράμματος. Στο προηγούμενο παράδειγμα για το οποίο θεωρούμε ότι η ποσότητα είναι θετικός αριθμός, ένα παράδειγμα περιττών ελέγχων είναι το ακόλουθο:

ΑΝ Ποσότητα<=50 ΤΟΤΕ 
   Κόστος <-- Ποσότητα*580 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 50 ΚΑΙ Ποσότητα <=100 ΤΟΤΕ 
Κόστος <-- Ποσότητα*520 
ΑΛΛΙΩΣ_ΑΝ Ποσότητα>100 ΚΑΙ Ποσότητα <=200 ΤΟΤΕ
      Κόστος <-- Ποσότητα*470 
ΑΛΛΙΩΣ 
      Κόστος <-- Ποσότητα*440 
ΤΕΛΟΣ_ΑΝ

Βλέπε επίσης: ΔΕ1, Κεφαλαίου 8

Share This