Επιλογή Σελίδας

Να γραφεί πρόγραμμα που να διαβάζει το βαθμό ενός μαθητή και να υπολογίζει την αντίστοιχη αξιολόγησή του με βάση το βαθμό του και σύμφωνα με τον παρακάτω πίνακα:
17,5 – 20 Άριστα
15,5 – 17,4 Πολύ καλά
13,5 – 15,4 Καλά
9,5 – 13,4 Μέτρια
0 – 9,4 Απορρίπτεται

Το πρόγραμμα να γραφεί με τους ακόλουθους τρόπους:
• Με εντολές ΑΝ … ΤΟΤΕ
• Με εντολές ΑΝ … ΤΟΤΕ … ΑΛΛΙΩΣ_ΑΝ
• Με εμφωλευμένα ΑΝ
• Με την εντολή ΕΠΙΛΕΞΕ

ΛΥΣΗ

!ΑΠΛΗ ΕΠΙΛΟΓΗ
ΠΡΟΓΡΑΜΜΑ ΧΑΡΑΚΤΗΡΙΣΜΟΣ_ΕΠΙΔΟΣΗΣ 
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟ ΜΑΘΗΤΗ: '
ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
ΑΝ ΒΑΘΜΟΣ >= 0 ΚΑΙ ΒΑΘΜΟΣ <= 9.4 ΤΟΤΕ 
      ΓΡΑΨΕ 'ΑΠΟΡΡΙΠΤΕΤΑΙ'
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘΜΟΣ >= 9.5 ΚΑΙ ΒΑΘΜΟΣ <= 13.4 ΤΟΤΕ
          ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘΜΟΣ >= 13.5 ΚΑΙ ΒΑΘΜΟΣ < 15.5 ΤΟΤΕ
         ΓΡΑΨΕ 'ΚΑΛΑ'
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘΜΟΣ >= 15.5 ΚΑΙ ΒΑΘΜΟΣ < 17.5 ΤΟΤΕ
         ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
ΤΕΛΟΣ_ΑΝ
ΑΝ ΒΑΘΜΟΣ >=17.5 ΚΑΙ ΒΑΘΜΟΣ <=20 ΤΟΤΕ
         ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ
ΠΡΟΓΡΑΜΜΑ ΧΑΡΑΚΤΗΡΙΣΜΟΣ_ΕΠΙΔΟΣΗΣ 
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟ ΜΑΘΗΤΗ: '
ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
ΑΝ ΒΑΘΜΟΣ >= 0 ΚΑΙ ΒΑΘΜΟΣ <= 20 ΤΟΤΕ 
   ΑΝ ΒΑΘΜΟΣ < 9.5 ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΠΟΡΡΙΠΤΕΤΑΙ'
   ΑΛΛΙΩΣ_ΑΝ ΒΑΘΜΟΣ < 13.5 ΤΟΤΕ
          ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
   ΑΛΛΙΩΣ_ΑΝ ΒΑΘΜΟΣ < 15.5 ΤΟΤΕ
         ΓΡΑΨΕ 'ΚΑΛΑ'
   ΑΛΛΙΩΣ_ΑΝ ΒΑΘΜΟΣ < 17.5 ΤΟΤΕ
         ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
   ΑΛΛΙΩΣ
         ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!ΕΜΦΩΛΕΥΜΕΝΕΣ ΑΝ
ΠΡΟΓΡΑΜΜΑ ΧΑΡΑΚΤΗΡΙΣΜΟΣ_ΕΠΙΔΟΣΗΣ 
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟ ΜΑΘΗΤΗ: '
ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
ΑΝ ΒΑΘΜΟΣ >= 0 ΤΟΤΕ 
   ΑΝ ΒΑΘΜΟΣ <= 20 ΤΟΤΕ
      ΑΝ ΒΑΘΜΟΣ <= 9.4 ΤΟΤΕ
         ΓΡΑΨΕ 'ΑΠΟΡΡΙΠΤΕΤΑΙ'
      ΑΛΛΙΩΣ
         ΑΝ ΒΑΘΜΟΣ <= 13.4 ΤΟΤΕ 
            ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
         ΑΛΛΙΩΣ
            ΑΝ ΒΑΘΜΟΣ <= 15.4 ΤΟΤΕ
               ΓΡΑΨΕ 'ΚΑΛΑ'
            ΑΛΛΙΩΣ        
               ΑΝ ΒΑΘΜΟΣ <= 17.4 ΤΟΤΕ
                  ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
               ΑΛΛΙΩΣ
                 ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
               ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΑΝ
         ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Share This