Επιλογή Σελίδας

Ένα ξενοδοχείο χρεώνει την ενοικίαση των δωματίων του ανάλογα με τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, σύμφωνα με τον παρακάτω πίνακα:

ΑΡΙΘΜΟΣ ΗΜΕΡΝ ΤΟΥΡΙΣΤΙΚΗ ΠΕΡΙΟΔΟΣ
ΧΑΜΗΛΗ ΥΨΗΛΗ
1-3 40€ ανά ημέρα 70€ ανά ημέρα
4-7 30€ ανά ημέρα 55€ ανά ημέρα
>7 25€ ανά ημέρα 50€ ανά ημέρα

Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

Γ 1.       Nα περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2

Γ2.       Για καθεμιά από τις 500 κρατήσεις του ξενοδοχείου κατά το προηγούμενο έτος:
α. Να διαβάζει τον αριθμό των ημερών ενοικίασης καθώς και την τουριστική περίοδο που έγινε η κράτηση, εξασφαλίζοντας ότι η επιτρεπτή τιμή για την τουριστική περίοδο είναι ΧΑΜΗΛΗ ή ΥΨΗΛΗ.   (μονάδες 3)
β. Να καλεί υποπρόγραμμα με είσοδο τον αριθμό των ημερών ενοικίασης και την τουριστική περίοδο, το οποίο να υπολογίζει, με βάση τον προηγούμενο πίνακα, τη χρέωση της κράτησης. O υπολογισμός της χρέωσης δεν γίνεται κλιμακωτά.  (μονάδες 2)
γ.     Να εμφανίζει τη χρέωση της κράτησης.  (μονάδα 1)
Μονάδες 6

Γ3.      Nα υπολογίζει και να εμφανίζει τη συνολική χρέωση των κρατήσεων του ξενοδοχείου για καθεμιά τουριστική περίοδο του προηγούμενου έτους.
Μονάδες 4

Γ4.       Nα κατασκευάσετε το υποπρόγραμμα του ερωτήματος Γ2.β.
Μονάδες 8

Τα Θέματα σε pdf, 2016, Ημερήσια, Επαναληπτικές, Παλαιό

ΛΥΣΗ

ΑΡΧΕΙΟ ΔΟΚΙΜΑΣΤΙΚΩΝ ΔΕΔΟΜΕΝΩΝ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2016_ΕΠΑΝ_ΗΜΕΡ_ΠΑΛΑΙΟ
!Γ1
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, ΜΕΡΕΣ
 ΠΡΑΓΜΑΤΙΚΕΣ: ΣΥΝ_ΧΑΜΗΛΗΣ, ΣΥΝ_ΥΨΗΛΗΣ, ΧΡΕΩΣΗ
 ΧΑΡΑΚΤΗΡΕΣ: ΠΕΡΙΟΔΟΣ
ΑΡΧΗ
!Γ2 
 ΣΥΝ_ΧΑΜΗΛΗΣ <-- 0
 ΣΥΝ_ΥΨΗΛΗΣ <-- 0
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
     ΔΙΑΒΑΣΕ ΜΕΡΕΣ
     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΠΕΡΙΟΔΟΣ 
     ΜΕΧΡΙΣ_ΟΤΟΥ ΠΕΡΙΟΔΟΣ='ΧΑΜΗΛΗ' ή ΠΕΡΙΟΔΟΣ='ΥΨΗΛΗ' 
     ΧΡΕΩΣΗ <-- Υπολογισμός_Χρέωσης(ΜΕΡΕΣ, ΠΕΡΙΟΔΟΣ)
     ΓΡΑΨΕ 'ΧΡΕΩΣΗ ΚΡΑΤΗΣΗΣ: ', ΧΡΕΩΣΗ

     !Γ3 
     ΑΝ ΠΕΡΙΟΔΟΣ = 'ΧΑΜΗΛΗ' ΤΟΤΕ
        ΣΥΝ_ΧΑΜΗΛΗΣ <-- ΣΥΝ_ΧΑΜΗΛΗΣ+ΧΡΕΩΣΗ
     ΑΛΛΙΩΣ
        ΣΥΝ_ΥΨΗΛΗΣ <-- ΣΥΝ_ΥΨΗΛΗΣ+ΧΡΕΩΣΗ 
     ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΡΑΨΕ 'ΣΥΝΟΛΟ ΧΡΕΩΣΗΣ ΚΡΑΤΗΣΕΩΝ'
 ΓΡΑΨΕ 'ΥΨΗΛΗΣ ΠΕΡΙΟΔΟΥ: ', ΣΥΝ_ΥΨΗΛΗΣ
 ΓΡΑΨΕ 'ΧΑΜΗΛΗΣ ΠΕΡΙΟΔΟΥ: ', ΣΥΝ_ΧΑΜΗΛΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

!Γ4
ΣΥΝΑΡΤΗΣΗ Υπολογισμός_Χρέωσης(μέρες, περίοδος):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: μέρες, χρεωση 
 ΧΑΡΑΚΤΗΡΕΣ: περίοδος 
ΑΡΧΗ
 ΑΝ περίοδος='ΥΨΗΛΗ' ΤΟΤΕ
    ΑΝ μέρες<=3 ΤΟΤΕ
       χρέωση <-- 70 * μέρες
    ΑΛΛΙΩΣ_ΑΝ μέρες<=7 ΤΟΤΕ 
       χρέωση <-- 55 * μέρες
    ΑΛΛΙΩΣ
       χρέωση <-- 50 * μέρες
    ΤΕΛΟΣ_ΑΝ 
 ΑΛΛΙΩΣ
    ΑΝ μέρες<=3 ΤΟΤΕ
       χρέωση <-- 40 * μέρες
    ΑΛΛΙΩΣ_ΑΝ μέρες<=7 ΤΟΤΕ
       χρέωση <-- 30 * μέρες
    ΑΛΛΙΩΣ
      χρέωση <-- 25 * μέρες
    ΤΕΛΟΣ_ΑΝ  
 ΤΕΛΟΣ_ΑΝ
 Υπολογισμός_Χρέωσης <-- χρέωση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This