Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Αν x > 0 ή y > 0 τότε
      Εμφάνισε “Ένας τουλάχιστον θετικός αριθμός” 
Αλλιώς_αν x < 0 και y < 0 τότε
      Εμφάνισε “Δύο αρνητικοί αριθμοί” 
Τέλος_αν

Να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο να παράγει το ίδιο αποτέλεσμα με το παραπάνω, χρησιμοποιώντας μόνο τις λογικές συνθήκες x > 0, x < 0, y > 0, y < 0 και χωρίς να χρησιμοποιήσετε λογικούς τελεστές.

Μονάδες 7

Τα Θέματα σε pdf, 2016, Ημερήσια, Μαϊου-Ιουνίου, Παλαιό

ΛΥΣΗ

Αν x > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός' 
Αλλιώς_αν y > 0 τότε
      Εμφάνισε 'Ένας τουλάχιστον θετικός αριθμός'
Αλλιώς
    Αν x < 0
       Αν y < 0
          Εμφάνισε 'Δύο αρνητικοί αριθμοί' 
       Τέλος_αν
    Τέλος_αν
Τέλος_αν
Share This