Επιλογή Σελίδας

Για τη μέτρηση της ποιότητας της ατμόσφαιρας στην Αθήνα, όπως και σε κάθε μεγάλη πόλη που έχει πρόβλημα μόλυνσης της ατμόσφαιρας, μετρούνται συνεχώς τα επίπεδα συγκεκριμένων βλαβερών συστατικών της, που είναι γνωστά ως ρύποι. Οι ρύποι αυτοί είναι το διοξείδιο του αζώτου (ΝO2), το μονοξείδιο του άνθρακα (CO), το διοξείδιο του θείου (SO2), το όζον (O3) και ο καπνός. Για τον περιορισμό της ρύπανσης σε περιπτώσεις που σημειώνεται σημαντική αύξηση των τιμών των ρύπων χρησιμοποιούνται τα όρια εκτάκτων μέτρων. Τα όρια αυτά που ισχύουν για την περιοχή της Αθήνας για δύο από τους πλέον συχνά εμφανιζόμενους ρύπους O3 και ΝO2 παρουσιάζονται στον παρακάτω πίνακα.

Να γραφεί πρόγραμμα το οποίο διαβάζει τις τιμές του ΝΟ2 και του Ο3 και να τυπώνει το αντίστοιχο μήνυμα σύμφωνα με τον παρακάτω πίνακα.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ρύποι 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:ΝO2, O3 
ΑΡΧΗ 
ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου' 
ΔΙΑΒΑΣΕ ΝO2 
ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος'
ΔΙΑΒΑΣΕ O3 
ΑΝ ΝO2>700 Ή O3 > 500 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ' 
ΑΛΛΙΩΣ_ΑΝ ΝO2 > 500 Ή O3 > 300 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
ΑΛΛΙΩΣ_ΑΝ ΝO2 > 400 Ή O3 > 250 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Ρύποι μέσα στα όρια' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This