Δίνεται το παρακάτω τμήμα αλγόριθμου, που υλοποιεί την πρώτη φάση της συγχώνευσης των ταξινομημένων πινάκων Α[100] και Β[200] σε πίνακα Γ[300]. Ο πίνακας Α είναι ταξινομημένος σε αύξουσα σειρά και ο πίνακας Β σε φθίνουσα. Το τμήμα αυτό επεξεργάζεται τους πίνακες Α και Β τοποθετώντας τα στοιχεία τους στον πίνακα Γ σε αύξουσα σειρά. Η διαδικασία σταματά, όταν εξαντληθούν τα στοιχεία ενός από τους πίνακες Α και Β. Το τμήμα αλγόριθμου έχει 8 κενά αριθμημένα από 1-8. Σε κάθε κενό αντιστοιχεί ένας τελεστής ή μία μεταβλητή. Για κάθε ένα από τα κενά να γράψετε στο τετράδιό σας τον αριθμό του και δίπλα τον τελεστή ή την μεταβλητή που αντιστοιχεί.

I<- 1
j<em><- </em>200
k<- 1
Όσο i … (1) 100 και j … (2) 1 επανάλαβε
    Αν Α[i] … (3) Β[j] τότε
       Γ[… ( 4)]<- Α[i]
       i<- i … (5) 1 
    Αλλιώς
       Γ[...(6)] <- Β[...(7)]
       J<- j … (8)1 
    Τέλος_αν
    k<- k +1
Τέλος_επανάληψης</code class="language-javascript">

 

Μονάδες 8
Να αντιγράψετε στο τετράδιό σας τον πίνακα που δίνεται παρακάτω και να συμπληρώσετε τις τιμές που θα έχουν οι μεταβλητές μετά από την εκτέλεση του τμήματος αλγόριθμου για καθεμιά από τις τιμές εισόδου που δίνονται στην πρώτη στήλη.

Χ Βρέθηκε Υπάρχει i
10
40
70
100

Μονάδες 12

Share This