Επιλογή Σελίδας

Παράδειγμα 6, Βιβλίου, Χαρακτηρισμός ατόμων

Να διαβάζονται δύο αριθμοί που αντιστοιχούν στο ύψος και βάρος ενός άνδρα. Να εκτυπώνεται ότι ο άνδρας είναι “ελαφρύς”, αν το βάρος του είναι κάτω από 80 κιλά, ή να εκτυπώνεται “βαρύς” στην αντίθετη περίπτωση. Επίσης να εκτυπώνεται “κοντός” αν το ύψος του είναι κάτω από 1.70, αλλιώς να εκτυπώνεται “ψηλός”.
Αλγόριθμος Παράδειγμα6
Διάβασε βάρος, ύψος
Αν βάρος < 80 τότε
     Αν ύψος < 1.70 τότε
         εκτύπωσε «ελαφρύς-κοντός»
     αλλιώς
         εκτύπωσε «ελαφρύς-ψηλός»
     Τέλος
αν
αλλιώς
     Αν ύψος < 1.70 τότε
         εκτύπωσε «βαρύς-κοντός»
     αλλιώς
        εκτύπωσε «βαρύς-ψηλός»
     Τέλοςαν
Τέλος
αν
Τέλος Παράδειγμα_6

par6kef2vivlio

ΔΤ6, Κεφάλαιο 2, Τετράδιο Εργασιών

Έστω ότι ένας Πανελλήνιος Διαγωνισμός στα Μαθηματικά δίνει δικαίωμα συμμετοχής στο 1% των μαθητών μίας τάξης με την προϋπόθεση ότι ο μέσος όρος της βαθμολογίας στα Μαθηματικά των μαθητών αυτής της τάξης είναι μεγαλύτερος από 18. Να γραφεί ένας αλγόριθμος που θα ελέγχει τη δυνατότητα συμμετοχής σε έναν τέτοιο διαγωνισμό και να παρακολουθήσετε τον αλγόριθμο για τα δεδομένα της τάξης σας.

Λύση:  (περισσότερα…)

ΔΣ3, Κεφάλαιο 2, Τετράδιο Εργασιών

Ένας καταναλωτής πηγαίνει στο πολυκατάστημα και έχει στην τσέπη του 5.000 ευρώ. Ξεκινά να αγοράζει διάφορα είδη και ταυτόχρονα κρατά το συνολικό ποσό στο οποίο έχει φθάσει κάθε στιγμή που αγοράζει κάποιο είδος. Οι τιμές των ειδών που αγοράζει είναι σε δραχμές και είναι δεδομένο ότι 1 ευρώ=340,75 δραχμές. Να γραφεί σε φυσική γλώσσα, με ακολουθία βημάτων και με διάγραμμα ροής, ένας αλγόριθμος για τον υπολογισμό του ποσού από τα ψώνια που έγιναν και να σταματά η αγορά ειδών έτσι ώστε να μην ξεπεραστεί το ποσό που έχει διαθέσιμο ο καταναλωτής.

Λύση:  (περισσότερα…)

ΔΣ4, Κεφάλαιο 2, Τετράδιο Εργασιών

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Ελεγχος_Ανάθεσης
 Διάβασε x
 Όσο x > 1 επανάλαβε
         Αν x mod 2 = 0 τότε      ! Αν χ είναι άρτιος τότε
            x ← x/2               ! Αλλαγή σε DIV για να εκτελεστεί στη ΓΛΩΣΣΑ
         αλλιώς 
            x ←3*x+1
        Τέλος_αν
        Γράψε x                   ! Πίνακας τιμών μεταβλητής
  Τέλος_επανάληψης                       
 Αποτελέσματα // x //
 Τέλος Ελεγχος_Ανάθεσης
 Να γράψεις τα αποτελέσματα αυτού του αλγορίθμου για x=13, x=9 και x=22. Τι παρατηρείς;

Λύση:  (περισσότερα…)

Ερώτημα 3, Θέμα Α, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Αν Α≥5 τότε
     Αν Β<7 τότε
Α←Α+1
     αλλιώς
Α←Α-1
     Τέλος_αν
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

Επίσης δίνονται παρακάτω δύο τμήματα αλγορίθμων από τα οποία λείπουν οι συνθήκες:

α.  Αν ………………….  τότε
Α←Α+1
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

β.   Αν………………… τότε
Α<-Α-1
      αλλιώς
Α<-Α+1
      Τέλος_αν
      Εμφάνισε Α

Να γράψετε στο τετράδιό σας τις συνθήκες που λείπουν, ώστε κάθε ένα από τα τμήματα α, β να εμφανίζει το ίδιο αποτέλεσμα με το αρχικό.

Μονάδες 10

 

Θέμα Β, 2009, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές του:
1         Διάβασε Χ
2         Όσο X>1 επανάλαβε
3                 Aν Χ mod 2=0  τότε
4                        Χ<-Χ div 2
5                 αλλιώς
6                         Χ<-3*Χ+1
7                 Τέλος_αν
8       Τέλος_επανάληψης
Επίσης   δίνεται   το   παρακάτω   υπόδειγμα   πίνακα   (πίνακας τιμών), με συμπληρωμένη την αρχική τιμή της μεταβλητής Χ.

Αριθμός Εντολής Χ Χ>1 Χ mod 2=0
1 5

Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχική τιμή Χ=5 (που ήδη φαίνεται στον πίνακα).

Α.   Για   κάθε   εντολή   που   εκτελείται   να   γράψετε   σε   νέα γραμμή του πίνακα τα εξής:

  1. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
  2. Αν η γραμμή περιέχει εντολή εκχώρησης, τη νέα τιμή της μεταβλητής στην αντίστοιχη στήλη. Αν η γραμμή περιέχει έλεγχο συνθήκης, την τιμή της συνθήκης (Αληθής, Ψευδής) στην αντίστοιχη στήλη.

Μονάδες 16

Β.   Να κάνετε τη διαγραμματική αναπαράσταση του ανωτέρω τμήματος αλγορίθμου (διάγραμμα ροής).

Μονάδες 4

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Ερώτημα 4, Θέμα Α, 2007, Επαναληπτικές, Ημερήσια

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση
Δεδομένα //Π,Ν,Χ//
flag <- ψευδής
Ι <- 1
Όσο   Ι ≤ Ν  και   flag=ψευδής  επανάλαβε
          Αν Π[Ι]=Χ  τότε
flag <- αληθής
         Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //flag//
Τέλος Αναζήτηση

  1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών; (Μονάδες 2)

Να αιτιολογήσετε την απάντησή σας. (Μονάδες 3)

Μονάδες 5

  1. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Θέμα Β, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:

ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: α, β, χ

ΑΡΧΗ

α <-1

β <- 2

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ α<= 4 ΤΟΤΕ

ΚΑΛΕΣΕ Διαδ1(α, β,χ)

ΑΛΛΙΩΣ

χ <- Συν1(α, β)

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ α, β, χ

ΜΕΧΡΙΣ_ΟΤΟΥ χ>11

ΓΡΑΨΕ χ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Διαδ1 (λ, κ, μ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: κ, λ, μ

ΑΡΧΗ

κ<-κ+1

λ<-λ+3

μ<-κ+λ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ε, ζ

ΑΡΧΗ

ζ<-ζ+2

ε<-ε*2

Συν1<-ε+ζ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.

Μονάδες 20

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα B, 2006, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής:

2016-10-04-16_43_35-aepp_2006_imerisia

α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα.

Μονάδες 7

β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Υ, όπως θα εμφανισθεί σε κάθε περίπτωση.

  1. Χ = 9
  2. Χ = 10
  3. Χ = 40

Μονάδες 3

Τα θέματα σε pdf, 2006, Μαΐου-Ιουνίου, Ημερήσια

 

Ερώτημα 2, Θέμα B, 2006, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος σε ψευδογλώσσα:

Αλγόριθμος Μετατροπή

Χ <- 0

Για Κ από 1 μέχρι 10

      Διάβασε Λ

      Αν Λ > 0 τότε

            Χ <- Χ + Λ

      Αλλιώς

Χ <- Χ – Λ

     Τέλος_Αν

Τέλος_Επανάληψης

Εμφάνισε Χ

Τέλος Μετατροπή

Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Τα θέματα σε pdf, 2006, Μαΐου-Ιουνίου, Ημερήσια