Επιλογή Σελίδας

Τι αλλαγές πρέπει να γίνουν στο πρόγραμμα του παραδείγματος 1 ώστε να τυπώνει και ποιος από τους δύο ρύπους υπερέβη τα όρια λήψης μέτρων.

ΛΥΣΗ

Πρέπει να αλλάξει η εντολή ΑΝ που χρησιµοποιείται και να χρησιµοποιηθούν δύο διαφορετικές εντολές ΑΝ.

ΠΡΟΓΡΑΜΜΑ Ρύποι 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:ΝO2, O3 
ΑΡΧΗ 
ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου' 
ΔΙΑΒΑΣΕ ΝO2 
ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος' 
ΔΙΑΒΑΣΕ O3
ΑΝ ΝO2>700 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ '  
   ΓΡΑΨΕ 'Άζωτο πάνω από τα όρια' 
ΑΛΛΙΩΣ_ΑΝ ΝO2>500 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
   ΓΡΑΨΕ 'Άζωτο πάνω από τα όρια' 
ΑΛΛΙΩΣ_ΑΝ ΝO2>400 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
   ΓΡΑΨΕ 'Άζωτο στα όρια ασφαλείας' 
ΤΕΛΟΣ_ΑΝ 
ΑΝ O3 >500 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ' 
   ΓΡΑΨΕ ' Όζον πάνω από τα όρια' 
ΑΛΛΙΩΣ_ΑΝ O3 >300 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
   ΓΡΑΨΕ ' Όζον πάνω από τα όρια' 
ΑΛΛΙΩΣ_ΑΝ O3 >250 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
   ΓΡΑΨΕ ' Όζον στα όρια ασφαλείας'
ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Ρύποι μέσα στα όρια'
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This