ΘΕΜΑ Β1
Το παρακάτω τμήμα αλγορίθμου αποτελεί μια παραλλαγή της ταξινόμησης φυσαλίδας, η οποία όμως σταματάει τις επαναλήψεις μόλις διαπιστώσει ότι ο πίνακας έχει ταξινομηθεί ως εξής:
Μετά την ολοκλήρωση του εσωτερικού βρόχου, ελέγχει εάν έγιναν αντιμεταθέσεις στοιχείων και αν δεν έγιναν τότε ο αλγόριθμος τερματίζεται. Το τμήμα αλγορίθμου που δίνεται περιέχει κενά που έχουν αριθμηθεί.

i  ...(1)... 
Αρχή_επανάληψης 
stop  ΑΛΗΘΗΣ 
Για j από Ν μέχρι i με_βήμα -1 
    Αν table[j-1] > table[j] τότε 
       Αντιμετάθεσε table[j-1],table[j]  
       stop  ...(2)... 
    Τέλος_αν 
Τέλος_επανάληψης 
...(3)... 
Μέχρις_ότου i ...(4)... N ή stop= ...(5)...

Να γράψετε στο τετράδιό σας τους αριθμούς των κενών και δίπλα από κάθε αριθμό ό,τι πρέπει να συμπληρωθεί ώστε να επιτελείται η λειτουργία που περιγράφεται.
Μονάδες 10

Share This