Επιλογή Σελίδας

Σε ένα κέντρο νεοσύλλεκτων υπάρχει η πρόθεση να δημιουργηθούν δύο ειδικές διμοιρίες. Η διμοιρία Α θα αποτελείται από νεοσύλλεκτους πτυχιούχους τριτοβάθμιας εκπαίδευσης, ηλικίας από 24 έως και 28 χρόνων. Η διμοιρία Β θα αποτελείται από νεοσύλλεκτους απόφοιτους δευτεροβάθμιας εκπαίδευσης, ηλικίας από 18 έως και 24 χρόνων. Οι υπόλοιποι νεοσύλλεκτοι δεν κατατάσσονται σε καμία από αυτές τις διμοιρίες. Να αναπτύξετε αλγόριθμο ο οποίος:

α. διαβάζει το ονοματεπώνυμο, την ηλικία και έναν αριθμό που καθορίζει το επίπεδο σπουδών του νεοσύλλεκτου και παίρνει τιμές από 1 έως 3 (1: τριτοβάθμια εκπαίδευση, 2: δευτεροβάθμια εκπαίδευση, 3: κάθε άλλη περίπτωση)
Μονάδες 5

β. εκτυπώνει:
i) το ονοματεπώνυμο του νεοσύλλεκτου ii) το όνομα της διμοιρίας (Α ή Β), εφόσον ο νεοσύλλεκτος κατατάσσεται σε μία από αυτές.
Μονάδες 15

ΛΥΣΗ:

Αλγόριθμος Νεοσύλλεκτοι

Διάβασε Όνομα, Ηλικία, Σπουδές

Εμφάνισε Όνομα

Αν (Ηλικία>=24) και (Ηλικία<=28) και (Σπουδές=1) τότε

Εμφάνισε “Α“

Τέλος_αν 

Αν (Ηλικία>=18) και (Ηλικία<=24) και (Σπουδές=2) τότε 

Εμφάνισε “Β“

Τέλος_αν 

Τέλος Νεοσύλλεκτοι

Τα θέματα σε pdf, 2002, Επαναληπτικές, Ημερήσια

Share This