Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Αν Α≥5 τότε
     Αν Β<7 τότε
Α←Α+1
     αλλιώς
Α←Α-1
     Τέλος_αν
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

Επίσης δίνονται παρακάτω δύο τμήματα αλγορίθμων από τα οποία λείπουν οι συνθήκες:

α.  Αν ………………….  τότε
Α←Α+1
αλλιώς
Α←Α-1
Τέλος_αν
Εμφάνισε Α

β.   Αν………………… τότε
Α<-Α-1
      αλλιώς
Α<-Α+1
      Τέλος_αν
      Εμφάνισε Α

Να γράψετε στο τετράδιό σας τις συνθήκες που λείπουν, ώστε κάθε ένα από τα τμήματα α, β να εμφανίζει το ίδιο αποτέλεσμα με το αρχικό.

Μονάδες 10

 

Share This