Επιλογή Σελίδας

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση
Δεδομένα //Π,Ν,Χ//
flag <- ψευδής
Ι <- 1
Όσο   Ι ≤ Ν  και   flag=ψευδής  επανάλαβε
          Αν Π[Ι]=Χ  τότε
flag <- αληθής
         Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //flag//
Τέλος Αναζήτηση

  1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών; (Μονάδες 2)

Να αιτιολογήσετε την απάντησή σας. (Μονάδες 3)

Μονάδες 5

  1. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

Μονάδες 3

Τα θέματα σε pdf, 2007, Επαναληπτικές, Ημερήσια

Share This