Επιλογή Σελίδας

Δίνεται ο παρακάτω ημιτελής αλγόριθμος αναζήτησης ενός αριθμού key σε έναν αριθμητικό πίνακα table N στοιχείων, στον οποίο ο key μπορεί να εμφανίζεται περισσότερες από μία φορές.
Αλγόριθμος Αναζήτηση
Δεδομένα // table, N, key //
Βρέθηκε <- Ψευδής
ΔενΒρέθηκε <- ……………………….
i <- 1
Όσο ΔενΒρέθηκε = Αληθής και i<=N επανάλαβε
Αν…………………….. τότε
Εμφάνισε “Βρέθηκε στη θέση”, i
Βρέθηκε <-   ……………………..
Αλλιώς_αν ………………………  τότε
ΔενΒρέθηκε <- ……………………….
Τέλος_αν
i <- i + 1
Τέλος_επανάληψης
Αποτελέσματα // Βρέθηκε //
Τέλος Αναζήτηση
Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο με τα κενά συμπληρωμένα, έτσι ώστε να εμφανίζονται όλες οι θέσεις στις οποίες βρίσκεται ο αριθμός key στον πίνακα table. Ο αλγόριθμος να σταματάει αμέσως μόλις διαπιστωθεί ότι ο αριθμός key δεν υπάρχει στον πίνακα. Εκμεταλλευτείτε το γεγονός ότι τα στοιχεία του πίνακα είναι ταξινομημένα σε αύξουσα σειρά.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Share This