Επιλογή Σελίδας

8, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ, 23ος Π.Δ.Π (2011) B’ Φάση (Θέμα Γυμνασίου)

Η Ελλάδα εκτός από ξακουστός καλοκαιρινός προορισμός, αποτελεί και τόπο χειμερινού τουρισμού. Χιονισμένα βουνά, άγρια ποτάμια και μια συνεχής αλλαγή περιβάλλοντος μπορούν να ικανοποιήσουν κάθε σχετική προσδοκία. Ξεχωριστή φυσικά θέση στο χειμερινό τοπίο, έχουν τα 16 χιονοδρομικά κέντρα της χώρας μας. Μερικά από αυτά, όπως το χιονοδρομικό κέντρο στα «3 – 5 Πηγάδια” (Βέρμιο Ημαθίας) προσφέρουν ψυχαγωγία όλο το χρόνο. Το κέντρο, διαθέτει τεχνική χιονόπτωση και την πίστα της μεγάλης κατάβασης από τα 2005 m στα 1430 m. Σε αυτήν τη μεγάλη πίστα μέσα στα έλατα, γίνεται ο τελικός ταχύτητας με ατομική χρονομέτρηση. Ο κάθε χιονοδρόμος κατεβαίνει τη διαδρομή και με βάση το χρόνο του, οι φωτεινοί πίνακες δίνουντη θέση του στη γενική κατάταξη. Ο πρώτος για παράδειγμα θα έχει αναγκαστικά θέση 1. Ο δεύτερος 1 ή 2 και ο Νιοστός οποιαδήποτε θέση από 1 έως Ν.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο αφού καταχωρίσει σε Πίνακα 20 θέσεων τη θέση που παίρνει ο κάθε χιονοδρόμος στη γενική κατάταξη   μέχρι  εκείνη   τη   στιγμή,   θα  εμφανίζει  την  τελική   θέση κάθε χιονοδρόμου μετά το τέλος του αγώνα. ΕΠΥ, 23ος Π.Δ.Π. (2011) Β’ Φάση (Θέμα Γυμνασίου)

ΛΥΣΗ

(περισσότερα…)

7, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ, 23ος Π.Δ.Π (2011) A’ Φάση

Οι τιμές κάποιων αγαθών ή τίτλων (π.χ. πετρελαίου, χρυσού, μετοχών αλλά και βασικών τροφίμων όπως των αλεύρων, της ζάχαρης κ.λπ.) διαμορφώνονται καθημερινά βάσει της προσφοράς και της ζήτησης, αλλά και με βάση την εκτίμηση για τη μελλοντική τους πορεία. Αποτέλεσμα αυτών των συναλλαγών είναι οι τιμές αυτές να αλλάζουν από μέρα σε μέρα. Κάποιοι εκμεταλλεύονται αυτήν την αυξομείωση των τιμών, αγοράζοντας μία ποσότητα (ή δικαίωμα σε ποσότητα) φθηνά, και έπειτα πουλούν την ίδια ποσότητα ή δικαίωμα ακριβότερα. Το κέρδος εκφράζεται από το λόγο της τιμής πώλησης προς την τιμή αγοράς. Έστω ότι γνωρίζουμε την τιμή που έχει κάποιο αγαθό κάθε μέρα για ένα μεγάλο χρονικό διάστημα. Θέλουμε να υπολογίσουμε το μέγιστο κέρδος που θα μπορούσε κάποιος να αποκομίσει με μία αγορά και στη συνέχεια μία πώληση.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο καταχωρεί σε έναν Πίνακα 30 θέσεων, την τιμή ενός αγαθού για κάθε μία από αυτές τις ημέρες, και θα εμφανίζει το μέγιστο δυνατό κέρδος από μία αγορά και στη συνέχεια μία πώληση.

Παράδειγμα 1

5 4 3 10 11 9 8 8 8 8 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9

Επεξήγηση παραδείγματος 1: Το μέγιστο κέρδος προκύπτει αν κάποιος αγοράσει την τρίτη μέρα (Χ3 = 3) και πουλήσει την πέμπτη (Χ5 = 11). Το κέρδος είναι Χ5 / Χ3 = 11/3 = 3.6666666… ΕΠΥ, 23ος Π.Δ.Π. (2011) Α’ Φάση

ΛΥΣΗ

(περισσότερα…)

Ερώτημα 2, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Να ξαναγράψετε στο τετράδιό σας το παρακάτω τμήμα προγράμματος, χρησιμοποιώντας αποκλειστικά μη εμφωλευμένες απλές δομές επιλογής Αν … Τότε … Τέλος_αν.

Αν Χ<> Α_Μ(Χ) Τότε
Γράψε “Λάθος”
Αλλιώς_αν Χ<=0 Τότε
Γράψε “Μη Θετικός”
Αλλιώς
Γράψε “Θετικός”
Τέλος_αν
Μονάδες 6

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Ερώτημα 3, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Να ξαναγράψετε στο τετράδιό σας καθένα από τα παρακάτω τμήματα αλγορίθμου, χρησιμοποιώντας μόνο μία δομή επανάληψης Για … Από …. Μέχρι και χωρίς τη χρήση δομής επιλογής.

(α)
i <- 1
j <- 1
Αρχή_επανάληψης
Εμφάνισε Α[i,j]
i <- i + 1
j <- j + 1
Μέχρις_ότου j > 100
(μονάδες 4)
(β)
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i = 50 τότε
Εμφάνισε Α[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης
(μονάδες 4)

Μονάδες 8

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Ερώτημα 4, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου:
Για Χ από Α μέχρι Μ με_βήμα Β
Εμφάνισε Χ
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας για καθεμία από τις παρακάτω περιπτώσεις τις τιμές των Α, Μ, Β, έτσι ώστε το αντίστοιχο τμήμα αλγορίθμου να εμφανίζει όλους:
1. τους ακεραίους από 1 μέχρι και 100
2. τους ακεραίους από 10 μέχρι και 200 σε φθίνουσα σειρά
3. τους ακεραίους από -1 μέχρι και -200 σε αύξουσα σειρά
4. τους άρτιους ακεραίους από 100 μέχρι και 200
5. τους θετικούς ακεραίους που είναι μικρότεροι του 8128 και πολλαπλάσια του 13.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Ερώτημα 5, Θέμα Α, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο παρακάτω ημιτελής αλγόριθμος αναζήτησης ενός αριθμού key σε έναν αριθμητικό πίνακα table N στοιχείων, στον οποίο ο key μπορεί να εμφανίζεται περισσότερες από μία φορές.
Αλγόριθμος Αναζήτηση
Δεδομένα // table, N, key //
Βρέθηκε <- Ψευδής
ΔενΒρέθηκε <- ……………………….
i <- 1
Όσο ΔενΒρέθηκε = Αληθής και i<=N επανάλαβε
Αν…………………….. τότε
Εμφάνισε “Βρέθηκε στη θέση”, i
Βρέθηκε <-   ……………………..
Αλλιώς_αν ………………………  τότε
ΔενΒρέθηκε <- ……………………….
Τέλος_αν
i <- i + 1
Τέλος_επανάληψης
Αποτελέσματα // Βρέθηκε //
Τέλος Αναζήτηση
Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο με τα κενά συμπληρωμένα, έτσι ώστε να εμφανίζονται όλες οι θέσεις στις οποίες βρίσκεται ο αριθμός key στον πίνακα table. Ο αλγόριθμος να σταματάει αμέσως μόλις διαπιστωθεί ότι ο αριθμός key δεν υπάρχει στον πίνακα. Εκμεταλλευτείτε το γεγονός ότι τα στοιχεία του πίνακα είναι ταξινομημένα σε αύξουσα σειρά.
Μονάδες 10

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Ερώτημα 1, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται τo παρακάτω τμήμα αλγορίθμου, το οποίο διαβάζει έναν θετικό αριθμό από τον χρήστη. Αν δοθεί μη θετικός αριθμός ζητάει από τον χρήστη άλλον αριθμό.
Αρχή_επανάληψης
Διάβασε α
Μέχρις_ότου α>0
Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο τροποποιημένο, έτσι ώστε:
α. Να υπολογίζει και να εμφανίζει πόσες φορές δόθηκε μη θετικός αριθμός. Αν δοθεί την πρώτη φορά θετικός αριθμός να εμφανίζει το μήνυμα “Σωστά”.
(μονάδες 4)
β. Να υπολογίζει και να εμφανίζει τον μέσο όρο των μη θετικών αριθμών που δόθηκαν. Αν δεν δοθούν μη θετικοί αριθμοί να εμφανίζεται κατάλληλο μήνυμα.
(μονάδες 2)
γ. Να υπολογίζει και να εμφανίζει τον μεγαλύτερο κατά απόλυτη τιμή μη θετικό αριθμό που δόθηκε. Αν δεν δοθούν μη θετικοί αριθμοί να εμφανίζεται κατάλληλο μήνυμα.
(μονάδες 5)
Μονάδες 11

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Ερώτημα 2, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο πίνακας Α τεσσάρων στοιχείων με τιμές:
Α[1]=3, Α[2]=5, Α[3]=8, Α[4]=13 και το παρακάτω τμήμα αλγορίθμου:
i <- 1 j <- 4
Όσο i<=3 επανάλαβε
πρόχειρο <- Α[j]
A[j] <- Α[i]
Α[i] <- πρόχειρο
Γράψε   Α[1], Α[2], Α[3]
i <- i + 1
j <- j – 1
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανισθούν κατά την εκτέλεσή του.
Μονάδες 9

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Θέμα Γ, 2011, Επαναληπτικές, Ημερήσια

Ένα πρατήριο υγρών καυσίμων διαθέτει έναν τύπο καυσίμου που αποθηκεύεται σε δεξαμενή χωρητικότητας 10.000 λίτρων. Να αναπτύξετε αλγόριθμο ο οποίος:
Γ1. να διαβάζει την ποσότητα (σε λίτρα) του καυσίμου που υπάρχει αρχικά στη δεξαμενή μέχρι να δοθεί έγκυρη τιμή.
Μονάδες 2
Για κάθε όχημα που προσέρχεται στο πρατήριο:
Γ2. να διαβάζει τον τύπο του οχήματος (“Β” για βυτιοφόρο όχημα που προμηθεύει το πρατήριο με καύσιμο και “E” για επιβατηγό όχημα που προμηθεύεται καύσιμο από το πρατήριο).
Μονάδες 2
Γ3. Αν το όχημα είναι βυτιοφόρο τότε να γεμίζει τη δεξαμενή μέχρι την πλήρωσή της. (μονάδες 3)
Αν το όχημα είναι επιβατηγό τότε να διαβάζει την ποσότητα καυσίμου την οποία θέλει να προμηθευτεί (μονάδες 2)
και, αν υπάρχει επάρκεια καυσίμου στη δεξαμενή, τότε το επιβατηγό όχημα να εφοδιάζεται με τη ζητούμενη ποσότητα καυσίμου, διαφορετικά το όχημα να μην εξυπηρετείται (μονάδες 3).
Μονάδες 8
Γ4. Η επαναληπτική διαδικασία να τερματίζεται, όταν αδειάσει η δεξαμενή του πρατηρίου ή όταν δεν εξυπηρετηθούν τρία διαδοχικά επιβατηγά οχήματα.
Μονάδες 4
Γ5.   Στο τέλος ο αλγόριθμος να εμφανίζει:
α. τη μέση ποσότητα καυσίμου ανά επιβατηγό όχημα που εξυπηρετήθηκε
β. τη συνολική ποσότητα καυσίμου με την οποία τα βυτιοφόρα ανεφοδίασαν τη δεξαμενή.
Μονάδες 4

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

(περισσότερα…)

Θέμα Δ, 2011, Επαναληπτικές, Ημερήσια

Ένας όμιλος αποτελείται από 20 εταιρίες. Να γράψετε πρόγραμμα το οποίο:
Δ1. να περιλαμβάνει τμήμα δηλώσεων.
Μονάδες 2
Δ2. να διαβάζει τα ονόματα των εταιριών του ομίλου και τα κέρδη τους για κάθε ένα από τα έτη 2001 έως και 2005. (Θεωρήστε ότι τα κέρδη είναι θετικοί αριθμοί.)
Μονάδες 2
Δ3. για κάθε εταιρία του ομίλου να καλεί συνάρτηση για τον υπολογισμό του συνολικού κέρδους της εταιρίας στην πενταετία. Στη συνέχεια να υπολογίζει και να εμφανίζει το μέσο ετήσιο κέρδος του ομίλου.
Μονάδες 5
Δ4. για κάθε εταιρία να βρίσκει την τριετία με το μεγαλύτερο συνολικό κέρδος και να εμφανίζει το όνομα της εταιρίας και το πρώτο έτος της συγκεκριμένης τριετίας. (Θεωρήστε ότι η τριετία αυτή είναι μοναδική.)
Μονάδες 5
Δ5.   Να κατασκευάσετε τη συνάρτηση που θα χρησιμοποιήσετε στο ερώτημα Δ3.
Μονάδες 6

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

ΛΥΣΗ 

(περισσότερα…)

Θέμα Α, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη.

  1. Ένα δομημένο πρόβλημα είναι επιλύσιμο.
  2. Η λογική έκφραση Χ ΄Η (ΟΧΙ Χ) είναι πάντα αληθής για κάθε τιμή της λογικής μεταβλητής Χ.
  3. Ο αλγόριθμος της σειριακής αναζήτησης χρησιμοποιείται αποκλειστικά σε ταξινομημένους πίνακες.
  4. Όταν το πλήθος των επαναλήψεων είναι γνωστό, δεν μπορεί να χρησιμοποιηθεί η εντολή επανάληψης Όσο … Επανάλαβε.
  5. Ο πίνακας είναι μία δομή που μπορεί να περιέχει στοιχεία διαφορετικού τύπου.

Μονάδες 10