Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές του:
1         Διάβασε Χ
2         Όσο X>1 επανάλαβε
3                 Aν Χ mod 2=0  τότε
4                        Χ<-Χ div 2
5                 αλλιώς
6                         Χ<-3*Χ+1
7                 Τέλος_αν
8       Τέλος_επανάληψης
Επίσης   δίνεται   το   παρακάτω   υπόδειγμα   πίνακα   (πίνακας τιμών), με συμπληρωμένη την αρχική τιμή της μεταβλητής Χ.

Αριθμός Εντολής Χ Χ>1 Χ mod 2=0
1 5

Να μεταφέρετε στο τετράδιό σας τον πίνακα και να τον συμπληρώσετε, εκτελώντας τον αλγόριθμο με αρχική τιμή Χ=5 (που ήδη φαίνεται στον πίνακα).

Α.   Για   κάθε   εντολή   που   εκτελείται   να   γράψετε   σε   νέα γραμμή του πίνακα τα εξής:

  1. Τον αριθμό της εντολής που εκτελείται (στην πρώτη στήλη).
  2. Αν η γραμμή περιέχει εντολή εκχώρησης, τη νέα τιμή της μεταβλητής στην αντίστοιχη στήλη. Αν η γραμμή περιέχει έλεγχο συνθήκης, την τιμή της συνθήκης (Αληθής, Ψευδής) στην αντίστοιχη στήλη.

Μονάδες 16

Β.   Να κάνετε τη διαγραμματική αναπαράσταση του ανωτέρω τμήματος αλγορίθμου (διάγραμμα ροής).

Μονάδες 4

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

Share This