Επιλογή Σελίδας

Δίνεται το παρακάτω πρόγραμμα και υποπρογράμματα:

ΠΡΟΓΡΑΜΜΑ Κλήση_Υποπρογραμμάτων

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: α, β, χ

ΑΡΧΗ

α <-1

β <- 2

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ α<= 4 ΤΟΤΕ

ΚΑΛΕΣΕ Διαδ1(α, β,χ)

ΑΛΛΙΩΣ

χ <- Συν1(α, β)

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ α, β, χ

ΜΕΧΡΙΣ_ΟΤΟΥ χ>11

ΓΡΑΨΕ χ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Διαδ1 (λ, κ, μ)

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: κ, λ, μ

ΑΡΧΗ

κ<-κ+1

λ<-λ+3

μ<-κ+λ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Συν1(ε, ζ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ε, ζ

ΑΡΧΗ

ζ<-ζ+2

ε<-ε*2

Συν1<-ε+ζ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος.

Μονάδες 20

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Share This