Επιλογή Σελίδας

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Ελεγχος_Ανάθεσης
 Διάβασε x
 Όσο x > 1 επανάλαβε
         Αν x mod 2 = 0 τότε      ! Αν χ είναι άρτιος τότε
            x ← x/2               ! Αλλαγή σε DIV για να εκτελεστεί στη ΓΛΩΣΣΑ
         αλλιώς 
            x ←3*x+1
        Τέλος_αν
        Γράψε x                   ! Πίνακας τιμών μεταβλητής
  Τέλος_επανάληψης                       
 Αποτελέσματα // x //
 Τέλος Ελεγχος_Ανάθεσης
 Να γράψεις τα αποτελέσματα αυτού του αλγορίθμου για x=13, x=9 και x=22. Τι παρατηρείς;

Λύση: 

x=13 Το x παίρνει διαδοχικά τις τιµές 40, 20, 10, 5, 16, 8, 4, 2, 1
x=9 Το x παίρνει διαδοχικά τις τιµές 28, 14, 7, 22, 11, 34, 17, 52, 26, 13, 40, 20,
10, 5, 16, 8, 4, 2, 1
x=22 Το x παίρνει διαδοχικά τις τιµές 11, 34, 17, 52, 26, 13, 40, 20, 10, 5, 16, 8,4, 2, 1
Παρατηρούµε ότι καταλήγουµε στην ίδια ακολουθία ανάθεσης αριθµών από
κάποιο σημείο μέχρι την κατάληξη στο x=1.

Share This