Επιλογή Σελίδας

Δίνεται το παρακάτω τμήμα αλγορίθμου ΤΑ_1:

Αν x>10 τότε
   Αν x<30 τότε 
      Κ <-- 3*x
   Αλλιώς
      Κ <-- 5*x
   Τέλος_αν
Κ<-- Κ/2
Αλλιώς
   Κ <-- x
   Αν x<5 τότε 
      Κ <-- 2*Κ
   Τέλος_αν 
 Τέλος_αν

Β1. Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.
Μονάδες 8

Β2. Χρησιμοποιώντας μόνο μία εντολή πολλαπλής επιλογής και μόνο απλές συνθήκες, να γράψετε στο τετράδιό σας τμήμα αλγορίθμου το οποίο θα παράγει το ίδιο αποτέλεσμα με το ΤΑ_1.
Μονάδες 12

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

Β2.

   Αν x < 5 τότε
      Κ <-- χ
      Κ <-- 2 * Κ
   Αλλιώς_αν x <= 10 τότε 
      Κ <-- x
   Αλλιώς_αν x < 30 τότε 
      Κ <-- 3 * x
      Κ<-- Κ/2
   Αλλιώς
      Κ <-- 5 * x
      Κ <-- Κ / 2
   Τέλος_αν 

 

Share This