Επιλογή Σελίδας

Στο παράδειγμα 1 του προηγούμενου κεφαλαίου με την μπάλα που εκτοξεύεται στον αέρα η γωνία βολής μπορεί να μεταβάλλεται από 20 έως 80 μοίρες σε βήματα των 10 μοιρών. Επίσης η αρχική ταχύτητα μπορεί να μεταβάλλεται από 10 μ/sec έως 40 μ/sec σε βήματα των 10 μ/sec. Να γραφεί πρόγραμμα που να υπολογίζει την οριζόντια απόσταση (το βεληνεκές) για κάθε συνδυασμό γωνίας και αρχικής ταχύτητας.

ΠΡΟΓΡΑΜΜΑ Τροχιά_μπάλας2 
ΣΤΑΘΕΡΕΣ 
G = 9.81 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ:V0,VX0,VY0,Θ, Βεληνεκές 
ΑΡΧΗ 
ΓΙΑ Θ ΑΠΟ 20 ΜΕΧΡΙ 80 ΜΕ ΒΗΜΑ 10 
    ΓΡΑΨΕ 'Γωνία:',Θ 
    ΓΙΑ V0 ΑΠΟ 10 ΜΕΧΡΙ 40 ΜΕ ΒΗΜΑ 10
        VX0 <-- V0*ΣΥΝ(Θ) 
        VY0 <-- V0*ΗΜ(Θ) 
        Βεληνεκές <-- 2*VX0*VY0/G
        ΓΡΑΨΕ 'Ταχύτητα:',V0,'Βεληνεκές:',Βεληνεκές 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This