Επιλογή Σελίδας

Στο προηγούμενο παράδειγμα ας υποθέσουμε ότι οι μετρήσεις είναι υποχρεωτικά θετικοί αριθμοί και ότι μετά την εισαγωγή κάθε αριθμού υπάρχει η ερώτηση αν θα εισαγάγουμε άλλο. Η διαδικασία θα τελειώσει, όταν η απάντηση θα είναι Όχι (ο ή Ο).

ΠΡΟΓΡΑΜΜΑ Άθροισμα2 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ:Επιλογή 
ΑΡΧΗ 
Πλήθος <-- 0 
Άθροισμα <-- 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
       ! Έλεγχος δεδομένων 
       ΓΡΑΨΕ 'Δώσε Αριθμό' 
       ΔΙΑΒΑΣΕ Χ 
       ΑΝ Χ <= 0 ΤΟΤΕ 
          ΓΡΑΨΕ 'Λάθος Αριθμός, Παρακαλώ δώστε ξανά...' 
       ΤΕΛΟΣ_ΑΝ 
       ! Αν το X δεν είναι θετικό εισάγουμε νέο αριθμό 
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Νέα μέτρηση ;' 
    ΔΙΑΒΑΣΕ Επιλογή ! Αν η επιλογή είναι Ο ή ο τότε σταματάει η επανάληψη
ΜΕΧΡΙΣ_ΟΤΟΥ Επιλογή='Ο' Ή Επιλογή='ο' 
ΜΟ <-- Άθροισμα/Πλήθος 
ΓΡΑΨΕ 'Άθροισμα =' , Άθροισμα 
ΓΡΑΨΕ 'Μέσος όρος =', ΜΟ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This