Επιλογή Σελίδας

Δίνονται τα παρακάτω τμήματα αλγορίθμων.

1.
Ι <- 0
Όσο Ι <= 9 επανάλαβε
    J <- I
    Όσο J <= 9 επανάλαβε
        Γράψε 'Α' 
        J <- J + 1 
    Τέλος_επανάληψης 
 Ι <- Ι + 1 
 Τέλος_επανάληψης

2.
Ι <- 0
Όσο Ι < 10 επανάλαβε
    Γράψε 'Α' 
Τέλος_επανάληψης

3.
Ι <- 0
Όσο Ι > 0 επανάλαβε
    Γράψε 'Α'
    Ι <- Ι + 1 
Τέλος_επανάληψης

4.
Για Ι από 0 μέχρι 4
    Γράψε 'Α'
    Για J από 0 μέχρι 6
        Γράψε 'Α' 
    Τέλος_επανάληψης 
Τέλος_επανάληψης

Για καθένα από τα τμήματα αλγορίθμων, να γράψετε στο τετράδιό σας τον αριθμό του (1 έως 4) και, δίπλα, πόσες φορές θα εμφανιστεί το γράμμα Α κατά την εκτέλεσή του.
Μονάδες 8

ΛΥΣΗ

  1. Το γράμμα A θα εμφανιστεί 55 φορές
  2. Το γράμμα A θα εμφανίζεται επ’ άπειρον (ατέρμων βρόχος)
  3. Το γράμμα A δε θα εμφανιστεί καμία φορά
  4. Το γράμμα A θα εμφανιστεί 40 φορές
Share This