Επιλογή Σελίδας

Θέμα Β, Ερώτημα 1, 2013, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Παράγοντες
Διάβασε
α k<- 2
Όσο α>1 επανάλαβε
Αν
α mod k = 0 τότε
Εμφάνισε
k
α<-α div k
Αλλιώς

k<-k+1
Τέλος_αν
Τέλος
_επανάληψης
Τέλος
Παράγοντες

Να σχεδιάσετε στο τετράδιό σας το αντίστοιχο διάγραμμα ροής.

Μονάδες 10

Ερώτημα 2, Θέμα Β, 2011, Επαναληπτικές, Ημερήσια

Δίνεται ο πίνακας Α τεσσάρων στοιχείων με τιμές:
Α[1]=3, Α[2]=5, Α[3]=8, Α[4]=13 και το παρακάτω τμήμα αλγορίθμου:
i <- 1 j <- 4
Όσο i<=3 επανάλαβε
πρόχειρο <- Α[j]
A[j] <- Α[i]
Α[i] <- πρόχειρο
Γράψε   Α[1], Α[2], Α[3]
i <- i + 1
j <- j – 1
Τέλος_επανάληψης
Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανισθούν κατά την εκτέλεσή του.
Μονάδες 9

Τα θέματα σε pdf, 2011, Επαναληπτικές, Ημερήσια

Παράδειγμα 8, Βιβλίου, Επαναληπτική είσοδος στοιχείων

Να γραφεί αλγόριθμος που να διαβάζει ένα άγνωστο πλήθος αριθμών και να εμφανίζει τον κάθε αριθμό.
Το πρόβλημα αυτό παρουσιάζει την εξής ιδιομορφία: ενώ φαίνεται ότι θα χρησιμοποιηθεί για τη λύση του κάποια επαναληπτική διαδικασία, δεν προσδιορίζεται ο τρόπος τερματισμού της. Καταρχήν, λοιπόν, ας εξετάσουμε τον αλγόριθμο που εκτελεί ένας άνθρωπος, όταν αντιγράφει κάποιους αριθμούς, όπως για παράδειγμα όταν συγκεντρώνονται τα έξοδα από διάφορους λογαριασμούς. Ο αλγόριθμος αυτός είναι:
Βήμα 1. Διάβασε έναν αριθμό
Βήμα 2. Γράψε τον αριθμό
Βήμα 3. Επανάλαβε τη διαδικασία από το βήμα 1.
Ο αλγόριθμος αυτός έχει μια ατέλεια, δεν διαθέτει τρόπο τερματισμού (ατέρμων βρόχος). Η έλλειψη αυτή είναι φυσική, εφόσον ο αλγόριθμος εκτελείται από έναν άνθρωπο. Αυτός θα σταματήσει να γράφει, όταν δεν υπάρχουν πλέον άλλοι αριθμοί. Ωστόσο είναι δυνατόν να διορθωθεί αυτή η ατέλεια, αν το βήμα 3 λάβει την εξής μορφή:
Βήμα 3. Αν υπάρχουν άλλοι αριθμοί, επανάλαβε τη διαδικασία από το βήμα 1, αλλιώς σταμάτησε.
Ο αλγόριθμος τώρα είναι σωστός και μπορεί να εκτελεστεί και από μία μηχανή. Όμως έχει ένα άλλο μειονέκτημα: ο τερματισμός γίνεται μέσα από την εντολή Αν … τότε … αλλιώς …, πράγμα που δεν συνιστάται και πρέπει να αποφεύγεται, γιατί εύκολα μπορεί να χάσει ο προγραμματιστής τον έλεγχο της ροής του προγράμματος και να οδηγηθεί σε λάθος. Για την άρση του μειονεκτήματος αυτού πρέπει να χρησιμοποιηθεί μία εντολή επαναληπτικής διαδικασίας, όπως η εντολή Όσο…επανάλαβε. Ο τελικός αλγόριθμος είναι ο εξής:
Αλγόριθμος Παράδειγμα8
Διάβασε x
Όσο x > 0 επανάλαβε
Εμφάνισε x
Διάβασε x
Τέλος
επανάληψης
Τέλος Παράδειγμα_8

Στον προηγούμενο αλγόριθμο η επαναληπτική διαδικασία τερματίζεται, όταν διαβασθεί ένας αρνητικός ή μηδενικός αριθμός. Δηλαδή, θεωρείται ότι οι εισαγόμενοι αριθμοί πρέπει να είναι θετικοί. Αν αυτό δεν συμβαίνει, τότε μπορεί να χρησιμοποιηθεί ως συνθήκη τερματισμού οποιαδήποτε συγκεκριμένη τιμή έχει συμφωνηθεί, ότι θα χρησιμοποιείται για το σκοπό αυτό, π.χ. η 999999. Προφανώς αυτή η τιμή δεν μπορεί να ανήκει στις εισαγόμενες τιμές. Στην περίπτωση αυτή η εντολή Όσο…επανάλαβε θα γραφεί ως εξής:

Όσο x ≠ 999999 επανάλαβε

Παρατήρηση: Ο βρόχος επανάληψης μπορεί να μην εκτελεσθεί καμία φορά, αν η πρώτη τιμή που διαβάζεται είναι αρνητική.

Παράδειγμα 12, Βιβλίου, Πολλαπλασιασμός αλά ρωσικά

p12kef2bmΑς θεωρήσουμε την πράξη του πολλαπλασιασμού δύο ακεραίων αριθμών και ας θυμηθούμε πώς αυτή υλοποιείται χειρωνακτικά. Τοποθετούμε, λοιπόν, τους δύο αριθμούς τον ένα κάτω από τον άλλο και πολλαπλασιάζουμε κάθε ψηφίο του κάτω αριθμού με όλα τα ψηφία του επάνω αριθμού. Πιο συγκεκριμένα, για κάθε ψηφίο του κάτω αριθμού παράγεται ένα μερικό γινόμενο, ενώ τα μερικά γινόμενα τοποθετούνται το ένα κάτω από το άλλο με μία μετατόπιση από τα δεξιά προς τα αριστερά καθώς θεωρούμε διαδοχικά τα ψηφία των μονάδων, των δεκάδων, των εκατοντάδων κ.λπ. Στη συνέχεια γίνεται η πρόσθεση των επιμέρους γινομένων, αφού τα τοποθετήσουμε στην κατάλληλη διάταξη όπως φαίνεται στο σχήμα 2.7. (περισσότερα…)

Παράδειγμα 5, Κεφάλαιο 2, Τετράδιο Εργασιών, Φοίτηση στο Πανεπιστήμιο

Σε κάποια Σχολή υπάρχει ένα 3ετές Τμήμα με διαφορετικό αριθμό φοιτητών/φοιτητριών ανά έτος φοίτησης. Συνολικά το Τμήμα αυτό έχει 200 φοιτητές. Να σχεδιασθεί ένα διάγραμμα ροής και να γραφεί ένας αλγόριθμος που θα διαβάζει το έτος κάθε φοιτητή του Τμήματος και θα υπολογίζει τον αριθμό των φοιτητών για κάθε έτος φοίτησης.

Λύση: (περισσότερα…)

ΔΣ4, Κεφάλαιο 2, Τετράδιο Εργασιών

Δίνεται ο παρακάτω αλγόριθμος:

Αλγόριθμος Ελεγχος_Ανάθεσης
 Διάβασε x
 Όσο x > 1 επανάλαβε
         Αν x mod 2 = 0 τότε      ! Αν χ είναι άρτιος τότε
            x ← x/2               ! Αλλαγή σε DIV για να εκτελεστεί στη ΓΛΩΣΣΑ
         αλλιώς 
            x ←3*x+1
        Τέλος_αν
        Γράψε x                   ! Πίνακας τιμών μεταβλητής
  Τέλος_επανάληψης                       
 Αποτελέσματα // x //
 Τέλος Ελεγχος_Ανάθεσης
 Να γράψεις τα αποτελέσματα αυτού του αλγορίθμου για x=13, x=9 και x=22. Τι παρατηρείς;

Λύση:  (περισσότερα…)

Θέμα Α, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη.

  1. Ένα δομημένο πρόβλημα είναι επιλύσιμο.
  2. Η λογική έκφραση Χ ΄Η (ΟΧΙ Χ) είναι πάντα αληθής για κάθε τιμή της λογικής μεταβλητής Χ.
  3. Ο αλγόριθμος της σειριακής αναζήτησης χρησιμοποιείται αποκλειστικά σε ταξινομημένους πίνακες.
  4. Όταν το πλήθος των επαναλήψεων είναι γνωστό, δεν μπορεί να χρησιμοποιηθεί η εντολή επανάληψης Όσο … Επανάλαβε.
  5. Ο πίνακας είναι μία δομή που μπορεί να περιέχει στοιχεία διαφορετικού τύπου.

Μονάδες 10

Θέμα Β, Ερώτημα 1, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου σε μορφή διαγράμματος ροής:

aepp_2011_imerisia

Να κατασκευάσετε ισοδύναμο τμήμα αλγορίθμου σε ψευδογλώσσα.

Μονάδες 10

Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, Ερώτημα 2, 2011, Μαΐου-Ιουνίου, Ημερήσια

Δίνεται τo παρακάτω πρόγραμμα και ένα υποπρόγραμμα:

Πρόγραμμα ΘέμαΒ Διαδικασία Διαδ(w,z)
Μεταβλητές Μεταβλητές
Ακέραιες: z,w Ακέραιες: z,w
Αρχή Αρχή
z <- 1 w <- w+z
w <- 3 z <- z+2
Όσο z<=35 επανάλαβε Γράψε z
Κάλεσε Διαδ(z,w) Τέλος_Διαδικασίας
Γράψε z
Τέλος_επανάληψης
Tέλος_Προγράμματος

Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του προγράμματος με τη σειρά που θα εμφανιστούν.

Μονάδες 10

 Τα θέματα σε pdf, 2011, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Β, 2010, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι γραμμές. Θεωρήστε ότι οι τιμές που εισάγονται είναι ακέραιες και μεγαλύτερες του μηδενός.

  1. ΔΙΑΒΑΣΕ x, y
  2. ΑΝ x < y ΤΟΤΕ
  3. z <- x
  4. ΑΛΛΙΩΣ
  5. z <- y
  6. ΤΕΛΟΣ_ΑΝ
  7. ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
  8. z <- x MOD y
  9. x <- y
  10. y <- z
  11. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Β1.  Να αναπαραστήσετε τμήμα αλγορίθμου με διάγραμμα ροής το παραπάνω

Μονάδες 6

Δίνεται το ακόλουθο υπόδειγμα πίνακα τιμών:

αριθμός γραμμής x y z
1 150 35

Στη   στήλη   με   τίτλο   «αριθμός   γραμμής»   καταγράφεται   ο αριθμός γραμμής της εντολής που εκτελείται. Στη   συνέχεια   του   πίνακα   υπάρχει   μια   στήλη   για   κάθε μεταβλητή του αλγορίθμου.

Να μεταφέρετε τον πίνακα στο τετράδιό σας και να τον συμπληρώσετε, εκτελώντας τις εντολές του τμήματος αλγορίθμου για x = 150 και y = 35 ως εξής:

Για κάθε εντολή που εκτελείται να γράψετε σε μία νέα γραμμή του πίνακα τον αριθμό της γραμμής της και το αποτέλεσμα της εκτέλεσης της εντολής.

Σημείωση:   Στον πίνακα τιμών έχει συμπληρωθεί η εκτέλεση της πρώτης εντολής του αλγορίθμου.

Μονάδες 10

Β3. Να μετατραπεί η δομή ΟΣΟ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ του παραπάνω αλγορίθμου σε ισοδύναμη με τη χρήση της δομής ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ… ΜΕΧΡΙΣ_ΟΤΟΥ.

Μονάδες 4

Τα θέματα σε pdf, 2010, Επαναληπτικές, Ημερήσια

Υποερώτημα α, Ερώτημα 2, Θέμα Α. 2009, Μαΐου-Ιουνίου, Ημερήσια

Έστω πρόβλημα που αναφέρει: «…Να κατασκευάσετε αλγόριθμο που θα ζητάει τις ηλικίες 100 ανθρώπων και να εμφανίζει το μέσο όρο ηλικίας τους…». Δίνονται οι παρακάτω    προτάσεις. Για κάθε μία πρόταση να γράψετε στο τετράδιό σας το αντίστοιχο γράμμα και δίπλα τη λέξη ΣΩΣΤΟ ή ΛΑΘΟΣ, αν θεωρείτε ότι η πρόταση είναι σωστή ή λανθασμένη αντίστοιχα.

α.   Πρέπει να χρησιμοποιηθεί πίνακας.
β.    Είναι δυνατόν να χρησιμοποιηθεί πίνακας.
γ.    Είναι δυνατόν να χρησιμοποιηθεί η εντολή  Όσο.
δ.    Είναι δυνατόν να χρησιμοποιηθεί η εντολή Για.
ε.    Η εντολή Για είναι η καταλληλότερη.
Μονάδες 10

ΛΥΣΗ

Β.1. 1 – Λ, 2 – Σ, 3 – Σ, 4 – Σ, 5 – Σ

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια